Jump to content

metarog

Members
  • Content Count

    328
  • Joined

  • Last visited

Everything posted by metarog

  1. Okay, two things here that might give you hope... One of mine was doing the same thing and I moved the pins in the cart connector a little toward the center by wedging a tiny eyeglass screwdriver behind each pin and pushing very carefully. Lo and behold now all games load just fine. So that might be your issue as well. Secondly, if you can't repair the cart connector let me know and I will try to desolder one from my dead board. I will check continuity first so I'm sure it is not broken. I can then send it to you for shipping cost which should be 2 dollars or so or just send me an old video game you dont want. I just sent another AA member a keyboard from the same dead unit.
  2. I would say that is progress as at least your getting video unlike mine. Press the reset button and see if there are any changes on the screen. I had this happen to one of my older O2s and it turned out to be a bad 8048. The changes can be subtle but I usually look around the "battleship" thing on the left. Let me know what if anything happens.
  3. I just tried one of mine too and got 4.9v so it seems like the power is good. Just in case I took out the power switch and the connections were filthy so I cleaned them up but still black screen. I wonder if there is a short being created somewhere after the 8048 chip. I think next I'll test the continuity between the 8048 and the cart connector and see if anything is amiss.
  4. I have a couple of dead O2s and I'd be happy to send you a keyboard. PM me your addy and I'll send you the shipping amount plus $5.00 for the keyboard. Hope that will do, Roger
  5. That came out amazing... Great solution to the silver finish which is almost always scratched up. I like the Odyssey2 logo you have on there too.
  6. Wow... To find all those games in the wild like that is tough and I rarely see Demon Attack and Atlantis even on EBay for a reasonable price. Congratulations and good luck on finding that Power Lords!
  7. I just picked this up for the collection... Pretty rare Vid Lid Plus for the O2! Looks nice on my testing console and is handy for keeping dust off and has a space for games and documentation.
  8. It wasn't the RF on mine either as I switched it with the one in my working unit and got the same results.
  9. I Am having the same issue with one of my backup units and can't figure it out either. As to the rf shield... You can cut it off as you don't need it... in fact later O2s didn't even have it. Just make sure there is a ground from the board to the rf box. I know that on my unit the problem is not the socketed chips as I put them in a working unit and they work fine. I suppose it could be one of the soldered chips but it don't know how to test them. I am pretty sure it is not the cartridge connector either as I get the same screen whether a game is in or not and on my working units I get the messed up blocky screen without a game in. Good luck and if you do figure it out on please let me know.
  10. I am not sure if I should start another thread to ask this but it does pertain to a complete collection so here goes... Does anybody know exactly what documentation was included with the older O2 consoles? I know there is the "Wonderful World of Odyssey" packet and that is pretty well documented but I don't think the early models included it. I have had several and most included the following: Instruction Manual Warranty sheet Service sheet Registration card Some included one of the game catalogs too. Was there anything else?
  11. Wow... What a great collection. So jealous of the Odyssey Scorepad! All those Homebrews are neat as well. Congratulations and keep us updated of any additions.
  12. I am pretty sure this came with CX-10s and "Sears" on the hex disc and on the paddles instead of Atari. It also came with the gray power supply and Target Fun was definitely in the box.
  13. Will do... I am always on the look out for stuff I don't have.
  14. I got lucky and won a cheap lot with the cover in it a few months back.
  15. I was organizing my O2 stuff and figured I'd take a few pics to share with everyone...
  16. It is great to know there are other members of the complete O2 club! I see a lot online about completing Sega, Nintendo, Intellivision etc, but very little on the old O2. Good to hear there more fans out there. Thanks for recommendation on the PB games... I'll get them eventually and the multicart as well.
  17. Yikes, that is about double what I paid... In fact that is probably what I have in for my whole set as I got most of my collection in one huge lot for less than $80 including Atlantis, The Voice, and almost 40 different games. PS. Thanks for the PM Scotty... I'll contact the guy you suggested when I have some extra cash.
  18. I just completed my U.S. set CIB including the Imagic carts and Power Lords. I also have 2 CIB consoles(one has detachable joysticks) and The Voice along with a lot of extra goodies. This was a fun set to collect for with the great box art and very retro games. The Parker Brothers games are on my radar if I can find them complete and cheap.
  19. Very Nice... Looks to be the Canadian edition. PM me with what you are looking for in trade as I might have it. I assume it has all the warranty paperwork and manual inside?
  20. Ok, here are the pics... Looks in decent shape with no broken posts but it is missing all the rubber feet but you can just take those off your old one. I don't know what to charge for this so if you have some video game related stuff you want to trade for this let me know as I have a bunch of systems. Even if you have manuals and inserts or whatever let me know. Hope this helps, Roger
  21. I have a loose bottom and top from an Inty with a bad board. I can shoot you a pic tomorrow if you are still interested.
  22. Open up the console and clean the cartridge slot with an old toothbrush and some contact cleaner... then wipe down every pin with a q-tip. If that doesn't work check to make sure all the pins are making contact with the game (not too separated from each other). If no change then check under the cartridge slot and see if any solder is missing on the pins.
  23. I just wanted to say thank you to whoever posted this as it fixed my continual fire issue on the right. I had to lift pin 6 and 7 out (a real pain to do btw) and bridge the pads with some solder. It now fires only when the joystick button is pressed. Muchas Gracias!
  24. Open up the O2 and look at he ribbon connecting the Keyboard to the main board. If it doesn't seem broken then carefully pull it out from the connector and clean the ends with contact cleaner or rubbing alcohol and then plug it back into the connector. I have had this happen to me once and that solved it.
×
×
  • Create New...