Jump to content

fabrice montupet

Members
  • Content Count

    960
  • Joined

  • Last visited

  • Days Won

    1

fabrice montupet last won the day on November 24 2016

fabrice montupet had the most liked content!

Community Reputation

1,746 Excellent

3 Followers

About fabrice montupet

  • Rank
    Dragonstomper

Contact / Social Media

Profile Information

  • Gender
    Male
  • Location
    Burgundy - France
  • Interests
    Old computers, especially TI-99 and Apple II computers
    Electronic, websites development, programming, graphism, sculpt, draw and many other things.

Recent Profile Visitors

7,070 profile views
  1. I suppose the Ti994w has problem since this new version of XB256 works fine both on the real hardware and with Classic99.
  2. There is a typo error in my previous message, I wanted to write "it has been cleared from memory".
  3. A critical bug with XB256 XB29GEM20220623 (already discovered with the previous version ). I don't know how you'll be able to correct it as the information about this bug are thin: Sometimes, when I launch a XB256 program (no matter which of them), I get error messages like "MEMORY FULL" or "STRING-NUMBER MISMATCH" Without modify the program I run it again one, two or three times and... it works! But sometimes, it's worse... I get a "LINE NOT FOUND IN xxxx" and when I list the program, it has be cleared from memory.
  4. A major bug found using XB256 XB29GEM20220623 (strangely the folder found in it is called XB29GEM20220317) : In video native mode (32 columns), I write this little program (it's just an example, it could be everything else) : * Extended Basic v2.9 G.E.M. >10 CALL CLEAR >20 FOR T=1 TO 10000::CALL LINK("DISPLY",10,10,str$(t)):: NEXT T All is OK, the program counts and displays the T value. I break the program, no needs that it reaches 10000. Then, I decide to use the video 40 columns mode: >CALL EDIT40 It's still OK, the editor uses now the 40 columns mode. Then I run again the program and stop it after a few seconds. I obtain: * BREAKPOINT IN 20 > The editor has hanged.... The problem can also be reproduced if I use CALL EDIT80 (video 80 columns mode).
  5. An other (minor) bug found: Sometimes, when I launch the emulator, the menu "Modules" is absent: I only get the menus bar "File/View/options/Interrupt" instead of "File/Modules/View/options/Interrupt" and, by consequence, only the "TI Basic" choice is proposed, the selected module during the previous emulator launch has disappeared. To correct the problem, I quit the emulator and launch it again.
  6. That's done 🙂 Note that when I pressed the key "!" nothing appeared on the screen.
  7. ... And it changes everything! 🙂 I set the delay between TI keyboard scans to 1206us and it works great! Now the emulator reacts like a charm in TI Keyboard mode with "all free CPU time" enabled. Thank you so much Fred. At this point, I am fulfilled. Getting an AZERTY PC keyboard layout in TI Keyboard mode would be the cherry on the cake but absolutely non essential. Nerveless, if you like to add this feature to your emulator, this weekend I will be happy to create the list with scan codes for all the AZERTY keys. Thank you again.
  8. ... But when I use the "TI Keyboard" mode with the "all free CPU time" option, I always have a problem: in XB Editor mode The keys pressed are randomly repeatedly displayed And it seems that the time before a character is displayed again after a longer keypress is too short. So, for the moment, I will only use the "PC Keyboard" mode even it can't handle all the TI keyboard modes,sadly. I am very sorry for all the trouble I give you to correct your emulator. I have found some other bugs but I prefer to distill them for fear of you end to hate me 😛
  9. Thank you Fred! This new version works fine 🙂 I have tested all the keys and they return the good character. I'm sorry, I have forgot to answer to your question about my keyboard model. For programming, I use a laptop Lenovo P50 i7 2.7GHz ,32Go RAM, 2 x 512Gb RAID SSD, NVIDIA Quadro M2000/4 Gb, 15.6" IPS screen Ultra HD 4K (3 840 x 2 160), MS-Windows11Pro with a french keyboard (so AZERTY). Here is a picture of the keyboard:
  10. Things are changing over the versions. After tries and tries, I can conclude that 3 keys still have problem: ";" ":" "$" As I said in my previous message: - Pressing the ";" key gives ".; on the screen - Pressing the ":" key gives "/:" In addition, I noticed that: - Pressing the "$" key gets a strange thing but not at each time: the 1st press gives well "$" on the screen but pressing the "$" key a second time gives ";$". But most of the time I get ";$" directly on the screen when I press the "$" key. The Debugger windows gives this after I reset the emulator, I press the "Space" key to get the main screen, I press the "1" key for TI Basic, then the ";" key then the ":" key, then the "$" key and I press the "$" a second time. Keyboard KEY: ' ' >20 032 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_CHAR Keyboard KEY: '1' >31 049 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_CHAR Keyboard KEY: '.' >2E 046 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_KEYDOWN Keyboard KEY: ';' >3B 059 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_CHAR Keyboard KEY: '/' >2F 047 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_KEYDOWN Keyboard KEY: ';' >3B 059 : Caps=off Shft=on Fnct=off Ctrl=off Msg=WM_CHAR Keyboard KEY: ';' >3B 059 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_KEYDOWN NOT ALLOWED Keyboard KEY: '4' >34 052 : Caps=off Shft=on Fnct=off Ctrl=off Msg=WM_CHAR Keyboard KEY: ';' >3B 059 : Caps=off Shft=off Fnct=off Ctrl=off Msg=WM_KEYDOWN Keyboard KEY: '4' >34 052 : Caps=off Shft=on Fnct=off Ctrl=off Msg=WM_CHAR
  11. I launch the emulator, enable the "All free time CPU" option and press 1 for TI Basic. When I press the key ";" I get a ".;" and when I press the key ":", I get "/:". Here is the debug window
  12. I am happy to use your emulator 🙂 and I appreciate a lot your efforts and your availability to make it better and better. I tried this new version and I always have the problem with the keys ":", ",", ";" and "$". Note that I use the ti994w62d as is, without importing any files from previous versions and that I also encounter the problem even if I disable the "Use all free CPU time" after enabled it.
  13. I am really sorry but this new version causes problems too: in PC Keyboard mode the ".","+","-","/" on the numeric keypad doesn't work anymore, pressing the "$" key causes display ";$", the "<>" key no longer works too.
  14. Hebdogiciel, one the best french revue for years 80 computers ! 🙂
  15. With my method I thought that it was the best way to capture two keys pressed (one in each side of the keyboard) at the same time. Thank you for the precision. For me, the "use all free CPU time" is the best feature of your emulator for programs development because it permits to directly simulate the behavior of a XB256 program when compiled . Of course, for that, I have calibrated the speed of my Core i7 CPU computer to execute the emulator (with "use all free CPU time" enabled) at a speed that is equal to the speed a compiled program runs on a real TI-99/4A. With this manner, in emulation, when I modify my program by adding functions I can directly see if it will be playable at the speed that I desire on the real hardware. (I hope that I was clear, my English has some limits, easily reached 😛)
×
×
  • Create New...