Jump to content

dalves

Members
  • Content Count

    176
  • Joined

  • Last visited

Community Reputation

51 Excellent

About dalves

  • Rank
    Chopper Commander
  1. Thanks again for the help. I was able to use the composite palette and jzintv looks great again.
  2. Thanks for the info. I was looking at the link about using a custom palette. I was wondering if this is data I would add to my current batch file or does this need to be it's own file? FWIW, I've attached pictures showing the difference in colors between my current jzintv and MAME. The MAME colors seems to be more consistent with what I get from jzintv on my Raspberry Pi, or when I'm playing my Intellivision console.
  3. On my gaming computer, and my test computer, I'm using the jzintv version from 12/25/2018. The colors look fine when I use my test computer through it's monitor, but the gaming PC colors look off when going through my HDTV. I would have assumed this would mean the TV was off or the colors on my video card were off. However, when I run the same Intellivision ROMS on my gaming computer through MAME, the colors are perfect. I'll certainly read more on the link you sent about defining your own color palette, but if the new version does have updated colors, is there an easy way to revert back to the previous color palette, or is it build into the jzintv.exe?
  4. Just a quick follow up. I bought a new gaming computer with an AMD Ryzen 5 with Vega 11 graphics. I installed jzintv but was still having problems with it stretching even when maintaining aspect ratio on the video card settings. I found out this had been a glitch in AMD's Radeon settings software, and when I updated it, it had been fixed. Jzintv is now working in 4:3. The only problem now is the colors are slightly off. The "Tan" color is greener and the "Brown" is dark green. All other emulators look like the colors are correct. I've tried adjusting the colors in my display settings, but when Intellivision looks good, every thing else looks way off. It's only happening on this new computer, so it has to be a setting thing. I'll keep tweaking it and see if I can find a good balance. Thanks for all the help getting it setup in 4:3 with the correct border.
  5. Right now I am using it on a "Test" computer that is an old Dell with a stock video card. I'll try moving it to another computer and see what I can find with the video settings. I know when I use MESS and load an Intellivision game, it will go to full screen, but maintain the 4:3 ratio. The same is true if I use Stella or Nestopia. It seems that JZINTV and Nostalgia 5 are the only ones stretching to 16:9. That is why I was assuming it wasn't a video card setting, but I will try on another computer and see.
  6. I am using my computer monitor which is widescreen. I have changed the batch file to read -z1024x768,8. In windowed mode, it is the 4:3 ratio. If I run it in full screen, it stretches it to 16:9.
  7. So I erased everything I had and started with a new jzintv install and created a new batch file. I am able to get it running with the batch file, but I still can't get it to have a 4:3 ratio when full screen. Below is the batch file I am using. "C:\Program files\jzintv\bin\jzintv.exe" -z1024x768, -f1 -v1 -b10 %1
  8. Does anyone know if the ROM is available for purchase?
  9. It appears there is something wrong with the path. I was trying to do this off the desktop of my work computer just to see if I could get it running, but must have screwed something up in the batch file. I was also trying to eliminate the keyboard hack file just in case something was messed up there. I'll try it again from scratch and see what I can do. I'm just hoping to have jzintv run at full screen with the 4:3 ratio. I have just moved my jzintv folder to C:\Program files. I tried doing a new batch file, but having the same results. My current batch file is below. "C:\Program files\jzintv\bin\jzintv.exe" -z3 -f1 -v1 "--kbdhackfile=C:\Program files\jzintv\kbdhackfile.kbd" %1 pause I used a screen capture to record the error as it would show only as the command prompt window was closing. It says... C:\Program Files\jzintv\rom>C:\users\dalves\Desktop\bin\jzintv.exe -z3 -x0 --kbdhackfile=swappable.kbd "C:\Program Files\jzintv\rom\KINGMOUN.ROM" The system cannot find the path specified.
  10. Sorry for the very delayed response. I am still having trouble trying to configure jzintv on my Windows computer. I've tried creating a batch file following the post below. However, when I right click on a ROM and use "Open With" and point to the batch file I made, the command prompt window opens for a second and closes. If I to the same thing with the ROM, but select the jzintv.exe instead, it launches the game but it is in the 320x200 window. I am quite certain this is something stupid that I am missing or doing wrong. For Windows use a text editor like notepad and create a batch script file (e.g. jzintv.bat) with a single line like the following example. Obtain a "keyboard hackfile" or create an empty text file named 'kbdhackfile.kbd' for now, or just remove that part of the command. Use this batch file in the above instructions to start a game. "path\to\jzintv.exe" -z3 -f1 -v1 "--kbdhackfile=path\to\kbdhackfile.kbd" %1
  11. I feel I've almost got it... When I added "-s0" to the command line, then none of my Intellivision ROMS would launch. I found the ecs.bin file on my computer and added it to my Raspberry Pi. Now my Intellivision ROMS work. I removed the "-s0" line and the Intellivoice games launch in ESC mode. If I add the "-s0" back to the command line, the games now load directly. Space Patrol works fine, and the Intellivoice games launch. However none of the Intellivoice games have the Intellivoice voices. There is still sound in those games, but it's missing the voices. I do have the "exec.bin, grom.bin, ivoice.bin, and ecs.bin in the Retropie BIOS folder. Just as a heads up, below is the config lines I currently have. jzintv = "/opt/retropie/emulators/jzintv/bin/jzintv -z1 -b10 -p /home/pi/RetroPie/BIOS -q %ROM%" default = "jzintv"
  12. So I upgraded the old version of jzintv that was on my Raspberry Pi with the newest Linux version from the website. The -b setting looks great and it now looks like what I am used to seeing with Intellivision games. That said, all the games load and play great with the exception of the Intellivoice games and Space Patrol. With the updated jzintv files, they won't run. If I use the older jzintv files, the intellivoice games and Space Patrol work perfectly. I'm trying to figure out what I may be missing with the upgrade.
  13. I am interested to try this, but wondering if there is a specific place I need to enter the -b flag in the retropie config I'm using. Below is what I currently have. I didn't know if I would add it between the -z1 and -p? jzintv = "/opt/retropie/emulators/jzintv/bin/jzintv -z1 -p /home/pi/RetroPie/BIOS -q %ROM%" default = "jzintv"
  14. I will check various games tonight to check the extended scroll boarder. The thing that makes me wonder if it's that, is the games that show the border offset using JZINTV on my Raspberry Pi, have perfectly aligned borders when I use the same ROM in my MESS emulator. I will check, but my memory is that every game with a colored boarder used on my Raspberry Pi had the border offset.
×
×
  • Create New...