Jump to content

jwild

Members
  • Content Count

    228
  • Joined

  • Last visited

Community Reputation

264 Excellent

About jwild

  • Rank
    Chopper Commander

Profile Information

  • Gender
    Male
  • Location
    Loveland, Colorado USA

Recent Profile Visitors

2,699 profile views
  1. I'm trying to export map data from Magellan in order to help make an Extended Basic game. Just playing with the tools right now. I'm using version 3.3.1. I created some simple characters and tested exporting them (128-143): I exported them as basic data and this seems fine: I exported as basic program. Also seems fine: Now extended basic program. Also seems fine: same with xb256 program: Next test was to create a screen using some normal characters and some of the characters I created: Then tested exporting basic data: The bottom of the screen looks right with all the custom characters (128-143). I can also see some other custom characters in the data above. But the majority of the screen data is "32" (space). I don't see any of the "A" or "B" or other normal characters in this data. Then tried exporting as basic program: I don't see any of the characters on the left or right side of the screen (columns 1,2, 31, 32). I think this is because PRINT can't write there. The "Optional" DATA looks good: And of course in Classic99: Now export XB program: This looks similar to the basic data above. The bottom of the screen looks right with all the custom characters (128-143). I can also see some other custom characters in the data above. But the majority of the screen data is "32" (space). I don't see any of the "A" or "B" or other normal characters in this data. Now in Classic 99 (XB): A big black screen. Breaking the program: Suspecting an issue with this line: and changing the "1" (transparent) to "4" (light green) rerunning it in Classic 99: I can see it now, but it's missing those "A" and "B" and "$" etc. That's all for now. Thanks for reading.
  2. HP-41. Best calculator ever. Sent from my iPhone using Tapatalk
  3. ********************************************************************************* ********************************************************************************* ********************************************************************************* TI-99/4A High Score Challenge Month: December, 2019 Game: Knight Lore, converted by @Asmusr I have never played this game before. It looks interesting. The controls are going to take some getting used to. Please see this thread for more info and files for playing: Good luck everyone.
  4. Eric in Monsterland High Scores: 1. jwild - 7875 2. Firefly - 5414 3. Opry99er - 5171 4. Chue - 1137 Thank you to retrospect for creating the game! The more I played it the more I liked it.
  5. 7875. This might be the best I can do. Sent from my iPhone using Tapatalk
  6. I moved some files around to use the "ISABELLA6" folder instead of "ISABELLA99" and can confirm that it works much better in Classic99. You can hit ENTER around 22 times (like the docs say) and it will compile and run. Very cool. Thank you senior_falcon. Thanks also to Sinphaltimus for the video on how to make a filename.bin file out of the compiled EA5 file for finalgrom99. Learning lots from you guys.
  7. Thank you senior_falcon. However, "clearly" isn't so clear. Archive is called "ISABELLA6.zip". When you extract it, it is a folder called "ISABELLA6". Inside that folder is two other folders as you clearly described in "Using XBGDP". There is no folder called "ISABELLA". Just "ISABELLA6" (top level), "ISABELLA99", and "DOCS". But I think I know what you mean now. use the files in the "ISABELLA6" folder and not the subdirectory "ISABELLA99".
  8. I think the problem is in step 17. It doesn’t seem to like HELLO-S as the file name. I played around a while and got it to compile, assemble, and run. You just have to type in the right file names with extensions. Here is a cheat sheet I made to help me understand and remember the relations of the file names and the tools: Sent from my iPhone using Tapatalk
  9. I feel silly posting this, but I need help with the XB Game Dev Pkg "hello" example. I have downloaded the latest Isabella6.zip archive from the pinned thread. I have extracted it and printed out the documentation files. I have downloaded the latest classic99 emulator 399.013 I am following the "Using XBGDP.pdf" file. I have copied the ISABELLA99 folder from the archive to the classic99\ folder (alongside DSK1, DSK2, etc as the help describes) I have changed the settings for DSK1 in classic99 to point to .\ISABELLA99\ and turned on "Write DV80 as Windows Text" and made sure "Write DF80 as Windows Text" is off. In classic 99, I have started XB and received the introductory "XB Game Developers Package "Isabella"" menu I selected "Extended Basic" I commanded "OLD DSK1.HELLO" I can list it and run it and see how slowly "Hello World!" scrolls across the screen. Break with f4 Options CPU Throttling - CPU Overdrive SAVE DSK1.HELLO SAVE DSK1.HELLO-M,MERGE RUN "DSK1.LOAD" It goes back to the "Isabella" menu with prompt on COMPILER (enter) Compiler window shows up. "XB merge file to compile?": DSK1.HELLO-M Assembly file to create?: DSK1.HELLO-S Runtime routines are on DSK1 Put runtime in low memory? N Proceed?: Y Compiler does some stuff and then "Isabella" menu shows up again, this time with prompt on ASSEMBLER (enter) SOURCE file name ?: DSK1.HELLO-S OBJECT file name ?: DSK1.HELLO-O LIST device name ?: (blank) OPTIONS ?: R Press ENTER or F8 "SOURCE - Open failure" Press ENTER or QUIT Any help would be appreciated. I will be reading the docs in the meantime. Thank you
  10. 6458. I wonder who that is in the boat. Maybe that’s Eric. Sent from my iPhone using Tapatalk
  11. Degaussed. Sent from my iPhone using Tapatalk
×
×
  • Create New...