Jump to content

mozzwald

Members
  • Content Count

    562
  • Joined

  • Last visited

Everything posted by mozzwald

  1. I build the Linux flash tool with Linux Mint 64 bit. Any Ubuntu variant would be a good choice
  2. The mac flash tool is specifically built for 10.15 Catalina and will not work with an older OS. Github can only build for the latest MacOS and so that is what we release. If you or anyone else could build for older OS versions I would be happy to make them available. https://github.com/FujiNetWIFI/fujinet-flasher
  3. finally, was able to get the site removed from the Norton blacklist. If anyone is will to provide good user reviews it would be appreciated. https://safeweb.norton.com/report/show?url=https%3A%2F%2Ffujinet.online Not sure if it's related but I read some info about Microsoft and others not liking any older hash algorithms and I was providing MD5's for the firmware binaries. Have now switched to SHA256 sums.
  4. A new firmware update is available at https://fujinet.online/download FujiNet Version: 0.5.fe08a639 Version Date/Time: 2020-12-27 21:07:58 Build Date/Time: Sun Dec 27 21:27:27 UTC 2020 Fancy New Features: * Can now skip WiFi setup in CONFIG * Disengage CONFIG disk if READ happens before STATUS is completed (meaning something else has responded to D1:) Please do not respond to this thread. If you have an issue, start a new post in the FujiNet subforum, open an issue on the github tracker or ask for assistance in Discord chat.
  5. Good call. There's nothing we can do about the antenna design other than follow their recommended design docs. Looks good, thanks Good question. I dunno, did not check consumption. I did test SIO power only, 12W Apple USB charger on with my 800XL and it worked. We need someone with that configuration to test it.
  6. Seems possible. Would need to add a configuration option that gets saved to SD card/SPIFFS. Can you please open an issue at https://github.com/FujiNetWIFI/fujinet-platformio/issues Lol, FujiFoil ™️ Glad it's working better. Now we need to figure out that Sophia Fuji problem...
  7. @MrFSL I've disabled WiFi power saving in the latest firmware build and have much better ping results. Please upgrade and test again Before --- fujinet ping statistics --- 15 packets transmitted, 14 received, 6% packet loss, time 14047ms rtt min/avg/max/mdev = 14.381/71.239/207.692/46.640 ms vs After --- fujinet ping statistics --- 15 packets transmitted, 15 received, 0% packet loss, time 14023ms rtt min/avg/max/mdev = 2.387/4.224/10.857/2.166 ms
  8. A new firmware update is available at https://fujinet.online/download FujiNet Version: 0.5.8edf468d Version Date/Time: 2020-12-19 04:49:28 Build Date/Time: Sat Dec 26 23:37:44 UTC 2020 Unbelievable Upgrades: * Host & Disk slots shown in Web admin page * Disable WiFi Power Saving for better latency Please do not respond to this thread. If you have an issue, start a new post in the FujiNet subforum, open an issue on the github tracker or ask for assistance in Discord chat.
  9. If someone figures out the cause of the problem, yes
  10. Today I have released the FujiNet v1.3 design files to our hardware github repository which fixes issues #1, #2 and #3. I also have put some up for sale at https://fujinet.online/shop along with some other knick knacks. I will be building some as I have time and put them up for sale until other vendors get going so keep checking if you are interested. Changes from v1.0: * SIO lines connected to ESP32 through two 74LS07 * P & N Channel transistors turn off 74LS07 when FujiNet is turned off separating the ESP32 from the Atari * Switch to QFN 24 CP20102 USB to UART Bridge * Hard reset button moved to SMD Snap Dome (optional) * Safe Reset button (handled in firmware) replaces Hard Reset button * New Power switch & 3D printed switch cover * Remove "always on" solder jumper * Add pull down on MOTOR line for Cassette emulation Merry Christmas!
  11. When using FujiNet with an Atari 400 or 800 you need to have the FujiNet powered externally with via the MicroUSB port. The 400/800 OS boots too fast for the fuji. The newer XL/XE machines boot slower and don't have this issue.
  12. um, no. I'd show you a picture of my desk but it's embarassing The 800XL sits almost under my laptop just below my monitor with big ugly surge protector next to laptop power brick, usb hub, router above the laptop, mess, 1050 on the other side of the laptop, cables, mess and more mess
  13. Here are my results from a v1.0 and v1.3. My router is on the 2nd floor and I also tested with the fujinets downstairs on the main floor. The v1.0 has a WROVER-B, v1.3 has a WROVER-IE (jumpered for PCB antenna). FWIW, my router is a POS Netgear WNDR3400 running DD-WRT configured with different SSID names for 2.4g and 5g. There were reports of having the same SSID name for 2.4/5g causing problems (I've always had my names different so I cannot confirm). If I get some time I will try this also. This being an atypical issue leads me to think there could be something wrong with the board, whether it be a bad component or soldering issue. I would hope your vendor is willing to at least do a swap and see if it clears up the problem, and triple check the replacement unit before shipping
  14. I've restarted the fujinet.online tnfs server if you wanna try it again just in case it's an issue there.
  15. Yep, there is only one antenna on the esp32. RF is out of my league so any insight would be helpful. I followed the Espressif design guide as best I could. Maybe adding makeshift shielding with copper or aluminum foil inside the fujinet case tied to ground would help. I would try myself, but there's no way for me to test it without a Sophia and I don't have a need for it. Glad you're able to experience the power of FujiNet now
  16. A new firmware update is available at https://fujinet.online/download FujiNet Version: 0.5.8edf468d Version Date/Time: 2020-12-19 04:49:28 Build Date/Time: Sat Dec 19 19:09:59 UTC 2020 The only change is to FujiNet CONFIG: * increase inputtable characters again because some people have ~ and | and { } Please do not respond to this thread. If you have an issue, start a new post in the FujiNet subforum, open an issue on the github tracker or ask for assistance in Discord chat.
  17. A new firmware update is available at https://fujinet.online/download FujiNet Version: 0.5.8edf468d Version Date/Time: 2020-12-19 04:49:28 Build Date/Time: Sat Dec 19 05:48:26 UTC 2020 Fanciful Fixes: * BIG BUGFIX: double density disks (ATR) now calculate correct sector offset * Modem: auto-answer can now happen during status * Modem: add RAUTOANS tool to enable/disable auto answer * Modem: Type 1 poll changed to 16 tries, from 26, handler loading now reliably works. * Modem: Backspacing too far no longer crashes modem in command mode (@mleair) * Modem: CRX now updated when somebody connects
  18. Not exactly. The hard reset button is moved to 'hidden' pads and a new Safe Reset button has been added. The firmware, however, can detect the pull up and set the button mapping correctly. Other than that, it's the same.
  19. At boot, the firmware checks for config on the SD card. If found, it copies it to the SPIFFS. Config writes are stored to both SPIFFS and SD (if available). If config is not found in SPIFFS or SD, it starts fresh.
  20. This is the v1.3 schematic which has been tested working with multiple devices on the bus including a Happy drive and at high speeds. The only issue noted so far is the 'off' SIO sound with any other SIO device on the bus (yet everything works). The sound is normal with FujiNet alone.
  21. You can download any atr from fujinet.online tnfs thru this web front end https://fujinet.online/tnfs-data/ see the networking dir
×
×
  • Create New...