Jump to content

stlouisrod

New Members
  • Content Count

    66
  • Joined

  • Last visited

Everything posted by stlouisrod

  1. Not to hijack this great thread, but I'm having an odd pixel coloring issue with a similar mod I installed from best electronics CA. Hoping the thread owner might have some suggestions... BECA has no suggestions for me. They provided a different transistor than the one used in this mod, as well as more resistors to replace original ones. I've also replaced numerous capacitors and the voltage regulator just in case the old ones were waning, but results are the same. Thanks. http://atariage.com/forums/topic/282598-best-electronics-atari-2600-composite-hack/
  2. Hardware limitation. The Atari could only execute a few assembly instructions in the time the TV beam swept sideways on a row. So by the time you loaded the accumulator with the new color value for a mushroom next to it, and moved that value to the color register, you were too far across the screen. If they had limited the number of mushrooms per row to like 8, it would have been possible. But that wouldn't have been Centipede anymore
  3. stlouisrod

    kaboom

    From the album: Best Electronics Atari 2600 Composite Hack Issues

    Instead of a black frown, he looks like he got punched in the face.
  4. stlouisrod

    stampede

    From the album: Best Electronics Atari 2600 Composite Hack Issues

    Red cows appear almost black. And the lighter red cows have yellow legs!
  5. stlouisrod

    indy 500

    From the album: Best Electronics Atari 2600 Composite Hack Issues

    Color smearing even on low-res images like the cars here.
  6. stlouisrod

    color bars

    From the album: Best Electronics Atari 2600 Composite Hack Issues

    Reds are too pink. Greens are too yellowish/orange.
  7. stlouisrod

    combat

    From the album: Best Electronics Atari 2600 Composite Hack Issues

    The red tank has a funny yellowish gun.
  8. Interesting idea. Though I don't see how the image could get any "cleaner". It's simply palette-inaccurate and occasionally corrupts side-by-side pixels depending on color combinations. Maybe you can specify what you mean by "cleaner"?
  9. So I installed the best electronics $20 composite video hack on my Atari heavy 6er, all soldering done with professional equipment, all pieces in the correct place per the 20+ page instruction manual. The RF signal before the replacement was well-saturated, and accurate, though it had noticeable streaking of color to the right of a graphic. There was also noticeable RF interference visible in games like Circus Atari, with that blue background. RESULTS: The composite video definitely has much less (practically no) signal interference common to the RF method, little to no color streaking, and a sharper more solid image with little to no dot crawl. However, no matter how much I tweaked the hack's voltage pot, and the original CLR ADJ pot on the Atari PCB, I could not get perfect reds and greens on the color bar chart. The greens were a bit weak, and the reds too pink. The acid test is Barnstorming where you should have a bright yellow plane against a nice medium green background. Instead the plane almost disappears into the background since the yellow is too close to the green. But the REAL annoyance is that in some games, a particular color combination of pixels results in a bizarre third color. For example, in Stampede, the bottom half of the red cattle (the legs) are literally YELLOW! And the deep red (brown?) cattle look nearly black. In Kaboom, all looks good until you look at the bomber's face. Instead of a smile, it looks like he's been punched in the face with a bunch of gray swiggles where his nose and mouth should be. His middle body also looks super thin, as though he lost 50lbs. And it's not just a high-res graphic mode issue. The cars in Indy 500 have a yellow double image surrounding them, which varies from barely visible to extremely annoying depending on the background color displayed. QUESTIONS: Has anyone else noticed these anomalies in a composite hack before, and if so, were you able to remedy it? Any idea where the issue is coming from (resistors, diode, transister, pot adjuster)? Would anyone in the community be interested in buying this heavy 6er from me for what I have into it ($180 for console and original Atari A/C gray power brick)? Cosmetically it's in great shape. I replaced the player 1 db9 port since pins were pushed inside it, and replaced 3 of the stickier switches with real Atari replacement switches (new old stock).
  10. Its a standard atari joystick. I've tried several.
  11. I installed your 1.07. But the 2nd port does not work the menu, even if I hold the joystick button down on startup. However, your suggestion had me try holding port 1 button on powerup, and that worked, even on the standard 1.06. So that's a pretty easy workaround. So thanks for that. You just gotta remember to mash that button every time you power up another game from the menu. I would be happy to help test any updates to this firmware that fully alleviate the issue on composite-hacked 2600s
  12. Yes, using 1.6, and SELECT and RESET are working options, thanks. The mod is supposed to only affect the video. But as we know, the 2600 is a video-timing-based machine, so it's possible the Harmony input polling routine is getting confused and thinking the joystick is a paddle. Once I launch a game, and replace the paddle with a joystick, all games play fine. It would have been nice to allow player 2 port to control the Harmony game menu as well, so folks could leave a paddle controller in that port just for menu usage, but leave a joystick in port 1 for the actual gameplay. Sure, 2 player joystick games then require some swapping after load, but for single player, it would be a nice option.
  13. Purchased the Harmony SD version, bios 1.6. Works great on my stock 4 switch woody, and DID work well on my stock 6 switch heavy sixer. However, I just installed the http://www.best-electronics-ca.com/composite mod upgrade kit on the heavy 6er, and now the joystick does not work on the menu anymore. Strangely my paddle controller AND Indy-500 steering controller DO work, though the paddle button is very hit and miss to launch games. Can the firmware be upgraded to fix this anomaly? It's very frustrating to have to put a paddle in just to select a game, then once in-game, replace it with a joystick, then repeat for next game. Is is possible a prior firmware version DOES work well with joysticks, despite having composite-modded the unit? I may replace a few of the caps on the heavy 6er PCB as part of routine maintenance, but I don't expect much change considering the Harmony worked fine before the mod. The mod involved removing the RF module, replacing 6 resistors with 4 different resistors, a diode, a transistor, and an adjustment pot that adjusts brightness/color saturation.
  14. stlouisrod

    My Games

    Games I've created on the Atari 8bit home computer system
×
×
  • Create New...