Jump to content

ngtwolf

New Members
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

12 Good

About ngtwolf

  • Rank
    Space Invader

Profile Information

  • Gender
    Male
  • Location
    Los Angeles, CA
  1. BTW, can you link to where you found that image of that card? Maybe theres something I can research there to figure out what the card type is (and maybe the pinout). The photo of the matching card, not that scan, I mean.
  2. Awesome, that definitely looks like it. I'll have to figure out the pinout to see if I can make an adapter for it though. If so, I'd like to move it over to my IIe since I don't really use the II+. Thanks so much for your help!
  3. No DB9's there except the one that is part of the Videx function strip stuck on the lid, which would connect to a videx keyboard enhancer that gets attached to the keyboard (I believe it replaces the normal keyboard card). I've since removed that whole piece since its kinda useless without the card (and generally useless anyway). Nope, no ram there. Attached is a better photo. The only connections on this card are two areas for ribbon cables, one for a 16 pin ribbon cable and one for a 14 pin ribbon cable. The picture that is of the chips replaced on the motherboard with it's connector is a 16 pin connector and looks like it connects to the end of this card, but can't be sure. I tried the software i had that identifies cards, but it didn't identify this one. Worst case, as mentioned, there are lots of removable logic chips on this board so I can always use it for those, just didn't want to do so in case it was some special rare card which while it might be rare, it doesn't seem like it's special.
  4. Thanks folks for the replies so far. Heres some more info, and i'll attach other photos i took when i first got the system. The Apple II+ came with four cards in it, but none of them were really hooked up to things inside, most of the stuff inside was unplugged. I think there was something going on at one point which i'll get into in a minute. One card was the disk controller, another was a memory expansion card (attaching to a ram chip spot on the board), another I believe is an 80 column card but it's not really hooked up to anything so i'm not sure that was ever working as such (I recall it works different on the II+ and you have to have some kind of manual switch or something), and then that weird card. As others have pointed out, it doesn't look like a commercial card but it also looks too good to be a home brew. Maybe it was made by some small local shop somewhere. If it's RGB, then I don't know how that would have worked. It has two connectors, and one of the connectors looks like it connects to whatever is going on in the main board. Also, it's all logic chips (or at least mostly logic chips and -no- ram) and since there was an 80 column card and a memory card, its unlikely to have been either of those. As a final note, there was a Videx keyboard enhancement on the lid, but it wasn't connected to anything and I believe that also needs a card attached to the keyboard which wasn't on this computer, so that was a bit odd also. Either it was removed (since stuff was unplugged inside), or this lid came from another computer. The part that leads me to believe there was another system is this computer also came with one of those Silentype thermal printers but there was no card for that printer in this computer either.
  5. Hi All, About 6 months back I picked up an Apple II+ that had some modifications and a card I can't identify. Anyone know what this is? Thanks!
  6. Thanks, I must have misread the page, it was late here when I looked at that. Sadly both my ICD FAST and Megafile 30, as well as my memory upgrade for my 520STFM went bad in the 25 years in storage, so I'll need to tackle upgrading all that before I can give this a shot. (oh, and burn some new TOS images since that clearly went bad as well...sigh).
  7. Well, I agree in that we don't know if it'll work on the STF or not. To be honest, I only have a 520STFM and a 520ST, and it didn't work on the 520 ST I have so my data pool is pretty small. Someone mentioned another non modulated one in the comments that didn't work as well, so my assumption was the modulator but I have nothing to back that up. My assumption is only based on the fact that the composite cables also don't work on ST's without the modulator as well. Obviously you can open these things up and with some soldering and/or parts make this work, but I'm only referencing out of the box solutions. As an aside, you can still get the box. I actually didn't get the exact link on the video either, the key is you have to get the same box because this specific box has a TV tuner in it, where-as many of the other boxes out there do not. Here is another link for the product, but just doing an ebay search for hdmi scart converter and finding the ones that look exactly like this are all the same chinese box. https://www.ebay.com/itm/SCART-to-HDMI-Converter-with-SCART-HD-Switch-PAL-NTSC-Video-Scaler-Ship-from-US/264094246559?hash=item3d7d3e669f:g:ybcAAOSwJotbBjMs:rk:2:pf:1&frcectupt=true
  8. Since everyone else is kinda circumventing the original request (of a technical solution you can build yourself) and offering other options, i guess I will do so as well. What I currently use is the ST to Scart cable you can buy from a place like coolnovelties for under $20 US dollars and a specific SCART to HDMI Converter (Supports PAL and NTSC) which is usually about $25 US Dollars on ebay (just make sure you use the exact one). So that's under $50. Plus, if you have other retro computers, this Scart to HDMI Converter comes up pretty handy quite a bit. The caveat is that this doesn't appear to work with the base ST line of computers without the Modulator. In theory that shouldn't matter, because the cable i got is definitely RGB and not Composite, but for some reason it didn't work on my 520ST but worked find on my 520STFM (and comments on the video below are similar experience). BTW, don't use the cheap scart cables you find on ebay as those are composite and not RGB and you'll get a pretty lousy picture. Basically, theres a video: Obviously if you live in a country with SCART built into your TV and monitors, you can do that directly and circumvent the hdmi converter, but if you're in the US, that isn't an option.
  9. This looks good. I'm in the process of burning new 1.04 roms to my 520STFM since a couple of the TOS chips went bad (leave your childhood ST in storage for 25+ years and everything goes to hell..haha). Would be good if you eventually offer an option to burn our own chips since I don't really need to buy rom chips or shipping across the world.
  10. Thanks for that link, I actually didn't know that was possible on the ST (i guess like whdload on the amiga?). From my brief search though, the site seems to imply they only work on Falcon and TT (I'm assuming because of ram requirements?). The OP has listed a 1040STFM, does it work on that?
  11. So i've kept a few old drives in my systems to just have them with the system (better to take up space inside a computer than in a box), but I'll be honest, I don't plug them in. The 'Hard Drive Noise' is the one thing I definitely don't miss... and my god, those old RLL drives in the megafiles were like rockets taking off.
  12. Technically this could be done with a Pi via a custom adapter and software (think Pi1541), but sadly there just isn't interest much interest in doing this for MFM/RLL. Original PC's have the XT2IDE adapter to avoid using MFM/RLL at all, so that really just leaves us with computers like the Atari ST who just happened to have old Megafile's sitting around. If this was a C64, there would probably be lots of low cost options, but alas the Atari doesn't fall into the mass market or people trying to save a buck. Personally I looked at the DREM and the $270 was crazy so I looked at lower cost options, like the Ultrasatan. Ultimately the price on that was still too high considering the most expensive retro hard drive i've purchased was $60+shipping for the SCSI2SD adapter for my Amiga 3000. For now, I just put a Gotek into my 520STFM drive bay and called it a day.
  13. Yeah, I wanted to keep my ST stock which is why I wanted to keep the drive inside the machine, but honestly, almost none of my disks work anymore (3 1/2" floppies were such crap.. i have older systems with 5 1/4 disks that have a much higher reliability percentage) so I decided it just wasn't worth it.. I was also lazy to print the mount, but in the end that would have been so much faster than all the time I wasted trying to get the external gotek working. I have the switch if I ever want to use the external floppy drive, but because of the media issues, that'll be less and less common going forward.
  14. I actually have it set that way now. I did the switch and since I couldn't get the gotek to work as external for me, I just 3d printed the mount and put the gotek inside and using a floppy as external. It's pretty much the same process no matter which one you have as external, its just for me the hxc software was a lot more finicky then the disk drive is. Oh, this is assuming you have an external floppy drive already (since you need the power and the cable), which i did.
  15. Updating my own post.. broke down and paid for the hxc software and went that route. Also used a different gotek. Still get's the same error, so i'm at a loss. At least I know now the hxc software isn't any better.
×
×
  • Create New...