Jump to content

Vinnie D.

New Members
  • Content Count

    47
  • Joined

  • Last visited

Community Reputation

21 Excellent

About Vinnie D.

  • Rank
    Space Invader
  • Birthday 11/18/1980

Contact / Social Media

Profile Information

  • Gender
    Male
  • Interests
    Vintage gaming and computing and making comics.
  1. I imagine retro enthusiasts fueled by nostalgia will gradually be replaced by those who do it out of an appreciation for history. There are plenty of vintage audiophiles today who weren't around for vacuum tubes. I know things look sad at the time with kids blankly poking away at their tablets, but some of those kids, just like us are the kinds who ask "how does this work?" and "Where did this come from?" That's the same sort of inquisitiveness that we had that could lead new blood back to the history of gaming and computing to before the days where everything was built on one or two standardized architectures, and into the wild west years of the 70's, 80's, and 90's when systems were wildly different and all pushing new boundaries, and in the wonder of what creative programmers did to make that hardware sing. Then again my parents are antiques dealers who's interests go back centuries, so appreciation of old things is kind of in my blood.
  2. Right now I'm really feeling the irrational want for a Famicom, Disk System, Family BASIC, and tape deck to essentially have a NES computer.
  3. I built something similar based on this here http://subethasoftware.com/2018/02/01/wifi-coco-for-15-or-for-any-retro-computer-with-an-rs-232-port/. Of course it's initially intended for a Coco, but given the design it should work on most anything. Of course the problem is that the A8 series has only one SIO port. I'm loading software via an SIO2PC USB cable, so that occupies the SIO port I'd be connecting with. Perhaps I could set up some sort of SIO pass through like a lot of Atari's accessories had, though I don't know how those work.
  4. In that case, Techmoan did a video on tapes a while back, and what to look for to get the best quality.
  5. Glad it's working out for you. It's cool to see that people are still passionate about loading from tape. Considering all the various proprietary disk drives and cartridges of the day, and all the different flash drives we have today, tape is still probably the first way you'll be able to load something onto a vintage computer when you first get one.
  6. Hrm. Makes sense. Guess I should have shelled out for a final GROM instead of a flashrom 99, but at the time I didn't know what you told me, so I'd assumed running GROMs was the only difference. At least the mystery is solved. I'll have to look into an upgrade of either a final GROM or just get a nanoPEB and run the disk version.
  7. Thanks. I didn't know there was a bigger RAM expansion out there, which is why I was confused about this.
  8. Simple question. I'm running a TI-99/4A with a 32K sidecar, speech synth with power pass through mod, and a Flashrom 99. When I downloaded the Don't Mess with Texas demo I noticed that it included a bin file which I assumed would run on Flashrom 99, since it originally runs from a cartridge. Ultimately though when I load it on the SD card it will never appear in the file list when the system comes up. Plenty of other software runs this way, but not DMWT. Is this even possible? I'm assuming if they bothered to release a .bin version it would be able to run somehow, so it seems strange that it wouldn't even be recognized by the Flashrom 99. Is it actually a GROM? Emulator only?
  9. I don't have any Atari specific experience on this problem, but I have had a power supply eating C64 before. After 3 different power supplies I realized the problem was with the system. In my case it was a bad bridge rectifier that was overdrawing the power supply, and just wasting the power back to ground. That's a recipe for dead power supplies right there. If everything is OK with a new PSU then you should be fine, but if it eats another one it might be time to break out a multimeter and a circuit diagram.
  10. Yes. Although the remote wire isn't always white depending on the system you're hooking up, but the remote plug is always smaller than the others so it will be the only one that fits in that jack anyway. It also has an aux in as well, but you can just use the mic input from your system. The aux input could be handy for hooking up an external source like a PC or phone playing a wav file in order to make tapes of your own without having to unplug the other cables.
  11. A few suggestions. I just fixed one myself. There are a few things you should check. First make sure you're getting good voltage. Take a multimeter across the top two pins of the power plug and set it to AC. You should get around 9 volts. Now set it to DC and check the bottom and left pin, and you should get 5 around 5 volts. If your AC is a little high it should still be safe up to 11v, but too much higher is dangerous. If it's significantly lower you don't have enough power to run the system. The DC line is MUCH closer. You should have no higher than 5.2vDC. If it's any higher your PSU is failing and will eventually damage your C64. 5.5V is the point of no return. Do not plug it in if it's this high. If it's lower than 5v then you may not have enough power to boot. Now check amperage. You should be getting between 1 and 2 amps from each line. Lower than 1, and again you don't have enough power. It shouldn't read higher, because it's not capable of that. In which case it's time to look into a new power supply. OK is your PSU verified good? Time to check the board. First let's check the obvious. Pull out your fuse and see if it's burned out. You can measure resistance on it. Expect about 3 ohms. If you can't get a reading it's blown, though usually you can just tell by looking at it. If it is blown it uses a 1.5amp quick blow fuse. Look at those 3 big drum capacitors on the right side of the board. Are any of them leaking liquid or bulging? If so you have a capacitor that's gone bad either from getting overloaded or just from age. Replacement kits are available if you have a bit of soldering skill. https://console5.com/store/ Are caps looking good? Ok, I'm not going to go in depth on checking voltages here, but there's an official C64 repair manual you can check full of circuit diagrams that should tell you what is where and what voltages to expect at those points. This is just a quick troubleshoot to help you find some of the more common problems. If you want to really dive in there with a multimeter you can reference the service manual available in PDF here. https://www.retro-kit.co.uk/user/custom/Commodore/C64/manuals/C64C_Service_Manual.pdf It's full of circuit diagrams that will tell you what is where, what it does, and what voltages to expect. This is also a good time to grab a can of compressed air and clean any dust out of your C64 by the way. If you want to really make it shine, and clean up your contacts, make sure to use 90% alcohol. Now if your power is good let's start checking those chips. First let's see if this is a video problem, or if it's just not booting. Try some blind keyboard commands. If you have a disk drive, or disk drive replacement just type load "*",8 and see if the drive reacts. If it does your C64 is running, but not putting out video. In that case it's very likely your VIC II chip. The VIC II can be found underneath the metal case to the middle right of the board with all the little holes in it. You may need to pry a little bit on the clips to the left side of the case to get the lid off. It's designed to just lift off, but over the years they tend to get a little stuck. Pull the VIC II. This chip is always slotted so just use a chip puller to take it out. Check the pins for corrosion, and try reinserting it. Sometimes it just has a bad connection and needs reseating. If that fails you may have a bad VIC II chip. So far no one has come up with an aftermarket replacement, but you may be able to find an original one on ebay or pull one from another C64. If blind keyboard commands did nothing, then you likely have other issues, so we can leave the VIC II be for now. One of the most common causes of a black screen is a failed Kernel ROM chip, and it's also very easy to check for. In fact it's the only one you won't even need to pull a chip for. There are certain cartridge games that bypass the kernel ROM entirely and boot straight to cartridge, so if the ROM is bad the system should boot with one of these. The most commonly known are Kickman and Jupter Lander. Kickman is cheap and plentiful on ebay. If you don't have one of those there are others that might work, so you might try with some you do own. You can also spring for a dead test cartridge, but I'm not going in depth on that one here. Did it boot with the cartridge in? If yes then congrats, we've found the problem. You just need to change out your Kernel ROM. You COULD hunt down an original, but I'd suggest that instead you take this opportunity to install JiffyDOS. It can be found on ebay, or you can get it from Retro Innovations. http://store.go4retro.com/ I don't know which version of the C64 you have so I don't know if your ROM is socketed or soldered. I fit's soldered you'll need to unsolder it very carefully and install a socket. If this is outside your ability you may want to have someone do it for you (or at this point just pay to have it repaired). If it's socketed, then all you need is a chip puller. They're super inexpensive and very useful. Again can be found on ebay if you don't already have one. DO NOT try to pull a chip without one or try to pry it out with something else. These are old chips and fragile. They will break if not pulled properly. Ok if it didn't work with the cartridge in you probably have other problems. NOW it's time to start pulling chips. First pull and reseat all slotted chips. Just like with the VIC before, we're trying to eliminate bad connections as the cause. If it boots you're good now. Otherwise let's continue. The chief chips that can cause a total black screen are the Kernel ROM, the VIC II, and of course the CPU, but we want to eliminate another bad chip first. if they're slotted, remove the following chips. The SID (the sound chip) at 18 both CIAs at U1 and U2 U 28 and U16 if you have them (not all boards do). The goal here is to isolate the absolutely vital chips. If it boots now it will look weird, and may not respond but will have picture. If that's the case, then power it back off and reinsert chips one at a time, trying again after each one until you lose picture again. When you find the culprit replace it. All but the SID aren't too hard to find replacements for, but SID chips are kind of valuable and expensive. You might can pull one from another dead C64, or look into the Nano Swin, a modern replacement for the SID. Using it, you'll lose the ability to use a mouse or paddle controls, but you will have sound. If you're still reading this then even that didn't get you a picture. This leaves you most likely with a bad CPU or PLA. The CPU is a MOS 6510 chip. There are modern replacements for the PLA such as the PLAnkton. Keep in mind if it's your CPU, there may still be something wrong with any of the previous chips mentioned once the CPU is working, so work your way backwards through these tests to try them again. In my case I found a bad CPU, fixed that, still had a black screen, checked again with a cartridge, and then discovered the ROM was also bad, then fixed that to get the system back up and running. Hope that helps.
  12. An Atom PSU isn't all that expensive. Trust me, invest now, because fixing a C64 with blown caps and possibly even burned out ICs is a lot more expensive and time consuming. By the time you've paid the price plus shipping for an original PSU brick you'd be halfway to a modern PSU with proper protections built in.
  13. Yes, it's built in, but it's a pretty standard AC cable and pretty sturdy. There's a storage compartment on the bottom you can roll it up into.
  14. Sure the model number on the back is 3279A. Here's one for sale on ebay. https://www.ebay.com/itm/Vintage-EIKI-Commercial-Cassette-Tape-Player-Recorder-Model-3279A/123301712051?hash=item1cb55ad0b3:g:amcAAOSwVuNbH~jF The headphone outputs are the large type, so you'll need to get some adapters, but it's nice having 4 of them, and 2 inputs, so I can have multiple systems connected at the same time.
  15. Mono is best for reliability, but stereo can work too, it just may be more finicky. Stay away from new production tape recorders. They really don't make them like they used to. Just pop in a music recording and you can immediately tell the huge amount of wow and flutter these new tape recorders have. There are a few good tape recorders made in the early 2000's though. Of course not all vintage computers will work with standard tape recorders. The C64 and Atari 8-bit line use specialized tape drives which encode the signal within the drive its self and send the data through a specialized port. I'm using an Eiki recorder myself, and it works with a Tandy Coco 2, TI-99/4A, and a Timex Sinclaire 1000. I also used it to record wave files from my PC to tape for use in My C64's tape drive. That's a pretty good record for compatibility, so I'd recommend that based on personal experience. You may have to fiddle with volume and tone to get it to read. I find max volume, and around 75% tone work best. You can of course also just save a wav file to your phone or computer and plug into that, but I fully understand the desire for an authentic experience.
×
×
  • Create New...