Jump to content

joltguy

New Members
  • Content Count

    47
  • Joined

  • Last visited

Everything posted by joltguy

  1. 😮 /me frantically begins refreshing email client.
  2. Nicely done!! What an excellent port. I love that you kept the Windows UI chrome on the small board size!
  3. Donated this morning and I hope all ADAM fans do the same. I've spent hours reading the newsletters I've downloaded from your site's amazing collection and I would seriously miss your site if it went away!
  4. Yep, it's looking that way. Thanks again for all your help and suggestions.
  5. Yes, I have. And I have the baud rate set to 9600 on both sides.
  6. ADAMLink V with the display option set to “Both”.
  7. Gave it a try with on the ThinkPad with PuTTY running under Windows 7 and the Prolific drivers installed and the adapter assigned to COM4. Still no luck... PuTTY window stays blank.
  8. I actually have an old ThinkPad that I'm going to install Windows 7 on and see what comes of that. FWIW the H19 terminal program I am using on my Raspberry Pi Zero W is h19term.
  9. Thanks for the info. Yeah, this is where I'm showing my ignorance because in my mind I was just thinking a serial port is a serial port is a serial port. I didn't realize they are wired uniquely for their specific purposes. Back in my PC/DOS days COM1: was the same as COM2: save for the addresses and IRQs. Anyway that probably explains the garbled text when connecting the modem to the Terminal port.
  10. Good point about the ports and the adapter/cable. I hadn't thought about that. But no, I personally haven't had any previous success using the Terminal port and hooking up to anything.
  11. That was a great suggestion! I did exactly that. The good news is that I know what the problem is. The bad news is that it appears that my Terminal header is indeed faulty. After hooking the modem up to the Terminal pins and setting up ADAMLink V accordingly (MIB2 2), I can no longer use the wifi modem. Trying to type anything like AT commands just results in random characters on screen. See the attached screenshots.
  12. Thanks @rietveld for your detailed help! I followed your instructions and the Pi did respond in the expected way through all of it however I'm still not getting any output from the ADAM. I also tried screen /dev/ttyUSB0 just to see if anything would come through on the device but nothing shows up. Attaching a screenshot of the output from dmesg:
  13. Today I came across a really nice Z80 Reference app on the iOS App Store of all places. It includes a complete guide to the Z80 instruction set and even includes some sample code for each instruction. All for the low price of $0.00. 🙂 Thought it might be useful to some folks here. Z80 Reference app for iOS
  14. Hi @rietveld I've been trying to get a similar setup working with my ADAM & MIB238 but so far haven't been able to get any 80-column output. I'm thinking maybe it has something to do with my cabling setup. I have the ribbon cable (by John Lundy) going from the MIB238 Terminal pins to a 25pin -> 9pin adapter. Connected to that I have a 9pin serial to usb cable which is then connected to the Pi Zero. Here are the parts I'm using: 9-pin to USB serial cable: https://www.amazon.ca/gp/product/B00425S1H8 25-pin to 9-pin adapter: https://www.amazon.ca/gp/product/B00005117M The 9-pin to USB serial cable is using the Prolific chipset and the Pi is detecting it at /dev/ttyUSB0 but I'm just not getting anything appearing in the H19 terminal window. Could you give me any hints or maybe link me to the exact cable setup you're using?
  15. Nice! What's the switch you're using to change VGA inputs?
  16. joltguy

    SGM 5th run

    Did you get the ADAM beige one?
  17. If you just need the board I found them on CanaKit for $12.95 CAD. That's for the Pi Zero W, which is what I ended up purchasing. The only catch is that there's no free shipping option so that increases the overall cost. https://www.canakit.com/raspberry-pi-zero-wireless.html
  18. 👍 This is brilliant! Nicely done, @rietveld I think I'll have to order myself a Pi Zero and give this a try.
  19. joltguy

    SGM 5th run

    Somehow I didn't get it. This is for the ADAM variant of the SGM, right? Can you please post or PM me the pre-order link?
  20. joltguy

    SGM 5th run

    I came here for exactly the same reason! I added my email when that post went up on FB but I haven't heard anything since and was starting to get worried that I had typo'd my own email address and missed the announcement.
  21. Looking forward to it. Love the set... such a super-clean ADAM setup! That monitor complements ADAM very nicely. 👍
  22. Insta-bought the Kindle release the day it came out!
  23. Seems to be working! It wouldn't launch when I copied the SDL2 framework to /Library/Frameworks (security issue) but I was able to get it to work by installing the framework in my user ~/Library/Frameworks folder instead. I can't test thoroughly test right now but I was able to get it to boot a few different .dsk images without issue. Full screen worked too! A couple of issues I did notice so far: The names of the mounted disk images don't show up in the menu Mounting to anything other than disk 1 or tape 1 doesn't seem to work Thanks for developing this! 👍
×
×
  • Create New...