Jump to content

Probabilitydragon

New Members
  • Content Count

    63
  • Joined

  • Last visited

Everything posted by Probabilitydragon

  1. Just to make sure - the game runs on 128kB machines, right? Or is some of the version compatible with my 64kB A8?
  2. This is kind of silly but here's a TikTok duet with me singing & playing my 600XL live. Well, I guess the capabilities of the Atari 8 bits as live music instruments have been greatly underestimated! https://www.tiktok.com/@kiureli/video/6971437247547657478?lang=fi-FI&is_copy_url=0&is_from_webapp=v1&sender_device=pc&sender_web_id=6967258794070525445
  3. I was interviewed by Davinder Bedi from London for his youtube show today. I actually talked quite a bit on my ATARI 600XL - and even @ivop and his POKEY explorer are mentioned!
  4. @Paul Lambert had exactly the same symptoms in the earlier thread as I did this morning. He’s running rev c, so it’s probably not a rev b issue. Might have happened because my break key is dead, and I’ve been using the reset key. But the symptoms have been there since the 80’s with this machine, and I was diligently using the break key back then 😀 so, hard to tell if it’s a hardware or a software issue 🤔
  5. rev b here, so the mystery of three and a half decades is solved.
  6. Oh yeah, that had been discussed relatively recently here, thank you for pointing me to the thread. I probably have rev b basic, but will peek the value at 43234 to find out!
  7. Well, if art considered real work (never did any other kind of job) then yes, I did use my 600XL for sound on a song I released & visual effects on the music video, posted on this forum earlier!
  8. Hi, Forum! After my initial excitement of playing around with my 600XL, it's been mostly left sitting idle on my table during the past months... But this morning, I did some BASIC coding just for fun. A silly routine that makes random sounds, characters and colors in GR.0 just for the heck of it. And, after having versions of my program that worked and after typing a new command line, RUNning the program just freezed BASIC. Interestingly, typing LIST would also freeze the machine. Now, as a kid, I recall something curious happening now and then with BASIC on my machine. It would have, perhaps, frozen like this occasionally. Or, sometimes, the BASC LISTing of the program would become "corrupt" for now reason and, if I remember correctly, typing LIST would produce the beginning of the program, and stop at a line that would display erroneous commands and no <RETURN> character at the end of line. The behaviour I'm describing happened decades ago so I don't remember the details. But I remembered being even a bit scared that my dearest computer, my most prized possession, was kind of going crazy occasionally Anyway, the question is not very important but it's something that has been puzzling me since 1985 - why does my 600XL behave like this? Is it something typical of the on-board ROM basic, fo A8's in general, of the 600XL, of the 600XL+1064 combo, or has there been something wrong with my machine ever since I got it? Nothing wrong with the memory, just ran a mem test, all green.
  9. Love the sound on that skecth @VinsCool 👌🏻
  10. Here you go. My machine could use some retrobrighting, but the 1064 actually still has the plastic foil on the metal strip - and so does my 1050, too for the record! Some keyboard issues resurfaced - the [1] key used work intermittently. It then resurrected and worked perfectly, only to die soon later - doesn’t work any more. [BREAK] doesn’t work either.
  11. As far as the audio is concerned, I sampled POKEY sounds and those MicroRhythm samples. For the video - that could have been stuff for another quiz - I used Colourspace to create patterns on a crt and used them as an overlay on the video.
  12. This forum is a treasure - again, I was educated. Wouldn’t have known of the background & genealogy of those samples.
  13. ...and the answer to the drum machine question is - Micro Rhythm! I should check out digi drum, too!
  14. Thanks! Rannalla istuja means Sitting On The Shore(literally the one sitting on the shore) - I might post a translation when I have one ready. The lyrics are about love, longing and death in a folk ballad style... But, as far as the guesses are concerned - distortion 6, no - digi drum, no. I think there’s dist. 6 as well (can’t remember what all sounds I dug out and sampled) but most of the ”signature” sounds on that song are from a different dist setting!
  15. Check out my latest offering! The Atari 600XL (with a 1064) was used for many of the sounds here, as well as the visuals. a quiz - which POKEY distortion setting did I mostly use? that’s an easy question for you guys I reckon. But can you name the A8 drum sequencer I used in the second verse? I hope I won’t find myself banned for ruthless self promotion 😉 I hope you guys instead appreciate my humble efforts for spreading A8 love here in Finland... where tha ATARI 8 bits were pretty much unknown even back in the day as this was Commodore country then!
  16. I just tested it - yeah, now I get the sounds that I wanted. Thanks a lot for the help! Just did a very quick test with filter modulated 16 bit $Ax bass frequencies - sounds awesome, opens up again a new world of sounds!
  17. ...and my POKEing around in BASIC was based on chapter 7 at de re atari, and yeah, there it says channel one muted and channel 2 on - so my BASIC routines were correct
  18. Ok - will try that. I thought channel 1 should have the volume, channel 2 muted. Created interesting results that way though 🤔😄
  19. Yeah, it’s probably my scandinavian keyboard
  20. Yes, the filter is another thing, and I’ve experimented with it a bit, mostly in Pokey Explorer. Also I’ve played around with 16 bit frequencies in both BASIC and PE, and there is either a bug in the program or I don’t understand how it’s supposed to work. A value of 80 / $50 in AUDCTL corresponds to channel 2 joined to 1 and channel 1 clocked @1,79MHz AFAIK 🤔
  21. ...lots of questions today, another question: what exactly is two-tone mode?
  22. Another note, I don't know if this is a bug or a keyboard layout related issue - when I press shift+6 (& on my keyboard), supposed to increase AUDC3 by $10, AUDF4 increases instead by $10. when I press shift+7 (' on my keyboard), nothing happens when I press shift+8 (@ on my keyboard), supposed to increase AUDC4 by $10, AUDC1 increases instead by $10. Pressing shift+2 also increases AUDC1 by $10.
  23. A question regarding PE 1.1 - when I join channels one and three and am using the "pure tone" square waves $Ax at 1,79MHz, the output of the sound behaves very differently than I'm expecting. When I do a basic routine with POKEing the AUDCTL to 80 (joining the channels and clocking channel 1 to 1,79MHz) and controlling the frequencies with the frequency bytes of channel 1 and 2, I get what I am expecting - I get 16 bit frequencies with one of the channels acting as the high byte / coarse control and the other one as low byte / fine tuning. But, while using Pokey Explorer, something very different happens. I don't really understand what's going on, but certainly not just square waves at 16 bit frequency resolution. Am I getting something wrong?
×
×
  • Create New...