Jump to content

Kirkman

Members
  • Content Count

    122
  • Joined

  • Last visited

Everything posted by Kirkman

  1. Is JagStudio pretty much only for use under Windows? I tried downloading it today, and most of the files I saw were .bat, .exe., and .dll. I'm a Mac guy, though I also have a Linux virtual machine. Was just wondering if there was any hope of Mac/Linux support in the future, or not.
  2. I finally got my GameDrive firmware updated and I'm finally trying some JCDs from the Internet Archive. I have a K-series Jaguar (got it for Christmas in 1993). Here's the serial if that's helpful: I've been trying hardest to play Battlemorph. I frequently get a black screen if I hit a button at the Jaguar logo. Sometimes if I just wait, then the Battlemorph title screen will appear by itself and I can play. I seem to be able to get through one mission, but after I select a second mission, the game usually glitches out and crashes. Something similar happened with Primal Rage. It loaded just fine, but when I got to the character select screen, the color palette was completely wrong and eventually the game crashed. Most of the others that I tried didn't load (just a black screen), at least at the first attempt. If I ever get some free time I need to go through them all systematically.
  3. On the front page of the Internet Archive, searching for both "Jaguar" and "jcd" (with the quotes) will show several collections folks have uploaded to IA.
  4. Looks like a user finally uploaded a full set of JCD and MRQ files to the Internet Archive, claiming they are "fully tested, CRC confirmed, 100% compatible". I am just now downloading them, so I can't verify that claim.
  5. I lived in St. Louis, so we didn't have local access to it at launch ... but my parents secretly arranged for an uncle in California to buy one for us. They surprised us with it for Christmas in 1993. I wrote about it on my blog, Break Into Chat, in 2012.
  6. As I mentioned in my message, I tried to run cd2jcd using Wine under MacOS Mojave, but cd2jcd always crashes. I tried re-installing wine in various ways, and installing the microsoft libraries, but it made no difference. Hence my desire to see a Mac-specific build of cd2jcd.
  7. Any update on the possibility of a Mac-native version of cd2jcd? I have tried to run it under Wine in MacOS Mojave, but it crashes every time.
  8. I would love to see such a patched version of Zool 2 someday.
  9. Anyone else using a RetroTINK 2X-Multiformat with their Atari Jaguar? I'm connecting my Jaguar’s via S-video cable to the RetroTINK, and displaying on a TCL 4-Series Roku TV. It mostly works well, but I am running into a persistent issue with the picture cutting out momentarily. Here is a video that shows what I’m talking about: https://vimeo.com/543650035/ec57b9d649 I didn't have any flicker / cut-outs like this when using S-video on my old CRT. Anybody else come across this? Any tips or ideas for stopping it?
  10. This really is a fantastic collection of clip art and music. I wanted to follow up on the BBS stuff ... you mentioned having "the original disks for the BBS software itself." Any chance you will post those, or any other BBS-related files? How about the MMS source code?
  11. I wish I could find a copy of one of the original Radoff/Lambe "Final Frontier" releases. I have two of Jeff Bath's modified releases. I also have a partial source code listing for Bath's FF 1.46 (saved this myself when I was a teen, but the file is corrupted in several places).
  12. Something quick that you might enjoy: Jon Radoff, creator of the Atari ST BBS games Space Empire Elite and Final Frontier, recently shared a small cache of old correspondence related to his games. He was a teen when he developed those games, and his mom had saved these artifacts in a scrapbook. https://breakintochat.com/blog/2020/12/03/jon-radoffs-bbs-related-correspondence/
  13. Thanks, DarkLord! I submitted the story, interview, and source code repo to Slashdot -- and to my surprise, it made the front page. Pretty exciting! Hopefully it introduced many folks to the quirks and wonders of the Atari ST and BBSing worlds.
  14. Yes, the “Thieves Guild emulator” can be run inside Hatari, but you’ll need a telnet->serial connection, either by hardware (WiFi modem or Lantronix) or software (tcpser). FWIW, I recently updated my tutorial on using tcpser and socat on a Mac. https://breakintochat.com/blog/2020/09/03/tutorial-telnet-to-a-bbs-using-a-terminal-program-in-the-hatari-emulator/
  15. Also, check out my interview with Paul Witte, who wrote Thieves' Guild, and his friend Herb Flower, who made all the art for the graphical front-end: https://breakintochat.com/blog/2020/09/15/paul-witte-and-herb-flower-creators-of-thieves-guild/ They met at a Utah Atari users group, where Witte was blown away by Flower's submission in a NEOchrome art contest. "It was these swirling purple clouds and stuff," Witte said. They later incorporated that image into the ending of Thieves' Guild.
  16. Yes, a real ST and a WiFi modem are the perfect way to do it.
  17. Yes, I'm so excited about that! I even made a discovery in the source today that I hadn't noticed before -- Paul had a commented-out "insta-travel" feature that apparently was intended for use in a CompuServe demo, which corroborates what he told me about CS negotiating to license the game. I hope the games fall into place. Having finally set up a barebones private BBS on my own Mega STe so I could play TG, I can appreciate the difficulty involved.
  18. Some of you have probably seen posts from me over the years trying to work out how to play Thieves' Guild using its graphical front-end client ... over telnet, inside an emulator, etc. So many failed attempts! But at last I have done it. I finished the game! And I'd like to share with you the fruits of my seven-year labor. Please check out my blog post: https://breakintochat.com/blog/2020/09/15/thieves-guild-memories/ It's a deep deep dive into the game, chock full of screenshots, videos, and more. ALSO -- I have saved the source code for the game! Paul Witte has given me permission to share it with the community.
  19. I just realized the front of the castle has a giant "H." Herb confirms this is deliberate.
  20. Recently I've been interviewing Paul Witte and Herb Flower about their BBS door game Thieves' Guild (play it on Dark Force!) in preparation for some future blog posts. Herb made some really cool pixel art for the TG front-end client that has always impressed me. Anyway, Paul and Herb told me that Herb had an unreleased game that he wrote in the late 80s in GFA BASIC, called "Dark Fortress." They mailed the disk to me, and I managed to recover the game. Anyway, you can download the game, learn more about gameplay, and read a short essay from Herb about its creation here: https://breakintochat.com/blog/2020/06/04/unearthed-dark-fortress-for-the-atari-st/
  21. I was going through my Atari ST disks recently and found a cassette tape I had long forgotten. I had used the tape to store BASIC programs I typed in from various Compute! and Antic books as a kid. I wrote about converting the tape to a .CAS file and trying to figure out where all the programs came from: https://breakintochat.com/blog/2020/05/30/unearthed-my-atari-8-bit-cassette-tape/ It was a fun research challenge tracking down each program, but perhaps my favorite nerdy part was diffing the source listings of the programs to see where I had made mistakes, or where I had customized the programs.
  22. Yes, re-flashing the internal SD card did the trick for me. Of course, after doing that I had to manually re-set all the preferences in CE_CONF (ACSI IDs, IP address, network settings, etc). Something else that occurred to me afterward is that I probably should have replaced the CE_DD and other drivers after I did the original upgrade. Having an older CE_DD might have been what caused all the issues.
  23. Ugh, I'm an idiot. I had two parts of the IP address reversed. I can't figure out how to delete this topic on my own, but mods feel free to do so.
  24. Hi everyone... I have a v1 CE that I've used for many years with my Mega STe. Recently I updated it and it began giving me trouble. On boot, the CE would say "Looking for CosmosEx on ACSI" and it would run through various numbers, but it would never succeed. I would quit out of this and the Atari desktop would appear. My SD card hard drive would mount properly, but not the O: Config drive or my N: shared drive (NFS). Since the O: drive didn't mount, I couldn't launch CE_CONF on the Atari. Instead I decided to try to SSH into the CE from my Mac. I've done it in the past, but this time it didn't work. When I tried the SSH command, it just sat there until eventually it timed out. Today I decided to pull out the CE's internal SD card and re-flash it with the latest Raspbian Stretch image, which I found on Jookie's webpage. This seems to have solved most of the problems. The Atari sees the CE again, and the O: and N: drives now mount properly. CE_CAST is working, and I can access the screencast through my web browser. The only thing that's not working is SSH access to the CE. Trying SSH continues to result in a timeout. Anyone have any ideas how I might fix that? --Josh
×
×
  • Create New...