Jump to content

Search the Community

Showing results for tags 'STE'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Atari Systems
    • Atari General
    • Atari 2600
    • Atari 5200
    • Atari 7800
    • Atari Lynx
    • Atari Jaguar
    • Atari VCS
    • Dedicated Systems
    • Atari 8-Bit Computers
    • Atari ST/TT/Falcon Computers
  • Classic Consoles
  • Classic Computing
  • Modern Consoles
  • Gaming General
  • Marketplace
  • Community
  • Community
  • Game Programming
  • Site
  • PC Gaming
  • The Club of Clubs's Discussion
  • I Hate Sauron's Topics
  • 1088 XEL/XLD Owners and Builders's Topics
  • Atari BBS Gurus's Community Chat
  • Atari BBS Gurus's BBS Callers
  • Atari BBS Gurus's BBS SysOps
  • Atari BBS Gurus's Resources
  • Atari Lynx Programmer Club's CC65
  • Atari Lynx Programmer Club's ASM
  • Atari Lynx Programmer Club's Lynx Programming
  • Atari Lynx Programmer Club's Music/Sound
  • Atari Lynx Programmer Club's Graphics
  • The Official AtariAge Shitpost Club's Shitty meme repository
  • The Official AtariAge Shitpost Club's Read this before you enter too deep
  • Arcade Gaming's Discussion
  • Tesla's Vehicles
  • Tesla's Solar
  • Tesla's PowerWall
  • Tesla's General
  • Harmony/Melody's CDFJ
  • Harmony/Melody's DPC+
  • Harmony/Melody's BUS
  • Harmony/Melody's General
  • ZeroPage Homebrew's Discussion
  • Furry Club's Chat/RP
  • PSPMinis.com's General PSP Minis Discussion and Questions
  • PSPMinis.com's Reviews
  • Atari Lynx 30th Birthday's 30th Birthday Programming Competition Games
  • 3D Printing Club's Chat
  • Drivers' Club's Members' Vehicles
  • Drivers' Club's Drives & Events
  • Drivers' Club's Wrenching
  • Drivers' Club's Found in the Wild
  • Drivers' Club's General Discussion
  • Dirtarians's General Discussion
  • Dirtarians's Members' Rigs
  • Dirtarians's Trail Runs & Reports
  • Dirtarians's Wrenching
  • The Green Herb's Discussions
  • Robin Gravel's new blog's My blog
  • Robin Gravel's new blog's Games released
  • Atari Video Club's Harmony Games
  • Atari Video Club's The Atari Gamer
  • Atari Video Club's Video Game Summit
  • Atari Video Club's Discsuuions
  • Star Wars - The Original Trilogy's Star Wars Talk
  • PlusCart User's Bug reports
  • PlusCart User's Discussion
  • DMGD Club's Incoming!
  • DASM's General
  • AtariVox's Topics
  • Gran Turismo's Gran Turismo
  • Gran Turismo's Misc.
  • Gran Turismo's Announcements
  • The Food Club's Food
  • The Food Club's Drinks
  • The Food Club's Read me first!
  • The (Not So) Official Arcade Archives Club's Rules (READ FIRST)
  • The (Not So) Official Arcade Archives Club's Feedback
  • The (Not So) Official Arcade Archives Club's Rumor Mill
  • The (Not So) Official Arcade Archives Club's Coming Soon
  • The (Not So) Official Arcade Archives Club's General Talk
  • The (Not So) Official Arcade Archives Club's High Score Arena
  • Adelaide South Australia Atari Chat's General Chat & Welcome
  • Adelaide South Australia Atari Chat's Meets
  • Adelaide South Australia Atari Chat's Trades & Swaps
  • KC-ACE Reboot's KC-ACE Reboot Forum
  • The Official Lost Gaming Club's Lost Gaming
  • The Official Lost Gaming Club's Undumped Games
  • The Official Lost Gaming Club's Tip Of My Tounge
  • The Official Lost Gaming Club's Lost Gaming Vault
  • The Official Lost Gaming Club's Club Info
  • GIMP Users's Discussion
  • The Homebrew Discussion's Topics

Blogs

There are no results to display.

There are no results to display.

Calendars

  • AtariAge Calendar
  • The Club of Clubs's Events
  • Atari BBS Gurus's Calendar

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website


Facebook


Twitter


Instagram


YouTube


eBay


GitHub


Custom Status


Location


Interests


Currently Playing


Playing Next

Found 9 results

  1. RetroElectroDad

    Atari 520 STE

    From the album: RetroElectroDad Computer Collection

    Atari 520STE upgraded to 4MB RAM.

    © Trevor Briscoe

  2. So I dug the 520 STE (4MB / TOS 1.62) out of storage recently, along with my external SCSI drive. The drive is a Seagate ST32155N "Hawk". Now, it's probably been about 20 years since I've worked with SCSI drives. Back in the '90s I had plenty of them, set them up, configured them, etc. Used them with the STE, Falcon, and Ensoniq sampler. But, some of the arcane details have escaped me at this point. Hopefully someone here has better memory recollection on these than I do at the moment... So... the drive powers up, and spins up, and the head un-parks, and moves into place. The activity LED goes out at this point, so I know the drive is ready. However... the drive will only do this when nothing is attached. The external case has two standard SCSI ports on the back. If I put a terminator plug into either port, the drive will power on, but won't spin up / mount. If I plug the ICD Link into either port, same thing - power but no spin-up / mount. This is with the STE off. Turning on the STE doesn't change the behavior either. It will just boot from floppy and not see the hard drive. If I plug just a SCSI cable into either port (or both), the drive spins up and mounts as it should. So I'm guessing this is a termination issue, but I can't for the life of my remember how I had things setup back then, other than I had a SyQuest EZ-135 and a CD ROM drive in the chain, maybe a scanner too. Hard to remember, because a lot of this stuff (including another cased hard drive I have) was later used with my Falcon. But from what I can remember, I don't think ANY of the drives were internally terminated, and parity was disabled. Any ideas?
  3. I bought a GBS8200 upscaler to connect my STE to an LCD display. When it didn't work as planned, I started researching and found that STE's lack a clock signal on pin 2 of the monitor port. I'm trying to determine how to get that signal presented, and level of difficulty. Any help or advice would be appreciated. Thanks Wade
  4. Just curious. Anyone using EmuTOS on EPROM on real hardware? Sounds like quite a project. I watched some videos of it in action on YouTube. The only concern I could see was that DRI's GEM icons are not exactly attractive compared to the Atari's versions we're all familiar with.
  5. Hello all! I'm looking for an Atari STE: either a 520, 1040, or Mega. I'd need it in excellent working condition, except for the floppy drive (and, in the case of the Mega, the hard drive), which I can replace using parts from other systems that I have. (Physical condition isn't as important to me, so we can talk about that ) I'd prefer a U.S. system, but I might also consider a U.K. system. I'll also consider other regions, if I can easily swap in a U.S. or U.K. TOS. (In the case of the Mega, a corresponding keyboard would be a bonus, but is not required.) Must be willing to ship to the U.S. (specifically, zip code 65721), since that's where I'm at If anyone's interested, feel free to post in here, or send me a PM. Thanks!
  6. It would have been great to see the AMY chip's power on both the 520STE and the 1040STE computers. Shame that Atari Corp.'s computer division was too aloof.
  7. Hi all, looking to buy an STE, STFM or STF, prefer 1 meg.... anyone selling? Can pay immediately, US preferred... Thanks!!
  8. I wanted to add a post here with regards to installing the STE 32Mhz booster by exxos, as although it's already on Facebook, if you're not a group member, you wouldn't see it. So, here goes The tools. I used a fairly standard set of small side cutters, temp controlled soldering iron, small forceps (For removing the old PLCC pins), flux, desolder braid, plastic levers (iPhone screen removal tools) and a large eraser. More on that later. One thing that isn't visible is the illuminated hands free magnifer, which is essential for the fine soldering. Total work time for this was about 4-5 hours for me, bearing in mind the TOS switcher had already been installed, and I had already preassembled the booster. Personally, I'd do the TOS switcher first and make sure it works before you move on to the booster. Starting PLCC removal using the pin method suggested by exxos in his instructions(http://www.exxoshost.co.uk/atari/last/removal/index.htm). It works, so use it. All pins lifted. Again, the instructions from exxos worked up to this point. I tried lifting the socket after snipping the leads, but no movement at all. Since the socket wouldn't lift, I decided to cut it into smaller pieces as per exxos. This is the first 'Gotcha' for me. The socket didn't cut into smaller chunks, it disintergated into small pieces leaving this very tough baseplate behind. This is where you MUST use plastic tools, or you'll destroy the tracks on your mainboard. This is where the 2 blue plastic levers came in. I had to trim the pins a second time, then work my way around the edge with the levers to lift the baseplate. It's desolderin time!! Baseplate off, pins ready to desolder. Follow the instructions by exxos for this part. TIP:- I used small forceps with serrated jaws for manipulating the pins, as they were easier to handle than the needle nosed pliers I own, which lost grip as the jaws were not serrated. exxos has already mentioned the "Gotcha" around the power pins, take your time, they do take longer to desolder. This shot is all pins removed, but solder is still present in the thru holes. Again, the PLCC removal guide by exxos is good up to here. TIP:- TAKE YOUR TIME, rushing will just hurt your chances of a good job. My next TIP comes here, cleaning the solder from the thru holes. I used 1.5 mm solder wick, and rather than put flux on the board, my flux was quite thin, so I DIPPED the wick into the flux. Get your soldering iron right in the middle of the hole, and on top of the wick. Be paitient, it takes a second or two, but the solder will melt, and the flux in the wick will help it flow, and you'll see the wick turn silver. Don't be tempted to re use wick, it won't work, just regularly trim the used parts away and discard. TIP:- if a hole doesn't clear of solder right away, move on so that you are not constantly heating the same part of the board, which can damage the tracks and vias. All cleaned up! I had a few holes that half cleared, the TIP here is to refill the holes with fresh solder, then use the wick again to empty them. Hold the board up to the light to confirm they're clear. After trimming the pin strips, I dropped them in to the mainboard as a trial run. TIP:- Here is where the eraser comes in.Put 2 of the inner pin strips into the booster board, then push the whole thing into the eraser, making sure the pins are well aligned. Solder the 2 end pins of each strip. Repeat until all of the pin strips are held in by just 2 solder joints at each end, as this will give you a little wiggle of the pins so you can get them into the mainboard. Insert the booster, and hold it in place with tape or blu-tac, and solder just 4 of the outside row of pins at the ends. TIP:- good alignment is critical here, before you move on to soldering the rest of the pins, so just soldering a few will give you a chance to wiggle things around. When you're happy it's all in a good position, solder the rest of the pins on the mainboard side, then the rest on the booster side. All soldered in, awaiting final wiring. All wiring completed, with a switch for 8/32 Mhz and Tos 1.62/2.06. Just need to mod the case for the switches. Just to the left of the yellow clip, you can see the 1.44 Mb fdd mod, also from exxos, that I installed at an earlier date. Booted up to TOS 1.62 at 32Mhz. Booted up to TOS 2.06 at 32Mhz. Now this is completed, I'll need to get some benchmarks run, and I've had some requests to run certain games/programs at 32Mhz to see just what the difference is. I'll post more on that when I have time, and when my floppy drive is fixed and working again Thanks to exxos (Chris Swinson) for all the support, and the time, effort and money he puts into developing these awesome upgrades. His guide can be found here: http://www.exxoshost.co.uk/atari/last/V1STE/
  9. Looking for anyone who has replaced the DMA in their STE and can contribute the old one for investigated into this project. http://exxos.www.idnet.com/IMPULSE/atari/last/gigafile/index.htm http://exxos.www.idnet.com/IMPULSE/atari/last/DMAfix/index.htm
×
×
  • Create New...