Jump to content
Albert

Forum Upgrade Completed

Recommended Posts

NOTE: If this is the first time you are visiting the upgraded forums, please EMPTY YOUR BROWSER'S CACHE! This should get rid of any weird problems you may be seeing, especially with regards to any features that are driven by Javascript.

 

I also suggest erasing any AtariAge-related cookies and then loging back in.

 

----

 

I just finished upgrading the AtariAge Forums to the latest version of the software we're using. While this isn't a major update, a fair bit of stuff did change internally. For the most part, things will look as they did before. However, there are several changes and improvements that you will certainly notice. Among them:

 

- Personal Portal Profile Page:

 

* Friends list - manage your friends for easier PMing, to see if your friends are currently online and display your friends on your profile

* Profile comments - allow visitors to leave comments on your profile. You can set to moderate all new comments before they're shown.

* Recent visitors - recent visitors are shown on your profile.

* Your content - show your recent posts / blog entries / gallery uploads on your profile

* Personal statement - add a short bio for others to read

* Member rating - rate other members

* Set your gender

* Easy access to edit your location, age and IM details

 

- New Text Editor: The text editors, both standard and rich text (WYSIWYG) have been completely rewritten to make them more intuitive and faster to load. Clutter has been reduced with the new dynamic menus. You can now switch between the rich text editor and the standard editor without the need to reload the page or visit your User Control Panel.

 

- New Attachment System: IPB 2.2 has a new attachment system that enables one to upload attachments without having to reload the post screen. The new attachment area is directly below the text editor.

 

- Auto resizing of large linked images: Posted images are automatically resized on-the-fly if they are larger than the available screen width of the browser. Clicking the image displays it full size in a pop-up window. Each reduced image has information above stating how much reduction has taken place and the dimensions of the original image.

 

I have a list of minor issues I need to address, so you may see a few wonky things for the next 24 hours or so until I get them all addressed. If you see any obvious errors or things that seem out of place, please let me know as I'm sure I missed a few things. I'll try to fix any problems as quickly as possible.

 

One issue I am aware of right now is that when you click on an image thumb, you end up with a tiny little popup window. I have to run a script to fix this and it'll probably take 12 hours or so to run. So please, no reports of this particular problem. :)

 

Enjoy!

 

..Al

Share this post


Link to post
Share on other sites

It appears that you need to use IE if you want to use the "Insert Special Item" menu, attachments, and a few other features; they don't work in Firefox. :(

Share this post


Link to post
Share on other sites

I like the content panel. I use something like that over at fedora forum so that I can look directly at the threads I started there without having to spend time searching for them. I can also put the computer down for a few weeks, take a break from learning Fedora, and when I come back, I look at the content and my questions (with answers) are all right there.

 

This could allow new Atari users to post a question (assuming their forum search doesn't answer it), then come back the next day and find the answer easily.

Share this post


Link to post
Share on other sites
It appears that you need to use IE if you want to use the "Insert Special Item" menu, attachments, and a few other features; they don't work in Firefox. :(

These should all work fine in Firefox, I have been using Firefox pretty much exclusively and all the Javascript-related items of that nature seem to work fine for me (there are one or two weird things I need to look at). What version of Firefox are you using? Do you have Javascript enabled in Firefox? Also, there are two editors, you might try switching between them. The icon in the upper-right corner of the editor will switch between them.

 

..Al

Share this post


Link to post
Share on other sites

I'm using FireFox 2.0.0.1, JavaScript fully enabled....weeeeeird...(and switching editors still doesn't bring up the options...)

Share this post


Link to post
Share on other sites
I'm using FireFox 2.0.0.1, JavaScript fully enabled....weeeeeird...(and switching editors still doesn't bring up the options...)

Try erasing your cache--there is a ton of new Javascript and many of the files are the same name. Please let me know if that makes a different.

 

Thanks,

 

..Al

Share this post


Link to post
Share on other sites

This is pretty neat. I played around with the stuff in my profile, and it's pretty slick. Thanks for the upgrade!

 

I noticed that I no longer had a fast reply window at the bottom of each thread. If you had your setting set to display one, it got set back to "no", so if anyone else was wondering where their quick reply window went, you just need to co into your controls and click "Board Settings" and change "Display quick reply window when available" back to "Yes".

 

Chris

Edited by Jibbajaba

Share this post


Link to post
Share on other sites
Set your gender

Finally! Now we will be able to avoid misunderstandings and tailor our replies better. There should also be an icon for when a user is under 18 so we will be nicer to them and avoid giving them nightmares.

Share this post


Link to post
Share on other sites
This is pretty neat. I played around with the stuff in my profile, and it's pretty slick. Thanks for the upgrade!

I haven't spent much time playing with it yet, but this is one of the more heavily modified areas with this upgrade. I still need to spend a bit of time cleaning up that page.

 

I noticed that I no longer had a fast reply window at the bottom of each thread. If you had your setting set to display one, it got set back to "no", so if anyone else was wondering where their quick reply window went, you just need to co into your controls and click "Board Settings" and change "Display quick reply window when available" back to "Yes".

One of the changes with this version is to store your "Quick Reply" setting in the database. So the forum now remembers whether you want it open or closed. Previously this was just a cookie setting, so it wasn't permanent.

 

..Al

Share this post


Link to post
Share on other sites
It appears that you need to use IE if you want to use the "Insert Special Item" menu, attachments, and a few other features; they don't work in Firefox. :(

Maybe that's why "Edit Profile Information" has blank info for me and it won't accept new info.

 

Nope, that's not it. I just checked with IE 7 and I get the same thing:

 

"Authorization mismatch - please go back and try again. If you have been trying to access a function incorrectly, please use the proper method."

Edited by Random Terrain

Share this post


Link to post
Share on other sites
It appears that you need to use IE if you want to use the "Insert Special Item" menu, attachments, and a few other features; they don't work in Firefox. :(

Maybe that's why "Edit Profile Information" has blank info for me and it won't accept new info.

 

Nope, that's not it. I just checked with IE 7 and I get the same thing:

 

"Authorization mismatch - please go back and try again. If you have been trying to access a function incorrectly, please use the proper method."

No, that was just quite broken. I paid someone to help me convert the skin from the older version of the software and unfortunately some of these pages were obviously converted properly. I'm going to have to go through them one at a time to make sure stuff isn't either A) missing or B) totally broken.

 

It should work now, please try it again! :)

 

..Al

Share this post


Link to post
Share on other sites
Thanks. Yep, it seems to be working, but it won't let me keep my birthday blank.

Fixed. :)

 

..Al

Share this post


Link to post
Share on other sites

Two things I've been experiencing with the new forum software:

 

(1) When I view a thread, I get a popup window about a script error, saying "ipsmenu" is undefined. It seems to pop up once for each post in the thread.

 

(2) I just used a smiley :) in a reply, but it didn't show up as a smiley.

 

Michael

Share this post


Link to post
Share on other sites

I really like the new upgrade!! I like that you can add your friends and see who has visited your profile! :) Thanks Al!!!

Share this post


Link to post
Share on other sites
Two things I've been experiencing with the new forum software:

 

(1) When I view a thread, I get a popup window about a script error, saying "ipsmenu" is undefined. It seems to pop up once for each post in the thread.

This I will have to look at. Can you send me a screenshot showing the complete error? One thing I would recommend is to empty your browser cache, as quite a bit of javascript changed with this new version. It's possible that will fix the error.

 

(2) I just used a smiley :) in a reply, but it didn't show up as a smiley.

Whoops, I hadn't properly imported the smiles from the old forum. They should all be there now.. :)

 

..Al

Share this post


Link to post
Share on other sites
Thanks. Yep, it seems to be working, but it won't let me keep my birthday blank.

Fixed. :)

No more problems so far. Thanks.

 

I thought you might want to know that the Firefox add-on called Firebug is showing an error or two once in a while as I browse the site.

Share this post


Link to post
Share on other sites
I really like the new upgrade!! I like that you can add your friends and see who has visited your profile! :) Thanks Al!!!

I second the friend list. I think it might had been there before, but I never used it. Anyhow it's cool how you can do one click and see when everyone was last online, and PM them with one more click!! Still playing around with all this new stuff. Was there a personal gallery before? I got to try that out.

 

~Omega

Share this post


Link to post
Share on other sites
Two things I've been experiencing with the new forum software:

 

(1) When I view a thread, I get a popup window about a script error, saying "ipsmenu" is undefined. It seems to pop up once for each post in the thread.

This I will have to look at. Can you send me a screenshot showing the complete error? One thing I would recommend is to empty your browser cache, as quite a bit of javascript changed with this new version. It's possible that will fix the error.

I just cleared my cache, and the "runtime error" popup is gone! :cool: So that means I can't send you a screenshot of it. :( (Not that it's needed *now*, of course! ;))

 

Michael

Share this post


Link to post
Share on other sites
. . . see who has visited your profile!

Only perverts and weirdos would look at my profile, so I am glad I can finally make a list and give it to the government.

Share this post


Link to post
Share on other sites
Thanks. Yep, it seems to be working, but it won't let me keep my birthday blank.

Fixed. :)

No more problems so far. Thanks.

 

I thought you might want to know that the Firefox add-on called Firebug is showing an error or two once in a while as I browse the site.

I am using the Web Developer plug-in for Firefox and I see some CSS-related warnings and sometimes some Javascript errors. The CSS stuff will be relatively easy to fix, not sure about any crazy Javascript though. I already had a fun run-in with Javascript earlier tonight. :)

 

..Al

Share this post


Link to post
Share on other sites

How do you add an attachment? Is it with the "Insert Special Item" dropdown box? I can't get any of the dropdown boxes to drop down. :(

 

Michael

Share this post


Link to post
Share on other sites
How do you add an attachment? Is it with the "Insert Special Item" dropdown box? I can't get any of the dropdown boxes to drop down. :(

 

Michael

Underneath the post editor is an "Attachments" section. I have attached a screenshot of what it looks like for me in Firefox. Are you not seeing this?

 

Picture_8.png

 

..Al

Share this post


Link to post
Share on other sites

Al, I know you don't like it, but how about letting the names of the members online keep on sorting like it is now? I like it as I can quickly glance who is posting currently or who is mostly offline. Anyhow if that could be a personal preference option it'd be sweet.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...