Jump to content
remowilliams

Satandisk SD/MMC card HD interface

Recommended Posts

Maybe I was not clear enough: with TOS 1.02 loading of BigDOS from C:\AUTO works not. Did you try with 2.06 (installed in RAM)?

Got it, just tried that and it does work.

 

To make F19 run at 60Hz we need only one command (add to source, then assemble): MOVE.B #2,$FF820A.W

 

I added launcher for 60Hz in archive: F19RD60.TOS

Thanks for taking a look at that! I ran it though and it flipped the desktop to 50hz and F19 is still at 50hz.

 

I think my problem with HDDRIVER 8.20 TOS/FAT is much bigger than I had previously thought. No matter what I do I can't get the ST itself to read/write to the Satandisk MMC after it's formatted TOS/FAT. It may just not work at all. Running BigDOS after HDDRIVER floppy boot will let me see things I wrote to the TOS/FAT card on the PC, but of course the ST is all hosed after doing so.

Share this post


Link to post
Share on other sites
Thanks for taking a look at that! I ran it though and it flipped the desktop to 50hz and F19 is still at 50hz.

 

Well - some games are made for specific framerate (sometimes only because of distribution considerations - to allow not users on other continent to play it! ).

I will try to find where is framerate switch in game, but it may be not easy, and there is a chance that it will not work at all after changes (because of bad timing).

You should look after US version of game. I have Starglider US version which resets if is started from 50Hz, but there is European version on WEB too - for instance on some Automation menu disk.

Share this post


Link to post
Share on other sites

I got mine. It's really cool! I just wish there was an easier way to mount .st disk images to install demos and such... i'm running an STE w/ tos 1.6

Share this post


Link to post
Share on other sites

this run is over with no plans on a second one. There's another thread where someone is proposing making a new run of them.

 

Nathan

Share this post


Link to post
Share on other sites
I got mine. It's really cool! I just wish there was an easier way to mount .st disk images to install demos and such... i'm running an STE w/ tos 1.6

 

There is now version of IMGRF (Image Runner Fast) for TOS 1.06/1.62 .

http://www.ppest.org/atari/imgrun.php

Edited by ppera

Share this post


Link to post
Share on other sites

Hello Atarians,

 

I am new to this channel, but actually I am an old Atarian, using Atari since 1983. I have almost bought all models of Atari ever released.

I am not a collector.

 

 

Some weeks ago, I bought a second hand Satandisk and I have succesfully formated the SD with HDDriver 7.80. It runs great !! Lovely piece of hardware.

 

Now, I read that there is a software that can be used to transfer files from my PC to the Atari formatted SD and it's called: satandisk pperas drimus ??!!??

 

As the site is not working anymore, could you please send it to my email, or place it somewhere to download it ?

 

Thank you all and nice to meet you.

Share this post


Link to post
Share on other sites
I got mine. It's really cool! I just wish there was an easier way to mount .st disk images to install demos and such... i'm running an STE w/ tos 1.6

 

There is now version of IMGRF (Image Runner Fast) for TOS 1.06/1.62 .

http://www.ppest.org/atari/imgrun.php

 

Odd. When I click on that link I get a pest control website.... :)

Share this post


Link to post
Share on other sites
Hello Atarians,

 

I am new to this channel, but actually I am an old Atarian, using Atari since 1983. I have almost bought all models of Atari ever released.

I am not a collector.

 

 

Some weeks ago, I bought a second hand Satandisk and I have succesfully formated the SD with HDDriver 7.80. It runs great !! Lovely piece of hardware.

 

Now, I read that there is a software that can be used to transfer files from my PC to the Atari formatted SD and it's called: satandisk pperas drimus ??!!??

 

As the site is not working anymore, could you please send it to my email, or place it somewhere to download it ?

 

Thank you all and nice to meet you.

 

Umm, you do know that you can format a 1 gig SD card so that its both Atari and Windows compatible, right? Not sure what version of HDDriver you have to have though. I've got 8.15 (need to update), and it works with that.

 

Here is a link - read it for the guide. I used it and it worked fine with my setup:

 

http://www.atari-forum.com/viewtopic.php?f=15&t=15764

Share this post


Link to post
Share on other sites
Hello Atarians,

 

I am new to this channel, but actually I am an old Atarian, using Atari since 1983. I have almost bought all models of Atari ever released.

I am not a collector.

 

 

Some weeks ago, I bought a second hand Satandisk and I have succesfully formated the SD with HDDriver 7.80. It runs great !! Lovely piece of hardware.

 

Now, I read that there is a software that can be used to transfer files from my PC to the Atari formatted SD and it's called: satandisk pperas drimus ??!!??

 

As the site is not working anymore, could you please send it to my email, or place it somewhere to download it ?

 

Thank you all and nice to meet you.

 

Umm, you do know that you can format a 1 gig SD card so that its both Atari and Windows compatible, right? Not sure what version of HDDriver you have to have though. I've got 8.15 (need to update), and it works with that.

 

Here is a link - read it for the guide. I used it and it worked fine with my setup:

 

http://www.atari-forum.com/viewtopic.php?f=15&t=15764

 

Thank you very much for your answer.

I formatted the 512MB SD to FAT via the PC, then I created a partition to my Atari (using HDDriver 7.80), now the SD is accesible from PC and Atari as you said. The only problem I face is that I cannot boot from the SD. So, I boot from a floppy disk, HDDRIVER finds the SD and then I have access to the files inside the SD.

 

I had experienced hard disk problems with this STE in the past. It's possible that I have the version of the problematic DMA chip, I am not sure.

 

Anyway, thanks a lot for your advise.

My Atari is a 1040 STE 4MB with TOS 2.06.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...