Jump to content
jwierer

Visual bB 1.0 - a new IDE for batari Basic

Recommended Posts

For some reason my VbB is very slow, it takes > 20s to type a character. Very strange. I'm on win 7.

 

Coolcrab, maybe that is not your case, but I noticed Visual bB is slow like that when I load a sample file that has too many comments using semicolons. To "fix" that, I open the file using another text editor and replace all ";" to "rem". That woked for me.

 

I hope that helps

 

Paulo

 

Update: Didn't see the answers after posting that :) woops...

Edited by pedgarcia

Share this post


Link to post
Share on other sites

Coolcrab, maybe that is not your case, but I noticed Visual bB is slow like that when I load a sample file that has too many comments using semicolons. To "fix" that, I open the file using another text editor and replace all ";" to "rem". That woked for me.

 

Are you using build 568? It shouldn't do that.

Share this post


Link to post
Share on other sites

There are several questions here, though the first one is the most important, the others are only minor questions.

 

I don't know if anyone has had this happen to them, but for some reason, when I opened my project in Visual bB, My default.bas was completely gone... well not gone, but all of the text in it was gone, I have no idea what happened, I didn't do anything to it yesterday, not only that, but now I can't even open the sprite for Player 0, all of my code is gone,

 

also, before that ever happened, yesterday I couldn't compile the default.bas (this happened the day before, when the code was still there before it vanished)

it told me that it "could not locate sed.exe"

 

also, just a small little question about sprites, you know that Halo Master Chief sprite? (from Halo 2600) I notice the helmet towards the middle has yellow and green in the same horizonal line, despite the limitations of the A2600, how was that done? I don't know if its possible to do that in PlayerPal or Visual bB's sprite editor...

 

is there a programming trick that would allow for multiple sprites on screen without flickering? (like Saboteur, Berzerk, Phoenix, etc)

Share this post


Link to post
Share on other sites

I don't use VbB at all, so I will let someone else answer about that part - although you may want to search your drove for default.bas in case your working copy is around elsewhere.

 

If you ever want to see how anything is drawn in an existing game, you can enable "debug colors" in Stella (control-comma on PC; command-comma on Mac). In the case of the Master Chief sprite, it looks like he is drawn using the player 0 sprite, and the ball. The background objects are copies of the player 1 sprite. This can be done in bB if you use the multisprite or DPC+ kernel.

 

post-48311-0-44774500-1537469587.png

 

post-48311-0-13542300-1537469509.png

Share this post


Link to post
Share on other sites

The 2600 has only a few resources that can be drawn (besides then playfield) across the screen: 2 sprites, 2 missiles and the ball. In batari BASIC game makers experience these objects as 2 8 pixel wide sprites and three rectangular solid boxes. But, at a hardware level it's more like these are five different crayons that can be dragged across the screen. Ed Fries chose to draw the player layer by layer with one crayon then switched to another part way through the helmet area with a different crayon. So, he wasn't breaking any rules getting the player sprite to be two colors on the same line.

Share this post


Link to post
Share on other sites

Well, that's interesting, it's nearly just like drawing sprites on the Colecovision, which if you want to the sprite to be more than one color, you kinda have to draw several sprites on top of the main sprite, each with different details, pretty cool,

 

Thank You!

Share this post


Link to post
Share on other sites

There are several questions here, though the first one is the most important, the others are only minor questions.

 

I don't know if anyone has had this happen to them, but for some reason, when I opened my project in Visual bB, My default.bas was completely gone... well not gone, but all of the text in it was gone, I have no idea what happened, I didn't do anything to it yesterday, not only that, but now I can't even open the sprite for Player 0, all of my code is gone,

 

also, before that ever happened, yesterday I couldn't compile the default.bas (this happened the day before, when the code was still there before it vanished)

it told me that it "could not locate sed.exe"

Are you using the latest version of bB (reveng41) and VbB (Build 568)?

 

Getting Started

 

How to 'Install' Visual batari Basic on a Windows PC

 

Also, I wonder if this would be helpful:

 

My .bin file can't be found (default.bas.bin can't be found)

 

If VbB is actually deleting your files, something is terribly wrong.

Share this post


Link to post
Share on other sites

Did find a "default.inc" in my folder, would that have anything to do with the code vanishing?

 

I'd make sure you have the latest bB and VbB, then see if anything changes. Also, did you look in your project folder using a real File Explorer folder and see what was there?

Share this post


Link to post
Share on other sites

Curious. I had an instance where VbB froze and when the next time my program loaded everything seemed okay nut when I went tO compile the program said it couldn't find the .bin.

 

I saw that the file missing from my folder. I saved the .bas as another name and tried again but the same thing happened again.

 

Has anyone ever had this happen?

Share this post


Link to post
Share on other sites

Curious. I had an instance where VbB froze and when the next time my program loaded everything seemed okay nut when I went tO compile the program said it couldn't find the .bin.

 

I saw that the file missing from my folder. I saved the .bas as another name and tried again but the same thing happened again.

 

Has anyone ever had this happen?

 

If I remember correctly, the only times the VbB/bB combination froze on me when compiling was when I did something goofy like not having a then in an if-then or something like that.

Share this post


Link to post
Share on other sites

I was interested in that. I figure once I am done with Bag Boy I may learn something else. I really like vbB and it has been a wonderful teaching tool so hopefully I can graduate.

 

Luckily it looks like all my code is good and other .bas files I loaded compiled so I might just copy it all into a new file and see if that works. It would suck to have to redo a weeks worth of work.

Share this post


Link to post
Share on other sites

Hmm. I just booted it up and was all cool. I'll just be certain to do more back ups just in case.

Share this post


Link to post
Share on other sites

 

If I remember correctly, the only times the VbB/bB combination froze on me when compiling was when I did something goofy like not having a then in an if-then or something like that.

Yeah. I had an asterisk at the end of a sentence. I accidentally deleted the number after it and noticed too late.

Share this post


Link to post
Share on other sites

I have problem to run it with Windows 10 64 bits - always i have info, that it isn't valid version for my system ;/

O.K. I got it ;)

Edited by Sikor
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...