Jump to content
jwierer

Visual bB 1.0 - a new IDE for batari Basic

Recommended Posts

Did you save your .bas file before compiling? You don't have "Save open files before compiling" checked in your settings.

Share this post


Link to post
Share on other sites
As far as I can tell it's just a problem with your code. Technically it will compile, but it's not going to show anything for a multisprite kernel.

Good catch! With the multisprite kernel, the "playfield:" statement uses only 16 "." and/or "X" characters across, because the playfield isn't asymmetric.

 

Michael

Share this post


Link to post
Share on other sites
Have you tried closing VbB and restarting it? The only problem I've had that is similar to this is when I screw up the code of a program with some silly mistake and the bin file can't be found because it didn't compile. If you try it with a .bas file that is error-free that you know is working properly and you still get the error, I don't know what to tell you. If all paths are correct, your program has no errors, and you have that .NET Framework 3.0 stuff on your computer, it should be working.

Yes, I restarted the program. The path files are correct, and when I clicked the link provided for .NET Framework 3.0, after downloading, when I tried to install it, it said it detected that I already had it and refused to install.

As far as I can tell it's just a problem with your code. Technically it will compile, but it's not going to show anything for a multisprite kernel. This is what I think you want to accomplish.

Technically I was just trying to see if that would run, and then if it did I would write real programs on the VbB editor. Oh, and if it's not to late to add it, the bB editor has a Multisprite Playfield Editor that produces playfield code that's 16 bits across. In the VbB editor I clicked on the Mirrored Playfield button, but when I right clicked and chose Grab Playfield ->Pixels it still gave me the full 32 bits. Maybe you could add a way to only grab the first 16 bits across.

BTW if compilation succeeds it will tell you in the message area on the bottom. From your screenshot I can only see it's started. BTW no need to put quotes around path, I handle that internally. Also since you know Qbert compiles you can create new project and copy the code into a .bas file. If you right click on the .bas file from the explorer you can generate items and it will create all the sprites and playfields that are in the code so you don't have to recreate them from scratch.

I'm not sure what you mean by putting quotes around the path. And I used the Crimson Editor for QBert.

Did you save your .bas file before compiling? You don't have "Save open files before compiling" checked in your settings.

I manually saved everything yes. I also tried checking it in the settings. Still no go.

As far as I can tell it's just a problem with your code. Technically it will compile, but it's not going to show anything for a multisprite kernel.

Good catch! With the multisprite kernel, the "playfield:" statement uses only 16 "." and/or "X" characters across, because the playfield isn't asymmetric.

Michael

Yeah, like I said, it's funny that I'm writing a program using the multisprite kernel and know it's only 16 bits across but failed to miss my mistake here. Anyway, fixing the code doesn't work either.

Share this post


Link to post
Share on other sites
Yeah, like I said, it's funny that I'm writing a program using the multisprite kernel and know it's only 16 bits across but failed to miss my mistake here. Anyway, fixing the code doesn't work either.

I might have missed it, but did you say that you tried another bB program that you know will work? For example, here's another program:

 

double_click_draw_2008y_03m_22d_1100.bas

 

If you download that and try to run it in VbB, do you still get an error?

Share this post


Link to post
Share on other sites

Still can't find the binary. I'm not even sure it creates one.

 

Just curious, why does Crimson Editor you have use 2600bas.bat, but the instructions for the visual IDE have you point to 2600basic.exe directly?

Share this post


Link to post
Share on other sites
Still can't find the binary. I'm not even sure it creates one.

 

Just curious, why does Crimson Editor you have use 2600bas.bat, but the instructions for the visual IDE have you point to 2600basic.exe directly?

 

If you just call the .bat file you can't grab all the error messages. VbB effectively does what the bat file does but checks the outputs for errors after each step. This was the best way I could figure out where the error occured. The only thing I can think of is you have some permissions issue preventing it from calling the executable. I can't see the output from your so I can't see what it's returning to you. From the Window it looks like XP? If it were Vista I would have suggested trying running as administrator. In your folder where you have 2600basic.exe do you have all the other files? 2600basic.exe won't be enough alone.

 

This is the contents of my bb folder

 

Directory of F:\Emulation\VisualbB\bB

04/27/2008  12:39 PM    <DIR>          .
04/27/2008  12:39 PM    <DIR>          ..
03/27/2008  11:01 PM    <DIR>          includes
04/27/2008  07:57 AM    <DIR>          manual
03/09/2008  10:11 PM    <DIR>          samples
03/09/2008  02:58 PM    <DIR>          sed
03/09/2008  02:58 PM    <DIR>          source
02/09/2007  01:32 AM             1,448 2600bas.bat
05/26/2007  10:01 PM           152,251 2600basic.exe
02/14/2007  04:16 AM           148,927 2600basic1.0.exe
07/16/2003  12:03 AM           114,688 dasm.exe
02/14/2007  04:03 AM             1,594 license.txt
02/14/2007  04:16 AM            91,396 optimize.exe
02/14/2007  04:16 AM            93,933 postprocess.exe
02/14/2007  04:16 AM            94,719 preprocess.exe
02/14/2007  04:03 AM            16,218 README.txt
04/20/2008  02:50 AM             2,118 scoreformats.zip
04/14/2003  01:00 AM            49,152 sed.exe
03/27/2008  11:00 PM            80,097 updated_2600basic.zip
             13 File(s)        846,541 bytes
              7 Dir(s)  26,970,464,256 bytes free

Share this post


Link to post
Share on other sites
Still can't find the binary. I'm not even sure it creates one.

 

Just curious, why does Crimson Editor you have use 2600bas.bat, but the instructions for the visual IDE have you point to 2600basic.exe directly?

 

If there was a bin you would see a sub folder "bin". I wonder if you don't have write permissions to create the sub folder? I am not sure it checks for that.

 

-Jeff

Share this post


Link to post
Share on other sites

Yes, I'm running XP pro and I have full administrator rights.

Directory of C:\Program Files\Atari2600\bB

03/27/2008  09:54 PM    <DIR>          .
03/27/2008  09:54 PM    <DIR>          ..
02/09/2007  01:32 AM             1,448 2600bas.bat
05/26/2007  10:01 PM           152,251 2600basic.exe
04/27/2008  01:02 PM               231 2600basic_variable_redefs.h
04/27/2008  01:02 PM            28,293 bB.asm
07/16/2003  12:03 AM           114,688 dasm.exe
04/20/2008  10:07 PM    <DIR>          includes
04/27/2008  01:02 PM               148 includes.bB
02/14/2007  04:03 AM             1,594 license.txt
03/27/2008  09:25 PM    <DIR>          manual
02/14/2007  04:16 AM            91,396 optimize.exe
02/14/2007  04:16 AM            93,933 postprocess.exe
02/14/2007  04:16 AM            94,719 preprocess.exe
02/14/2007  04:03 AM            16,218 README.txt
04/27/2008  01:02 PM    <DIR>          samples
03/27/2008  09:25 PM    <DIR>          sed
04/14/2003  01:00 AM            49,152 sed.exe
03/27/2008  09:25 PM    <DIR>          source
             12 File(s)        644,071 bytes
              7 Dir(s)  118,129,889,280 bytes free

Here is the contents of the folder holding my test program

Directory of C:\Program Files\Atari2600\bB\samples\VbB Project 1\New Project

04/26/2008  04:09 PM    <DIR>          .
04/26/2008  04:09 PM    <DIR>          ..
04/27/2008  11:45 AM            10,966 default.bas
04/26/2008  06:32 PM               403 default.pla
04/26/2008  04:09 PM               126 default.spr
              3 File(s)         11,495 bytes
              2 Dir(s)  118,129,819,648 bytes free

Share this post


Link to post
Share on other sites
Yes, I'm running XP pro and I have full administrator rights.

 

I recreated your directory structure just to make sure and items compile fine. I'm not sure what's going on in your case. I may try it on my XP machine and see if it works differently.

 

Sorry,

Jeff

Share this post


Link to post
Share on other sites
Yes, I'm running XP pro and I have full administrator rights.

 

I recreated your directory structure just to make sure and items compile fine. I'm not sure what's going on in your case. I may try it on my XP machine and see if it works differently.

 

Sorry,

Jeff

That's OK, like any computer problem I have, hardware or software, it's most likely something very small, and very simple that I'm overlooking.

Share this post


Link to post
Share on other sites

It may sound stupid, but if I create a new project and like to edit the BAS file my font size is HUGE. I mean really HUGE :D

How can I resize it?

Share this post


Link to post
Share on other sites
It may sound stupid, but if I create a new project and like to edit the BAS file my font size is HUGE. I mean really HUGE :D

How can I resize it?

Did you click on the Settings tab? There's supposed to be a button with the words Select Font on it.

Share this post


Link to post
Share on other sites

This prompted me to take another look at bB. It's a good start! I tried putting the contents of the Stella, bB and VisualbB into a folder called C:\VBB. Next, I had to move sed.exe into the main VBB directory. Emulator field is C:\VBB\Stella.exe and bB compiler field is C:\VBB\Stella.exe The Add bB Environment Variable and Add bB Compiler to system Path check boxes are checked (although I didn't realize they had to be until I tried to compile once or twice). So far no luck on successfully compiling anything in the sample folder from bB. If I use the Project Wizard I am able to cut and paste the examples though. I can settle with that. This is not a cry for help or a complaint - just a bit of insight into the end-user experience :)

 

Interestingly, if I make sed.exe unavailable (take it out of the C:\VBB folder) and try to compile, VbB locks. I am running XP SP2.

 

Again, congrats on a good start! Now the simple folk stumble over user interface and value checking gaffs ^_^

Share this post


Link to post
Share on other sites
This prompted me to take another look at bB. It's a good start! I tried putting the contents of the Stella, bB and VisualbB into a folder called C:\VBB. Next, I had to move sed.exe into the main VBB directory. Emulator field is C:\VBB\Stella.exe and bB compiler field is C:\VBB\Stella.exe The Add bB Environment Variable and Add bB Compiler to system Path check boxes are checked (although I didn't realize they had to be until I tried to compile once or twice). So far no luck on successfully compiling anything in the sample folder from bB. If I use the Project Wizard I am able to cut and paste the examples though. I can settle with that. This is not a cry for help or a complaint - just a bit of insight into the end-user experience :)

 

Interestingly, if I make sed.exe unavailable (take it out of the C:\VBB folder) and try to compile, VbB locks. I am running XP SP2.

 

Again, congrats on a good start! Now the simple folk stumble over user interface and value checking gaffs ^_^

 

You're compiler should point to 2600basic.exe and sed.exe should be in the same folder as 2600basic.exe. The problem really is that batariBasic should already be configured correctly in order for vbB to work (see bB release notes). If you can't compile outside of vbB, it probably won't work in the IDE. One thing it does do is see if the environment variable is pointing to a location where batariBasic is installed. If you already had the environment variable pointing to a different directory bB is probably not going to work and hence you won't be able to compile in vbB either.

 

-Jeff

Share this post


Link to post
Share on other sites

Thanks for the feedback! As I stated before, I was able to generate a working/compiling project via the Project Wizard so all is well. I just noticed VbB would lock if the sed.exe wasn't found. It should deal with that more gracefully. However, it may just be my kludged setup that produces this behavior.

 

What would be nice is an unofficial distribution that includes Stella, bB and Visual bB pre-configured. Debugging everyone's configuration is less productive than debugging the program itself :)

 

For that matter, an enthusiast could make a VbB example project called "Northwinds Traitors" where one must battle waves of corrupted Access Server Killbots.

 

EDITED: For clarification.

Edited by theloon

Share this post


Link to post
Share on other sites
Thanks for the feedback! As I stated before, I was able to generate a working/compiling project via the Project Wizard so all is well. I just noticed VbB would lock if the sed.exe wasn't found. It should deal with that more gracefully. However, it may just be my kludged setup that produces this behavior.

No you are right. It definitely looks for the required components, but the logic for gracefully exiting is never called. That's a bug :(

 

Thanks,

Jeff

Share this post


Link to post
Share on other sites

Here's a few changes and bug fixes based on feedback. New build posted to first post

 

[New] Preview in multi-sprite Kernel

[New] You can now copy entire sprites/playfields (colors, pixels, heights)

[New] When working with a mirrored playfield it assumes you're working with a multi-sprite kernel and only copies half the screen

[New] You can remove items from the recent items list

[New] Added various keywords (step, bank, pop, etc..)

[New] Last browsed folder is persisted so you don't have to always start from the desktop when browsing for projects, items, etc...

 

[bug] Checks for pre-requsite compiler/assembler files and fails gracefully if any files are missing

[bug] Resizing mirrored playfields was not working. Now fixed

[bug] Playfields can now be set to a height up to 88 pixels high

[bug] Commenting last line of code caused an EOF crash

 

A few other small things.

 

-Jeff

Share this post


Link to post
Share on other sites

Here's a small update with a few bug fixes based on feedback.

 

New build posted to first post

 

[bug] If you tried to do a search and replace, in some cases vbB would hang

[bug] Tab order for replace form was wrong - this was annoying me

[bug] on Build 530 The color palette was brokken affecting Choose color is broken, Set Player Color, and Set Background Color

[bug] Right click on sprite or playfield should sets to. Bascially you don't have to left click on a cell first

 

[New] The color palette form will be set to the current row color of the sprite/playfield

[New] Playfield, Background, and Player colors are persisted so you don't have to set them everytime you launch vbB

[New] Right click on playfields allows you to chose either the standard or multisprite kernel

 

Maybe a few other things I forgot.

 

-Jeff

Share this post


Link to post
Share on other sites

Thanks for posting the latest version. I hope all VbB users will download this as soon as possible. VbB is even better than before. For example, when working on a multicolored sprite or playfield, if you want to know the color you used for a row, just right click on that row and the Hex number for the color will show up in the right click menu next to Set Color. Very useful if you want to reuse a color you've already chosen and can't remember what it was.

Share this post


Link to post
Share on other sites

Thanks to whoever pinned this. Much needed!

 

So, since I haven't read EVERYthing.. does everyone get an error message every time they exit VBB?

Share this post


Link to post
Share on other sites
Thanks to whoever pinned this. Much needed!

 

So, since I haven't read EVERYthing.. does everyone get an error message every time they exit VbB?

No error message for me unless you mean a message reminding you that you forgot to save your program.

Share this post


Link to post
Share on other sites

Mine says:

 

"InvalidArgument=Value of '0' is not valid for 'index'.

Parameter name: index

Try using regedit to remove HKLM\Software\VisualbB"

 

and I click OK and it exits fine. This happens after EVERY exit.

 

Thanks to whoever pinned this. Much needed!

 

So, since I haven't read EVERYthing.. does everyone get an error message every time they exit VbB?

No error message for me unless you mean a message reminding you that you forgot to save your program.

Share this post


Link to post
Share on other sites
Mine says:

 

"InvalidArgument=Value of '0' is not valid for 'index'.

Parameter name: index

Try using regedit to remove HKLM\Software\VisualbB"

 

and I click OK and it exits fine. This happens after EVERY exit.

When jwierer sees this, I bet he'll be able to figure it out.

Share this post


Link to post
Share on other sites
Mine says:

 

"InvalidArgument=Value of '0' is not valid for 'index'.

Parameter name: index

Try using regedit to remove HKLM\Software\VisualbB"

 

and I click OK and it exits fine. This happens after EVERY exit.

 

Thanks to whoever pinned this. Much needed!

 

So, since I haven't read EVERYthing.. does everyone get an error message every time they exit VbB?

No error message for me unless you mean a message reminding you that you forgot to save your program.

 

I wonder if that happens if you have no default projects set? I'll have to check and see if I don't do a check for that. It's a pretty innocuous error, though I could see that being annoying. Given what it says it happens when it's closing and trying to save settings back to the registry.

 

-Jeff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...