Jump to content
jwierer

Visual bB 1.0 - a new IDE for batari Basic

Recommended Posts

Is it normal that Visual bB needs to be launched in administrator mode ? Sounds strange... 🙄

 

(But works perfectly on my Win10 computer)

Share this post


Link to post
Share on other sites
1 hour ago, Yoruk said:

Is it normal that Visual bB needs to be launched in administrator mode ? Sounds strange... 🙄

 

(But works perfectly on my Win10 computer)

 

I remember needing to do that on one of my computers over the years. Don't remember if I had to do it on my latest computer.

 

Make sure Load Start Web Page on Open is turned off on the settings page. If you enable it, you'll get a ton of error messages and will probably have to close the program using your computer's Task Manager. Don't try to load any web page with VbB. Use a real browser:

 

https://www.randomterrain.com/atari-2600-memories-batari-basic-vbb.html#trouble_ton_of_error_messages

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, Random Terrain said:

Make sure Load Start Web Page on Open is turned off on the settings page. If you enable it, you'll get a ton of error messages and will probably have to close the program using your computer's Task Manager. Don't try to load any web page with VbB.

 

Yes I've done that ! I have the web page displayed into Firefox. 😃

Share this post


Link to post
Share on other sites

anyone tried to run it on wine or mono, on gnu/linux? not running here, wine here is version 5.0.3, and mono is 6.8.0.105 - gnu/linux distribution is ubuntu, version 21.04

Share this post


Link to post
Share on other sites

Just a heads up on those swanky M1 Mac and/or Windows 10 ARM users:  I got it to work after a few tries.  As usual no definite steps just a "what worked in the last attempt" explanation.

 

First problem was some versions of Windows 10 ARM don't install .net 3.5.  You can force the issue by making it revert to a known working Windows 10 ARM build as documented at Parallels:

https://kb.parallels.com/125526

 

Once you have .net 3.5 installed try copying an earlier version of VisualbB to your batari BASIC folder.  I used version 544 downloaded here:

https://atariage.com/forums/topic/123849-visual-bb-10-a-new-ide-for-batari-basic/

 

Launch VisualbB and set the usual settings (disable the web page stuff, set NTSC or PAL, select a mono-spaced font etc..) and then close down VisualbB.

 

Download the latest version of VisualbB and overwrite the files in your batari BASIC folder.  Basically, we just wanted the older working VisualbB to correctly integrate its settings into the registry.  The newer VbB has problems either related to permissions or the registry branches that get created for compatibility.

 

If you're using Parallels to get Windows 10 ARM working I'd suggest doing all this VERY first thing after creating the virtual machine.  I suspect that also goes for bare bones Windows 10 ARM machines as well.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...