Jump to content
Sign in to follow this  
Atari5200

Turbo Express sound problem question

Recommended Posts

I just bought a Turbo Express knowing the sound would only work via head phones. From what I understand this is a common problem with the product. But the price was good and it came with some stuff, anyway, here is my question.

 

Is the issue mainly with a solder point or something that the speaker just got disconnected and will resoldering it fix the problem, or is there more to it than just a simple connection being broken?

Share this post


Link to post
Share on other sites

IIRC the problem is the bad capacitor that needs to be replaced. My Express has the same problem, but I never fixed it. I'd like to hear if anyone has successfully fixed one. There are instructions online.

 

Tempest

Share this post


Link to post
Share on other sites
yeah, doesn't look that bad, I might even try it myself.

It is not easy! Those pics make it look much easier than it is, because you forget how small everything is when you're looking at them... A friend of mine who has spent a large part of his adult life with a soldering iron in his hand helped me do mine, and it was about as much fun as a root canal... :(

Share this post


Link to post
Share on other sites

If you do not want to attempt the fix yourself you may want to drop Omne a pm. He did a great job fixing up mine.

Share this post


Link to post
Share on other sites

well I got my Turbo Express and the sound works, so...I guess it fixed itself from the time the seller packed it until it arrived to me.

Share this post


Link to post
Share on other sites

It's really not that hard of a fix. I've done like 5-6 units over the years. You just need to watch how the case halves line up so that your replacement cap sits comfortably.

Share this post


Link to post
Share on other sites

I wouldn't use the same cap if i need to do it again, I'd do like what was posted above, and use 3" wire and tuck it in some open space. But I guess lucky enough for me, I don't have to worry about it for now.

Share this post


Link to post
Share on other sites

Theres A moderator that goes by the name of nat in the pc engine fx forums.Even though I don`t really visit that site anymore.,The guy just seems to be A wiz at fixing anything that mite be wrong with A turbo express or A turbo grafx.Usually he does it for free.You just pay the postage to send it to him.I have sold him A few pc engine and turbo grafx games over the years,and he`s pretty trust worthy.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...