Jump to content
Sign in to follow this  
cybercylon

Any colecovision AV mods bypass the RF box?

Recommended Posts

The daughter card to the RF modulator to my colecovision is pretty much toast.

 

http://www.atariage.com/forums/index.php?s...=148150&hl=

 

Are there any AV mods that can bypass the box all together. I know you can get sound directly from the chip, but what about video.

 

Or maybe one of you modders have extra daughter cards around.....

 

I'd rather not ebay for a new console unless I have to.

 

Jason

Edited by cybercylon

Share this post


Link to post
Share on other sites

The A/V mod I did on mine years ago was tapped directly from the audio/video chips. I didn't go inside the rf module like some people do. You do need some other parts( resistors/capacitors) in between to get the signal levels right.

Share this post


Link to post
Share on other sites
The A/V mod I did on mine years ago was tapped directly from the audio/video chips. I didn't go inside the rf module like some people do. You do need some other parts( resistors/capacitors) in between to get the signal levels right.

 

The daughter board contains a chip which converts the color difference signals off the TMS9928 to composite.

 

The TMS9918 chip is identical but puts out composite natively instead of using a color diff output.

 

If you want to skip the RF board, the easiest way to do so would be to find a TMS9918A chip on eBay, clip pins 35 and 37 off completely (don't connect them to the board), and bend pin 36 up and to the side instead of setting it in the board.

 

Tie Pin 36 to ground by way of a 470 ohm resistor. At this point, pin 36 itself will then supply a great composite signal. You don't even have to run it through DC removal or impedance matching as its all in the chip.

 

This produces a great signal. But you'll lose video and audio from the Atari 2600 expansion module.

 

Good luck.

Share this post


Link to post
Share on other sites

I think my life just got made easier...

 

I have video back again. In my messing around, there were a couple of breaks in the solder joints for the IC on the RF board.

 

Still no sound (sound like an empty channel), but it appears that I can capture the video from the RF board after all using the various methods out there, and hopefully I can get my sound directly from the chip.

Share this post


Link to post
Share on other sites

Well, I'm back up and running using one of the composite AV mods. Turns out the chip on the daughter card was fine.

 

Now I see that gives you a nice composite signal for expansion model 1, but as I expected, no sound since I am directly taking the sound from the chip in the CV. I'm sure I could do the same from the expansion model (I'm assuming you can grab it from the TIA), but that is a challenge for another day.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...