Jump to content
R.Cade

Atari 800 Emulation in Windows 7/Vista

Recommended Posts

What are you guys using for modern OS's. Atari800WinPlus 4.0 and 4.1 have screwed up colors in full-screen mode for me, and Atari800 SDL version complains about something video related. Both work fine in Windows XP for me on the same PC.

Share this post


Link to post
Share on other sites
What are you guys using for modern OS's. Atari800WinPlus 4.0 and 4.1 have screwed up colors in full-screen mode for me, and Atari800 SDL version complains about something video related. Both work fine in Windows XP for me on the same PC.

 

I use Win800plus 4.1, and 4.0 before, on Vista and it's fine with either, never had a problem with it (as far as that's possible on Microsoft bloatware ;) ). Maybe a graphics card driver update? Did you force XP drivers to install for Vista?

 

I have no interest in Win 7 so sorry can't help with that.

Share this post


Link to post
Share on other sites

Well I've had the same problem in W7 with screwed up colours in full screen mode. I have no solution but I have a workaround. Start A800WinPlus, Go into the taskmanager "processes" tab and shut down the "explorer" process, this will kill the "framework" of W7 and you can then turn off the taskmanager and alt-tab to the emulator and go into fullscreen mode. Works fine here. When you're done playing, bring up the taskmanager again and go to File/Run and put in explorer.exe presto, everything's back to normal.

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem, with Windows 7 and full-screen having distorted colors. That workaround you mentioned is cool, but worrisome in that you have to kill the Windows 'kernel' process in order to get it working. I hope someone fixes this issue!

Share this post


Link to post
Share on other sites

I was going to install 7 today. Have you tried the XP compatibility option?

 

Same result. Even tried with a non-Aero enabled laptop and still no luck. Screen flashes at the edges and then a complete colour palette issue occurs. Bit of a pain if the author is no longer updating it as it is the best A800 emu I've come across to date.

Share this post


Link to post
Share on other sites

Same palette bug occurs with Atari800. Seems to be an SDL related full-screen bug with Windows 7. This also seems to occur with DOSBOX as well, which uses SDL too. Only option so far is to use Altirra which works fine in any display mode. Hopefully, SDL will be fixed at some point.

 

Hope that helps.

Edited by Daze

Share this post


Link to post
Share on other sites

Yes, it does that in other emulators as well. I just use Altirra now and no problems at all. It's a nicer emulator, and still updated.

Share this post


Link to post
Share on other sites

Well I've had the same problem in W7 with screwed up colours in full screen mode. I have no solution but I have a workaround. Start A800WinPlus, Go into the taskmanager "processes" tab and shut down the "explorer" process, this will kill the "framework" of W7 and you can then turn off the taskmanager and alt-tab to the emulator and go into fullscreen mode. Works fine here. When you're done playing, bring up the taskmanager again and go to File/Run and put in explorer.exe presto, everything's back to normal.

 

That's a pretty cool workaround. The weird colors have been driving me batty and that works great. I don't mind the extra step to turn explorer off and back on again.

 

Thanks for the tip! :) +1 Rep points for you!

Edited by Deteacher

Share this post


Link to post
Share on other sites

What are you guys doing about the aspect ratio, in full-screen mode?

 

One of the things that turns me off THE MOST about emulation - now that every blinkin' laptop and desktop monitor has gone "widescreen" is the damn emulated system screen is stretched in full screen on everything. Damnit, I was some kind of sorry when everyone abandoned 4:3 displays. If anything, I'd rather have "tall screen" for viewing more of a web page or PDF page. I don't watch movies on my PC, nor do I intend to.

 

But I can't stand when it stretches things out to fill the screen. I wish the emulators included an option to toggle on/off some vertical black bars on the sides, to emulate the proper (for classic systems) aspect ration on these friggin' wide screens.

Share this post


Link to post
Share on other sites

That's a pretty cool workaround. The weird colors have been driving me batty and that works great. I don't mind the extra step to turn explorer off and back on again.

 

Thanks for the tip! :) +1 Rep points for you!

 

Glad to be able to help :)

Share this post


Link to post
Share on other sites

I signed into this site to say that I love everyone who suggested Altirra as I was banging my head against the wall for over a year... also, coincidentally, I've been calling myself RKade on forums for a decade now. That's all I wanted to say, I'm going back to fun.

Share this post


Link to post
Share on other sites

What are you guys doing about the aspect ratio, in full-screen mode?

 

Still wondering if people:

 

(1) Like playing in a little window (surrounded by a junky desktop) so they can see proper aspect ratio

 

or

 

(2) Play full-screen, with everything stretched and looking short/fat, in order to fill the widescreen (and you don't mind this)

 

or

 

(3) Is there an emulator that will "fullscreen" at the proper aspect ratio, by placing "black bars" (or whatever) at the sides of the widescreen, appropriately, to recreate the Atari's original aspect ratio.

 

Am I the only person who likes FULLSCREEN WITH PROPER ASPECT RATIO? I never see anyone talk about it. It's what the real Atari did. It's what I'd like my emulator to do. Damn "widescreen" PCs today have created this problem that doesn't seem to bother anybody else. :? :? :? :? :? :?

Share this post


Link to post
Share on other sites

Well it bothers me, and it bothered so much that I've implemented a solution to the problem in Atari800 :-) Once you configure the aspect ratio of your monitor (Display settings->Video mode settings->Host display aspect ratio) and set the appriopriate method of screen stretching (Display settings->Video mode settings->Image aspect ratio set to Authentic), the display will have correct aspect ratio regardles of fullscreen resolution you choose.

 

Altirra has a similar option (View->Stretch Mode->Preserve Aspect Ratio).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...