Jump to content
batari

Latest Harmony Cart software

Recommended Posts

Guess those PAL versions are still 60Hz then

 

 

Yep - you can tell if you run the game in Stella and hit the Developer Key to toggle frame stats (ALT-L on Linux/Windows or COMMAND-L on Mac). Format will be shown in the top-left corner as NTSC, PAL, SECAM, NTSC50, PAL60, or SECAM60.

 

post-3056-0-34101300-1522442974_thumb.png post-3056-0-16099700-1522442989_thumb.png

  • Like 1

Share this post


Link to post
Share on other sites

Another question.. What can be the cause if your batari Basic DPC+ game works perfectly in stella but stopped working on the harmony and just spin/load the whole time and never starts?

I can upload the game if that helps.

Share this post


Link to post
Share on other sites

Somehow the Harmony is failing then. Odd size maybe?

 

Or bankswitch detection crashed (just guessing this can even happen). Try giving it a bankswitch type suffix.

Edited by Thomas Jentzsch
  • Like 2

Share this post


Link to post
Share on other sites

Looks like you have an Encore, earlier versions of the DPC+ driver (the first 3K of the game) have a compatibility issue with it so that might be what you're encountering.

 

In reply 609 of Space Rocks I post some info of the issue as well as one way to fix problem games by replacing the DPC+ driver in the game. Another way is to hex edit the game, as mentioned in reply 339 of the Encore topic.

  • Like 1

Share this post


Link to post
Share on other sites

By DPC+ Kernel I suspect you're talking about batari BASIC, if so would need to ask about that in the bB forum.

Share this post


Link to post
Share on other sites

Hello.

 

I've just received my Harmony Encore today, it works fine but I have color problem (green comes pink for instance).

I have a 2600jr Pal. I assume I need to try the Pal firmware but I'm on 1.06 NTSC (default shipping).

Which firmware should I try ? I'd like to try a PAL 50hz.

I'm on RF and I have a Trinitron 21" which works perfect with all other consoles (even NTSC ones but on Scart and composite, don't know about RF)

Thanks for your help

Share this post


Link to post
Share on other sites

AFAIK 1.06 was never released for PAL. But except for the Harmony menu itself, this doesn't matter at all. The games play completely independent from the firmware colors.

Share this post


Link to post
Share on other sites

I've just received my Harmony Encore today, it works fine but I have color problem (green comes pink for instance).

I have a 2600jr Pal. I assume I need to try the Pal firmware but I'm on 1.06 NTSC (default shipping).

 

 

The problem's not the firmware on the Harmony, it's running a ROM meant for the NTSC console. Find the ROM for the PAL version of the game and you'll be OK.

 

See Atari NTSC vs PAL vs SECAM for more info.

Share this post


Link to post
Share on other sites

 

The problem's not the firmware on the Harmony, it's running a ROM meant for the NTSC console. Find the ROM for the PAL version of the game and you'll be OK.

 

See Atari NTSC vs PAL vs SECAM for more info.

 

 

Ok thanks, that's what I thought. I used the Harmony Encore set from Everdrive packs and most of the roms are US ones. I'll try a full rom set with European ones to check, thanks

Share this post


Link to post
Share on other sites

So got a Harmony cart. It is currently running 1.03. I want to upgrade it to the latest, but cannot get any of my computers to see the Harmony. Tried Mac, Win10 64 bit and Win732 bit. The machine sees the cart and adds it as a com port, but the Harmony software will not see it. Any suggestions?

Share this post


Link to post
Share on other sites

Have you tried different USB cables?

Yes, 4 different ones including the heavy duty one from my 3D printer. It seems to see it in device manager, but not in Harmony.

Share this post


Link to post
Share on other sites

Here's what I am seeing. But the Harmony is not seeing the cart. Also seeing ERROR: no answer on '?' if I run the HarmonyCart.com version.

post-48098-0-70587300-1534977722.jpg

post-48098-0-41577800-1534977734_thumb.jpg

Edited by MMarcoux66

Share this post


Link to post
Share on other sites

When you plugin the Harmony cart, does the list in the device manager change? Is the entry in COM3 the Harmony cart? What do you get there for the details?

 

Does FT Prog allow flashing the cart? I don't know if anyone has ever tested this, but maybe that would be an alternative.

Edited by Thomas Jentzsch

Share this post


Link to post
Share on other sites

When you plugin the Harmony cart, does the list in the device manager change? Is the entry in COM3 the Harmony cart? What do you get there for the details?

 

Does FT Prog allow flashing the cart? I don't know if anyone has ever tested this, but maybe that would be an alternative.

 

Yes, 2 entries show up from the cart being connected. Com3 and USB Serial Converter. These both are using drivers by FTDI. I plugged it in the morning and it became COM6. However none of the other settings have changed. Here they are... I didn't mess much with the FT Prog as I didn't want to hose the card, but I believe it could be used to program this if someone knew how to do it.

post-48098-0-88747400-1535028019.jpg

post-48098-0-89037300-1535028029.jpg

Share this post


Link to post
Share on other sites

Looks like mine, except that bits per second is 115200.

 

You are using version 1.3. of the Harmony Programming Tool and Device/Connect doesn't help, correct?

Edited by Thomas Jentzsch

Share this post


Link to post
Share on other sites

Looks like mine, except that bits per second is 115200.

 

You are using version 1.3. of the Harmony Programming Tool and Device/Connect doesn't help, correct?

Yes, I am using version 1.3 of Harmony from Github. It will not connect when choosing that option. Just tried your bps setting and it didn't change it from not working.

Share this post


Link to post
Share on other sites

This was what I am seeing when I run the other HarmonyCart prog in the Program Files directory. It may mean something to the folks that created the program.

post-48098-0-93131900-1535044202_thumb.jpg

Edited by MMarcoux66

Share this post


Link to post
Share on other sites

Purchased the Harmony SD version, bios 1.6. Works great on my stock 4 switch woody, and DID work well on my stock 6 switch heavy sixer. However, I just installed the http://www.best-electronics-ca.com/composite mod upgrade kit on the heavy 6er, and now the joystick does not work on the menu anymore. Strangely my paddle controller AND Indy-500 steering controller DO work, though the paddle button is very hit and miss to launch games.

 

Can the firmware be upgraded to fix this anomaly? It's very frustrating to have to put a paddle in just to select a game, then once in-game, replace it with a joystick, then repeat for next game. Is is possible a prior firmware version DOES work well with joysticks, despite having composite-modded the unit?

 

I may replace a few of the caps on the heavy 6er PCB as part of routine maintenance, but I don't expect much change considering the Harmony worked fine before the mod. The mod involved removing the RF module, replacing 6 resistors with 4 different resistors, a diode, a transistor, and an adjustment pot that adjusts brightness/color saturation.

 

 

Share this post


Link to post
Share on other sites

Purchased the Harmony SD version, bios 1.6. Works great on my stock 4 switch woody, and DID work well on my stock 6 switch heavy sixer. However, I just installed the http://www.best-electronics-ca.com/composite mod upgrade kit on the heavy 6er, and now the joystick does not work on the menu anymore. Strangely my paddle controller AND Indy-500 steering controller DO work, though the paddle button is very hit and miss to launch games.

You can use the console switches (RESET and SELECT) alternatively

 

Can the firmware be upgraded to fix this anomaly? It's very frustrating to have to put a paddle in just to select a game, then once in-game, replace it with a joystick, then repeat for next game. Is is possible a prior firmware version DOES work well with joysticks, despite having composite-modded the unit?

IMO this is not a problem of Harmony but a problem of your mod.

 

Does it by chance modify controllers too? It might be, that the joystick is detected as something different now.

Share this post


Link to post
Share on other sites

You can use the console switches (RESET and SELECT) alternatively

 

IMO this is not a problem of Harmony but a problem of your mod.

 

Does it by chance modify controllers too? It might be, that the joystick is detected as something different now.

Yes, using 1.6, and SELECT and RESET are working options, thanks. The mod is supposed to only affect the video. But as we know, the 2600 is a video-timing-based machine, so it's possible the Harmony input polling routine is getting confused and thinking the joystick is a paddle. Once I launch a game, and replace the paddle with a joystick, all games play fine.

 

It would have been nice to allow player 2 port to control the Harmony game menu as well, so folks could leave a paddle controller in that port just for menu usage, but leave a joystick in port 1 for the actual gameplay. Sure, 2 player joystick games then require some swapping after load, but for single player, it would be a nice option.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...