Jump to content
Cliff Friedel

A400 Composite Mod

Recommended Posts

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

Share this post


Link to post
Share on other sites

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

 

This might be a start:

http://www.atarimagazines.com/v3n1/littlebrother.html

Share this post


Link to post
Share on other sites

the 400 is basically similar to the 800, only the main boards are majorly different (OS is on the 400 main, os is on cart for 800) so video upgrades should be very similar to the 800, if not identical...

 

sloopy.

Share this post


Link to post
Share on other sites

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

 

This might be a start:

http://www.atarimaga...tlebrother.html

 

but there are errors in those instructions, an errata was published in one of the later issues

Share this post


Link to post
Share on other sites

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

 

This might be a start:

http://www.atarimaga...tlebrother.html

 

but there are errors in those instructions, an errata was published in one of the later issues

 

Here is the correction. Looks like a misprint in the article. the circuit and the connecton points look fine to me.

 

http://www.atarimagazines.com/v3n4/help.html

Share this post


Link to post
Share on other sites

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

 

 

I shoe-horned the 8bitdomain 5200 A/V mod into my Atari 400. It gives very good SVideo and Composite output.

 

You can see the pictures in my gallery.

 

HTH

Share this post


Link to post
Share on other sites

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

 

 

I shoe-horned the 8bitdomain 5200 A/V mod into my Atari 400. It gives very good SVideo and Composite output.

 

You can see the pictures in my gallery.

 

HTH

 

Very nice... Any chance of a detailed how to, for those of us who are dense :D

Share this post


Link to post
Share on other sites

Hey guys. Got a couple of A400s that will power up but will not show video over RF. I either get interference or no signal at all. Reading the 400/800 service guide, I saw that the A400 combines the signal at the power supply board. Has anyone ever tried to use this signal to build a composite hack for the A400? Saw that there are 5200 hacks that may work, but many of them aren't in production anymore and all of them seem to focus on the CTIA/GTIA. If you have any information, please let me know. Thanks.

 

Cliff

 

 

I shoe-horned the 8bitdomain 5200 A/V mod into my Atari 400. It gives very good SVideo and Composite output.

 

You can see the pictures in my gallery.

 

HTH

 

Very nice... Any chance of a detailed how to, for those of us who are dense :D

 

I second that emotion.

Share this post


Link to post
Share on other sites

Very nice... Any chance of a detailed how to, for those of us who are dense :D

 

Sure, I will get some more detailed instructions together this week.

 

In the meantime, the guy I bought my AV mod from has more for sale:

 

eBay Auction -- Item Number: 3205309160511?ff3=2&pub=5574883395&toolid=10001&campid=5336500554&customid=&item=320530916051&mpt=[CACHEBUSTER]

 

I bought one! There's one left.

 

Oh man, the 400 was my first computer. To have video out (S-video too!!) will really be a joy!!! PLEASE PLEASE compile the detailed instructions when you have the time. I also have 48k I haven't installed yet, either!

Share this post


Link to post
Share on other sites

Very nice... Any chance of a detailed how to, for those of us who are dense :D

 

Sure, I will get some more detailed instructions together this week.

 

In the meantime, the guy I bought my AV mod from has more for sale:

 

eBay Auction -- Item Number: 3205309160511?ff3=2&pub=5574883395&toolid=10001&campid=5336500554&customid=&item=320530916051&mpt=[CACHEBUSTER]

 

I bought one! There's one left.

 

Oh man, the 400 was my first computer. To have video out (S-video too!!) will really be a joy!!! PLEASE PLEASE compile the detailed instructions when you have the time. I also have 48k I haven't installed yet, either!

 

Crap, I missed it... :(

 

looks like RF for me on my 400

 

[edit]

 

Wonder if anyone can figure out how to do the same with a longhorn Engineer mod!(maybe not as they are only 2600/7800)

Edited by orpheuswaking

Share this post


Link to post
Share on other sites

Very nice... Any chance of a detailed how to, for those of us who are dense :D

 

Sure, I will get some more detailed instructions together this week.

 

In the meantime, the guy I bought my AV mod from has more for sale:

 

eBay Auction -- Item Number: 3205309160511?ff3=2&pub=5574883395&toolid=10001&campid=5336500554&customid=&item=320530916051&mpt=[CACHEBUSTER]

 

I bought one! There's one left.

 

Oh man, the 400 was my first computer. To have video out (S-video too!!) will really be a joy!!! PLEASE PLEASE compile the detailed instructions when you have the time. I also have 48k I haven't installed yet, either!

 

Crap, I missed it... :(

 

looks like RF for me on my 400

 

[edit]

 

Wonder if anyone can figure out how to do the same with a longhorn Engineer mod!(maybe not as they are only 2600/7800)

 

THAT SUCKS!!! I thought it would be cool if another was doing this too. I seriously thought about buying them both, but they're $50!!!! Now I wish I had; if I'd have known you better I certainly would have to save one for you.

  • Like 1

Share this post


Link to post
Share on other sites

Heh heh!

 

So I message the seller, asking for more. He puts up a couple and messages me back.

 

I message orpheus, tell him about it. While I'm checking the ebay link, I notice one is sold and only one left (again).

 

I decide to buy it, in case orpheus wants it.

 

Minutes later, orpheus messages back, he's the other guy who bought the one!! lol.

 

I'm glad to have erred on the side that orpheus gets one and we can compare notes on this.

 

But I don't need 2, I don't think!

 

If anyone else is interested in one, let me know! (Neither have arrived yet, of course)

Share this post


Link to post
Share on other sites

Heh heh!

 

So I message the seller, asking for more. He puts up a couple and messages me back.

 

I message orpheus, tell him about it. While I'm checking the ebay link, I notice one is sold and only one left (again).

 

I decide to buy it, in case orpheus wants it.

 

Minutes later, orpheus messages back, he's the other guy who bought the one!! lol.

 

I'm glad to have erred on the side that orpheus gets one and we can compare notes on this.

 

But I don't need 2, I don't think!

 

If anyone else is interested in one, let me know! (Neither have arrived yet, of course)

possibly, depends on the shipping cost/having some money from ebay sales

Share this post


Link to post
Share on other sites

Very nice... Any chance of a detailed how to, for those of us who are dense :D

 

 

 

 

Installing the 8bitdomain (aka Retrokidz) 5200 AV mod in an Atari 400.

 

 

Disclaimer - the following instructions are based on my own experimentation. I will not accept any responsibility for damage to your beloved Atari 400 as a result of trying to replicate this!

 

 

 

The 8bitdomain 5200 AV Mod is designed as a solderless AV mod for an Atari 5200 game system.

 

The mod adds Composite and SVideo output to a 2-port 5200 game console.

 

 

It achieves this by having the user remove the original GTIA chip. The GTIA is then inserted into the mod, and the mod board inserted into the socket vacated by the GTIA.

 

The mod taps eight lines of the GTIA to generate its output. Signals to and from the GTIA are not interfered with and most of the 40 pins are simply pass-thrus on the board.

 

 

Indeed, the mod only really requires eight lines on the GTIA:

 

Pins: 3, 21, 22, 23, 24, 25, 27 and 31.

 

It also uses pin 37 of POKEY to generate the audio, which is output to a standard 3.5mm audio jack.

 

 

 

Since the 5200 and the Atari 400/800 systems share the same basic architecture, including use of the GTIA display chip, the mod works in an Atari 400.

 

However installation is more complicated and not solder-less.

 

 

Although the mod works in a 400, it will not physically fit. This is due to the following:

 

 

On the 400/800 CPU board, the ANTIC chip is too close to the GTIA to allow the 5200 AV mod board to fit. The mod board is designed to be low profile but requires several inches of space to the right of the GTIA chip to fit properly. In a 400/800 CPU board, this space is occupied by the ANTIC chip.

 

The board could be stacked with an IC socket to lift it clear of the ANTIC, but this does not work either. The board has an seven pin connector that sits to the side of the GTIA socket, into which is connected the Composite, SVideo and audio outputs, as well as the audio in from the POKEY.

 

On a 400/800 CPU board, this space is occupied by the motherboard.

 

Also, even without lifting the mod board clear of the ANTIC, the board will not fit under the heavy 400 RF shield. Atari did not leave enough room for after market modifications.

 

 

 

Therefore, to fit the mod board into the 400, we must replicate the required pins to a more suitable location outside of the RF shield.

 

 

You will need:

 

Nine pieces of wire cut to about 2ft each. I use 25 gauge electronics grade wire from Fry's. If you can get multiple colours it will help you greatly.

 

Each piece of wire needs to be stripped to expose 1/16 inch of bare wire at each end.

 

A good soldering iron.

 

A good quality de-soldering tool. I recommend a solderpult.

 

A clean static free work space.

 

I also recommend a 40 pin IC socket and a small piece of strip board (veroboard).

 

 

This is in addition to the equipment recommended by the mod provider:

 

1. Phillips & Flat blade screwdriver.

 

2. Needle nose pliers.

 

3. Sharp angled cutters

 

3. Hand drill (I used a power drill).

 

5. 1/8" and 1/4" bits.

 

6. 1/2" hole cutting tool.

 

7. Awl or scribe

 

8. Xacto knife.

 

9. Metal Ruler.

 

19. Anti-stat mat with wrist strap

 

11. Tin Snips

 

 

 

For the purposes of the description I will use the following orientation:

 

Top refers to the component side, bottom to the foil side of any circuit board.

 

400 Main Board: south is the controller jacks side, north is the CPU and RAM boards side, east is the power board side.

 

CPU Board: south is the edge connector, north is the opposite side. The GTIA is located on the west side of the CPU board.

 

Picture references can be seen in my gallery under "Atari 400 AV Mod gallery"

 

 

NOTE: I also STRONGLY recommend that you add some additional cooling to your 400 when you do this mod.

 

I ended up drilling four vent holes along the top of the RF shield, plus a further set of four holes at the base of the RF shield, to facilitate cooling the 400's CPU board.

 

A power drill with a 3/8 drill bit will cut through the case in about 4 seconds, so this is a simple additional step while you have your 400 in pieces.

 

 

 

To install the AV mod board:

 

1. Disassemble the Atari 400.

 

The Atari 48K memory expansion instructions give a good overview of how to dis-assemble a 400.

 

http://www.myatari.com/ebay/48k400.pdf

 

 

 

2. On the 400 main board, locate resistor R160 next to the POKEY chip.

 

The chip is the large 40-pin IC on the main board and typically has a code of CO12294.

 

Pin 37 is on the east side of the IC and located toward the RAM and CPU boards.

 

Immediately to the east of the IC is a resistor marked R160. De-solder the south leg of the resistor. Then insert one of the pieces of cut wire so that both the wire and the resistor leg are in the barrel. With 25-gauge wire this is possible. Then re-solder the resistor leg.

 

(See IMG_2806.JPG)

 

 

 

3. On the CPU board, locate capacitor C302 immediately north of the GTIA chip.

 

The GTIA is western most chip with and typically has a code of CO14805.

 

The western leg of C302 is adjacent to an unused barrel. Examine the board under light and you will see both of these connect to pin 3 of the GTIA. This is the GND line.

 

Either de-solder the western leg of C302 or the unused adjacent barrel, and solder in another piece of cut wire.

 

In my example I used brown wire.

 

(See IMG_2799.JPG)

 

 

 

4. Locate Pin 11 on the CPU edge connector.

 

Note you are looking for pin 11 of the edge connector, NOT the GTIA IC.

 

Immediately above pin is an empty barrel. This traces back to Pin 31 of the GTIA (the L0 line).

 

De-solder the barrel and solder in a wire.

 

In my example I used white wire with a blue stripe.

 

(See IMG_2799.JPG)

 

 

 

5. Locate Pin 2 on the CPU edge connector.

 

Note you are looking for pin 2 of the edge connector, NOT the GTIA IC.

 

Immediately above pin is an empty barrel. This traces back to Pin 25 of the GTIA (the CSYNC line).

 

De-solder the barrel and solder in a wire.

 

In my example I used red wire with a blue stripe.

 

(See IMG_2799.JPG)

 

 

 

6. Locate the three resistors to the immediate east of the south of the GTIA chip.

 

It is hard to read the silk screen on my board, but the southern most resistor looks to be R307.

 

De-solder the southern leg of each resistor, adding a wire to each one, before re-soldering them.

 

These three resistors connect to pins 22, 23 and 24 of the GTIA (the L1, L2 and L3 lines).

 

In my example I used the following colours: pin 22 - yellow, pin 23 green, pin 24 white.

 

(See IMG_2799.JPG)

 

 

 

7. Again, locate the same three resistors to the immediate east of the south of the GTIA chip.

 

The north of each resistors connects to a common line that can be traced to pin 27 of the GTIA.

 

This is +5V line.

 

De-solder the northern leg of any resistor, add a wire and re-solder it.

 

In my example I used black wire.

 

(See IMG_2799.JPG)

 

 

 

8. Locate the empty solder barrel to the immediate east of the three resistors in the previous step.

 

Solder in a wire to the empty barrel.

 

On the bottom of the CPU card you can see this traces back to pin 21 of the GTIA.

 

In my example I used red wire.

 

(See IMG_2799.JPG)

 

 

 

9. Group the eight wires on the CPU board and tie with a plastic tie to keep them neat.

 

Thread the eight wires from the CPU board, plus the wire from pin 37 of POKEY, through the hole in the RF shield next to the colour adjustment that is mounted on the CPU board in the north east corner. Do not add the POKEY line to the bundle with the plastic tie. It will be simpler for future dis-assembly if the POKEY line is left separate.

 

Use electrical tape to secure them to the side of the RF shield.

 

 

 

10. Solder a 40 pin IC socket into the strip board.

 

You will need a small piece of strip board only slightly larger than the IC socket, although there is space for much larger ones if you wish.

 

The IC socket only needs to be soldered on pins 3, 21, 22, 23, 24, 25, 27 and 31.

 

I recommend also soldering pins 1, 20 and 40 to ensure a good secure fit.

 

 

 

11. Taking your bundle of wires from step 9, solder each one to the strip board so that the relevant connection is made back to the GTIA inside the RF shield.

 

If you followed my color convention the connections are as follows:

 

Pin 3 - Brown.

 

Pin 21 - Red

 

Pin 22 - Yellow

 

Pin 23 - Green

 

Pin 24 - White

 

Pin 25 - Red with Blue Stripe

 

Pin 27 - Black

 

Pin 31 - White with Blue Stripe.

 

(NOTE: Pin 37 of the POKEY is not soldered to this strip board)

 

 

 

12. Insert the mod board into the IC socket on the strip board ensuring you keep the same orientation so that Pin 1 is connected to Pin 1.

 

 

 

13. Using a drill, mount the Composite, SVideo and audio jacks into the 400's case.

 

I found that the the under-side of the case, on the left hand side as you look at the machine, toward the front, made a suitable mounting point.

 

This allows the new connectors to stay hidden from view. Be sure to mount the jacks high enough to allow the plugs clearance from the desk, remembering that the case plastic is angled.

 

(See IMG_2815.JPG)

 

 

 

 

14. Attach the line from pin 37 of POKEY to the green EZ Hook of the mod. Seal the connection in electrical tape to ensure no shorts.

 

 

 

15. Insert the seven pin connector from the Composite/SVideo/EZ Hook jacks to the header on the mod board.

 

The blue line should be closest to Pin 20 of the IC socket, the Green line closest to Pin 21.

 

(See IMG_2804.JPG)

 

 

 

16. Test and Re-assemble your Atari 400 with Composite and SVideo out.

 

When you re-assemble the 400, you will need to carefully feed the excess wire from the CPU board through the hole in the shield as you drop the main/CPU/RAM board assembly back into place. Make sure the entire assembly drops neatly back into place. If there is any displacement, remove and try again.

 

 

 

17. Congratulations, you have now joined an extremely select group of Atari enthusiasts.

 

There are probably fewer Composite/SVideo capable Atari 400s than Atari 1400XLs!

 

 

 

 

Please! - post some picture of your AV modded 400s if you do this!

Edited by oracle_jedi

Share this post


Link to post
Share on other sites

 

 

17. Congratulations, you have now joined an extremely select group of Atari enthusiasts.

 

There are probably fewer Composite/SVideo capable Atari 400s than Atari 1400XLs!

 

 

 

 

Please! - post some picture of your AV modded 400s if you do this!

 

Thank you sir... I think I can follow this... Do you have a picture of the extra holes you drilled (just out of curiosity)

 

Thanks

Share this post


Link to post
Share on other sites

 

Thank you sir... I think I can follow this... Do you have a picture of the extra holes you drilled (just out of curiosity)

 

Thanks

 

Very welcome!

 

I added four new pictures showing the cooling holes, the SVideo socket and an annotated image of the CPU board showing the eight tap points ( use zoom as the text is small ).

Share this post


Link to post
Share on other sites

Thank you sir... I think I can follow this... Do you have a picture of the extra holes you drilled (just out of curiosity)

 

Thanks

 

Very welcome!

 

I added four new pictures showing the cooling holes, the SVideo socket and an annotated image of the CPU board showing the eight tap points ( use zoom as the text is small ).

 

Good deal, I've downloaded all the photos and printed out the instructions... I'm good to go as soon as I get the MOD in the mail. I'll be sure to document my install...

 

Now the question is which 400 do I put it in? regular keyboard or full stroke keyboard machine (both 32k)

Share this post


Link to post
Share on other sites

Am I being dumb? I can't see any photos:(

 

Check his post and look for a line like this one..

 

Picture references can be seen in my gallery under "Atari 400 AV Mod gallery"

Share this post


Link to post
Share on other sites

Okay I have the mod and just have a quick question... The Pokey chip lead has a easy connector on it... Did you use it that way, or cut it off and solder direct?

 

Thanks!

 

(I'll be working on this in a few weeks, and will document it also)

Share this post


Link to post
Share on other sites

I finally received my mods as well. Will be thinking about this. I'm pretty sure I'm the least experienced/prepared for this, but I really appreciate the hints/help that have been/will be posted on this.

 

A big, big thanks to oracle_jedi for sharing in his experience, without which I surely couldn't even think of doing this mod.

 

:)

Share this post


Link to post
Share on other sites

Wow composite for the 400? I didn't think that was possible. Some day I might do this mod and install that 48K upgrade kit I have just so I can use my 400 as my main Atari again. The 800 has it going on, but the 400 was my first computer so I have a special place for it. Plus I like the flat Option/Select/Start/Reset keys for some reason over the 'normal' 800 ones.

 

Tempest

Share this post


Link to post
Share on other sites

Okay I have the mod and just have a quick question... The Pokey chip lead has a easy connector on it... Did you use it that way, or cut it off and solder direct?

 

Thanks!

 

(I'll be working on this in a few weeks, and will document it also)

 

 

I soldered a wire from R160 to ourside the RFI shield, and then connected the EZ hook to the wire there and wrapped it in electrical insulation tape.

 

My reasoning was that it was not possible to insert the entire EZ hook assembly through the hole in the RFI shield, and so running a line out seemed simpler.

 

Throughout the installation I was trying very hard not to directly hack the 5200 mod board, since if the upgrade didn't work, I was planning on trying to re-sell the mod to a 5200 owner. This was also the reason for the 40-pin IC socket cradle I made instead of soldering the 8 GTIA lines directly onto the mod.

 

Since I now know the mod does work, you could cut the audio line, feed the cut wire through a hole in the RFI shield, and then re-attach it. But if you use the EZ hook to attach to pin 37 of POKEY, you will have to carefully place the plastic part of the hook so it does not get dislodged when you re-assemble the 400. I didn't like the idea of that large hook assembly "floating about" inside the 400

 

HTH

Edited by oracle_jedi

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...