Jump to content
Bones-69

RXB - Rich Extended Basic

Recommended Posts

attachicon.gifRXB2015.dsk

 

I never put together the programming files for RXB2015. It would be simple enough for you to do with a hex editor and the data file on the disk image, though. The attached dsk image has the improved BASICLOAD program which should work with any device that supports DSK1, so you can try flashing the cart in-console again...and again. I've heard it takes some people 2 times to get it done correctly.

 

Gazoo

 

That's the second time I read about the improved BASICLOAD, first with the XB2.7, and now here. I probably have missed something, but what does it do, and which program is it? :?

Share this post


Link to post
Share on other sites

That's the second time I read about the improved BASICLOAD, first with the XB2.7, and now here. I probably have missed something, but what does it do, and which program is it? :?

 

Start reading here: http://atariage.com/forums/topic/218904-playground/page-2?do=findComment&comment=3203342

 

Then go here: http://atariage.com/forums/topic/239276-make-a-disk-challenge/?do=findComment&comment=3255273

 

After that, go here: http://atariage.com/forums/topic/229718-extended-basic-v27-suite-cartridge/page-21?do=findComment&comment=3257258

 

And you can finish it up here: http://atariage.com/forums/topic/163627-rxb-rich-extended-basic/page-22?do=findComment&comment=3257510

 

Gazoo

  • Like 3

Share this post


Link to post
Share on other sites

Clearly I'm being stupid.

 

Booting with my 632K cart, programmed up in my MiniPro as RXB2012/REA2011, with your RXB2015.DSK image from post #550 mounted as DSK1 in my nanoPEB, I boot into RXB2012. It automatically loads your updater. When prompted, I enter DSK1.RXB2015 and press return.

 

Your program then goes off and READS the GROMs and EPROMs in that order. It NEVER says anything about WRITING data. After reading the GROMs and EPROMs, it returns a "Successful , Press Space" message.

 

At this point, it becomes a complete crap-shoot as to whether I get RXB2012 with REA2011 or RXB2012 and LOSE REA2011 entirely.

 

It doesn't matter how many times I run this, I NEVER get my cart upgraded to RXB2015. Sometimes I get an RXB2012 cart with REA2101, other times I lose REA2011 but I NEVER see menu items relating to RXB2015.

 

I must be missing SOMETHING (other than a brain?!). Have I overlooked a vital step? Is there a jumper I need to move on the card, or do I need to stick my tongue out the corner of my mouth throughout the upgrade process for it to work?

Share this post


Link to post
Share on other sites

The loader is reading the disk file. The GROM is being written without a text message because the write is too fast to see.

Share this post


Link to post
Share on other sites

Thanks, but nothing on the cart changes to reflect the update to RXB2015. Is the upgrade purely software driven? Do I need to change the position of any on-board jumpers to allow writing to the cart from the console?

 

I'm confused by the fact the cartridge seems to change only the presence of REA and doesn't reflect any "upgrade" to the later revision of RXB.

Share this post


Link to post
Share on other sites

Thanks, but nothing on the cart changes to reflect the update to RXB2015. Is the upgrade purely software driven? Do I need to change the position of any on-board jumpers to allow writing to the cart from the console?

 

I'm confused by the fact the cartridge seems to change only the presence of REA and doesn't reflect any "upgrade" to the later revision of RXB.

 

I used the disk to upgrade my RXB cart with no problem. There is a jumper to write protect the 1284p, you might want to check that. But I would assume that nothing could be written to the chip if the jumper was set to write protect.

 

Gazoo

Share this post


Link to post
Share on other sites

No. I've checked the jumpers and it makes no difference how I set the write-protect ones. The program still doesn't change anything in the EEPROMs.

 

I give up. I have more important things to do than lose sleep over this.

 

Gazoo? If you ever find time to pull the chips from a working RXB2015, could you please upload them/PM me with a ZIP file. I don't have the Ti knowledge to construct one from the posted GROM images, so downloading Minipro files is the only way I'll see an upgrade to RXB2015.

 

Sorry guys. I'll just have to admit defeat on this one, and move on.

Share this post


Link to post
Share on other sites

RXB UPDATE E

(No menu runs DSK1.LOAD just like original XB.)

 

Release:

RXB 2015E

 

RXB2015E.dsk

 

Disk image for in-console update to latest version of RXB.

 

Love it Rich! Leave it alone now, it's perfect. ;)

 

Gazoo

 

Share this post


Link to post
Share on other sites

 

attachicon.gifRXB2015E.dsk

 

Disk image for in-console update to latest version of RXB.

 

Love it Rich! Leave it alone now, it's perfect. ;)

 

Gazoo

 

Thanks but always have new ideas.

 

Rich

Share this post


Link to post
Share on other sites

Hello Rich!

 

I have question about RXB. I try to start my game Meteors (http://tigameshelf.net/ in TI BASIC). In TI Basic scroll of stars work fine, but in RXB there is no scroll.

Is there somethig wrong or is there some other possibility to simulate stars scroll?

 

Dalibor

Share this post


Link to post
Share on other sites

Oh in another thread I found the issue is the Scroll in XB and RXB or any Extended Basic all have the same issue.

 

The scroll in TI Basic does not work the same way as XB does so this is why this issue exists.

 

To fix a RXB program running TI BASIC that used this Scroll function replace the line

 

(line number) PRINT

 

with

 

(line number) CALL MOVES("VV",736,32,0) :: CALL HCHAR(24,1,31,2,24,3,32,28,24,31,31,2)

 

The above CALL MOVES is VDP to VDP 736 bytes from screen address 32 to 0

 

The above CALL HCHAR will put 2 characters at row 24 col 1, then put 28 space characters from row 3 to 30, and finally put 2 characters 31 at row 31 and 32.

 

It would be detrimental to add another scroll TI Basic version to RXB as in 30 years only this this TI Basic program has ever shown this problem with compatibility.

Share this post


Link to post
Share on other sites

Rich, what is the main difference between RXB 2015 D and E?

I was asked to make a small change to RXB 2015 D for the load screen and fixed a bug I found in my code, also updated documents and Video Links.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Rich!

I would like to verify the complete subprogram list of RXB 2015E with you. This is needed to detect compatibility of a Basic Program with a certain Basic Version (RXB, XBII+, XB, TIB, SEB,...) automatically within Web99. Have there been other subprograms in older versions of RXB no longer supported in RXB 2015E? Have there been subprogram name changes?

 

AMSBANK
AMSINIT
AMSMAP
AMSOFF
AMSON
AMSPASS
BASIC
BEEP
BIAS
BLOAD
BSAVE
BYE
CAT
CHAR
CHARPAT
CHARSET
CHARSETALL
CLEAR
CLSALL
COINC
COLOR
CUTDIR
DELSPRITE
DIR
DISTANCE
DUPCHAR
DUPCOLOR
EA
EAED
EALR
EAPGM
ERR
EXECUTE
FCOPY
FILES
GCHAR
GMOTION
HCHAR
HEX
HGET
HONK
HPUT
INIT
INVERSE
IO
ISROFF
ISRON
JOYST
KEY
LINK
LOAD
LOCATE
MAGNIFY
MKDIR
MOTION
MOVES
NEW
ONKEY
PATTERN
PEEK
PEEKG
PEEKV
POKEG
POKER
POKEV
POSITION
PROTECT
QUITOFF
QUITON
RENAME
RMDIR
RMOTION
RUN
SAY
SCREEN
SCSI
SECTOR
SIZE
SOUND
SPGET
SPRITE
SWAPCHAR
SWAPCOLOR
USER
VCHAR
VERSION
VGET
VPUT
XB
XBPGM

Further the documentation refers to RND as subprogram. Isn't RND rather a command? It's not working with CALL RND.

EAED seems to be missing in the documentation, however CALL EAED seems to be in the subprogram list.

Thanks a lot, Klaus

Edited by kl99
  • Like 2

Share this post


Link to post
Share on other sites

I just replaced RND with a new version.

I will have to check out EAED and see where I went wrong.

  • Like 2

Share this post


Link to post
Share on other sites

From my last video:

 

 

I just attempt to us RXB commands to use my BSAVE and BLOAD routines:

 

CALL BSAVE("RS232") ! TI computer 1 SAVE lower 8K

 

CALL BLOAD("RS232") ! TI computer 2 LOAD lower 8k

 

Oddly it never completed or worked and I am very puzzled why?

 

SAVE "RS232"

OLD "RS232"

Works and even:

SAVE "RS232",MERGE

Also works so why is my BSAVE and BLOAD not working as it works exactly the same as OLD and SAVE works?

  • Like 1

Share this post


Link to post
Share on other sites

I have an Ubergrom board with the AT49f040 (blank) - is there a post that details what image or the process I need to use to turn this into a RXB cart? :) Cheers, Arthur...

Share this post


Link to post
Share on other sites

I have an Ubergrom board with the AT49f040 (blank) - is there a post that details what image or the process I need to use to turn this into a RXB cart? :) Cheers, Arthur...

 

Since you have an UberFROM card and an AT49F040, you'll also need to obtain an Atmega 1284P. The RXB requires BOTH chips.

 

Download both files in << THIS POST >>. You might also want to go << HERE >> and get the instructions on how to program the 1284 if it's your first time programming that type of chip. Good luck!

  • Like 3

Share this post


Link to post
Share on other sites

Would that be one of these???

 

http://www.ebay.com/itm/ATMEL-ATMEGA1284P-replaces-ATMEGA644P-ATMEGA32-ATMEGA16-/270792917133

 

 

 

Since you have an UberFROM card and an AT49F040, you'll also need to obtain an Atmega 1284P. The RXB requires BOTH chips.

 

Download both files in << THIS POST >>. You might also want to go << HERE >> and get the instructions on how to program the 1284 if it's your first time programming that type of chip. Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...