Jump to content
Sign in to follow this  
Sirius

Road Blasters Cockpit

Recommended Posts

Hi, not sure if this is the right place for this question, but I thought I'd try. I have a roadblasters coin op that's not displaying video correctly. It's hard to describe but it only displays certain portions and blacks out in others. If you check out this video you can see the problem.

 

http://www.youtube.com/watch?v=BNbwijCeLI4

 

I know it's not the monitor because I've tried 2 different ones.The problem lies in one of the two boards. Not sure which one, but I'd like to figure out which it is, so I can get it repaired. The problem only seems to be getting worse since the time I took the video. The car is barely displayed and the screen goes black at times during the attract mode (like showing "The Enemy"). The longer it's left on the closer it goes back to what you see in the video, but never any better.

Any help or thoughts would be appreciated.

Share this post


Link to post
Share on other sites

I'd say the monitor is fine.

 

More like there's some sort of problem with a RAM or more likely ROM that holds sprite / object definitions - or the data path between that and the video chip, or maybe a problem with the video chip itself.

 

Arcade games usually do a powerup self-test but they don't necessarily catch all faults. Also I tried it in MAME, seems there's some service menus but nothing relating to diagnostics.

 

I guess with the ROMs you could pull them one at a time and see if the behaviour stays the same. If it does then there's a possible suspect chip.

If you had a way of reading the ROMs you could verify them against the equivalent MAME set.

 

With the RAMs, there's usually multiple chips of the same type, you could try swapping them around but I suspect the machine wouldn't work at all with bad RAM.

Share this post


Link to post
Share on other sites

I didn't think of trying to pull the roms. I did pull some of the other chips though. I'm thinking of getting a eprom burner so I can test and burn new roms for this and my Defender. A nice tool to have in your arsenal. As far as the self test...It will not go into it for some reason. There are two switches for it. One on the sound card and one in the rear of the cab by the coin mech's. The one at the rear was disconnected from the switch, but if I twist the wires together and turn on the machine, it boots normally and goes to attract mode. If I press the left thumb button on the steering control it causes the machine to reboot.The one on the sound card pcb isn't even wired to work. One of the problems with this board set is trying to identify the proper chips for ram and video. My Defender board was a lot simpler to diagnose and has way more documentation available. There doesn't seem to be much online about troubleshooting the "System 1 Boards". I had a line on what I think is the video chip but the guy hasn't gotten back to me yet. He said he had to check his inventory and let me know, that was about 4 weeks ago. I'm sure that it's a bad chip, but finding out which one is the battle.

 

Do you by any chance have a reader/burner? If so what brand? If I get one, I just want to be flexible enough to read and burn newer chips as well as the older ones. There seems to be a fine line with the different brands as to what chips they'll read and burn. A lot of the newer brands wont read the older chips, and the older ones wont read the newer chips. If anyone has recommendations...I'm listening!

 

Thanks for the tips...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...