Jump to content
sailorcull

Atari ST won't show files on disk in drive

Recommended Posts

I just purchased a 1040 STFM on ebay and low and behold, it turns on, the disk drive light comes on for a second and the monitor screen shows the usual top menu, but shows no files on the disk. I have tried many disks and have tried the disks on my other ST and the disks are fine. What would cause the system to not read the disk? The drive also does not make a sound.

Thank you in advance..

LSC

Share this post


Link to post
Share on other sites

If you're a bit adventurous, you can swap the known working drives from the other ST

to the non-working one and see if that is what it is...

 

If you do that, and it still doesn't work, then while you have it apart, carefully check

and reseat all the socketed chips. They suffer from "creep" sometimes.

 

HTHs.

Share this post


Link to post
Share on other sites

I am adventurous but I kind of don't want to mess up the working one doing this! I am going to see about returning it. Wish me luck!

Thank you for your reply..

Share this post


Link to post
Share on other sites

Well, honestly...its not that hard to take them apart. Just go slow, be careful, take pictures

of things as you go, you would do okay.

 

But if not, I hope you can get your money back at least! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...