Jump to content
ViciousTengu

Sega CD Model 1 Audio Problem

Recommended Posts

I recently purchased a broken Sega CD Model 1 off an auction and did a bunch of small repairs. So far I've gotten everything to work perfectly except one annoying problem that I can't seem to figure out, stuttering choppy audio. All of the obvious things have been checked & contacts have been cleaned thoroughly and the Genesis runs fine on its own. When connected to Sega CD the sound is stuttering from the Genesis headphone port as well as the TV and even when the mixing cable is used. The only time it sounds clear is when a aux cable is plugged into the Sega CD mixing jack with nothing connected to the other end, which I assume is disabling the sound that is coming out of the Sega CD side of things. Anyone ever experience this before?

Share this post


Link to post
Share on other sites

I had choppy sound coming from a Turbo Duo and it turned out to be leaking capacitors.

 

Check the caps around the audio circuit for signs of leakage and replace as necessary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...