Jump to content
Sign in to follow this  
Dripfree

Poor Ms Pacman DOA TI 99/4a

Recommended Posts

So a while back I bought a real cheep lot of 99/4a games on Ebay. My 99/4a was having Issues with all its games not just the ones I just purchased. So the other day I finally did what needed to be done. I took my 99/4a apart and cleaned all the contacts.... I also removed that piece of felt in there if anyone is familiar cuz it seemed to be coming apart and getting onto the contacts. success all games work first try now.
With the exception of Mrs Pacman. She was part of my Ebay lot even though the lot was still a good deal I was looking forward to Mrs Pacman. The computer doesn't even detect the game It only shows Basic. I'm sure the carts most likely toast and I'm just S.O.L. but I thought just maybe someone might know some tricks to try. I opened the cart and checked all the traces they all seem to be good. cleaned the contacts any. Anything else I should try before I throw this thing in the trash?

Share this post


Link to post
Share on other sites
How aggressively did you clean the contacts? If you haven't already, try a pencil eraser.

Dead carts are pretty rare, but they do happen, so you may be out of luck.

TI's Ms Pac-man was a good port, though painfully slow for the early levels.

Share this post


Link to post
Share on other sites
Do you have any other Atarisoft titles and do they work?

V2.2 consoles wont play the Atarisoft games, and IIRC, the title does not even show up in the Master Title Menu.

Share this post


Link to post
Share on other sites
Thanks oracle thats very good to know. Sadly I was working on the joystick splitter adapter around the same time I posted this. Now I feel very foolish. I cleaned the contacts no good. Then I opened Ms packman up. I checked the traces all good. I then re tinned all the contacts no good. I added a little solder to the rom chips cuz some points looked as if they were may not be making contact. At this point I decided the rom chips must be bad.... So I gutted Ms Packman and used her case to store my splitter...... After reading your post I turned on my TI...... It is indeed rom version 2.2...... Ugh... Ironically I also own an older black and silver TI that would have played it! I don't use that one just cuz I think my beige TI looks better. Oh well live and learn. At least I got a sweet splitter out of it. I do realy like my splitter. I find it fitting that I used an atarisoft game for my TI to give my the ability to use an atari stick on my TI. But I also feel bad that I gutted a great classic game for no good reason. Thank you very much for the info. Now at least I won't make that mistake again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...