Jump to content
Sign in to follow this  
heiwa

Gameboy glitch

Recommended Posts

Hi everyone,

 

I recently digged up my old original gameboy and tryed playing a few games on it but the result is what you see in the pictures. All the cartidges have show similar problems and they all work fine in another unit I have so its definitely the gameboy itself. The weird thing about this is that the game is playing fine underneath all that garbled mess. This is especially apparent in Super Mario Land since I can make out parts of the game and it works as it should. Also the sound shows no problems at all. I tried cleaning the screen contacts but that didn't work. This seems consistent with some kind of memory fault but shouldn't that preclude the game from running properly? Sorry for the low quality pictures but it's really hard to get a good image of that screen.

 

Thanks

post-35484-0-52107100-1367118503_thumb.jpg

post-35484-0-59441700-1367118539_thumb.jpg

post-35484-0-60374000-1367118674_thumb.jpg

post-35484-0-13971400-1367118900_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...