Jump to content
Sign in to follow this  
atariLBC

Lynx II Sound Issue

Recommended Posts

Over the summer I picked up a used Lynx II bundle on Game Gavel. It worked great for a few months but the sound has recently stopped working. I've read that this is a common issue for the Lynx II and that either the capacitors or speaker may need replaced. Is this a simple repair? Or should I just get another unit as their relatively inexpensive?

 

Thanks!

Share this post


Link to post
Share on other sites

It's probably the speaker or capacitor. Easy to repair. If memory serves the cap is 220uF, 10v or 16v will be fine. If you have a multimeter you can disconnect the speaker and check connectivity across the 2 connections, it should measure almost a short. If its open circuit you need a new speaker. There are equivalent speakers on EBAY, I think the impedance of Lynx 2 speaker is 16 ohm, and Lynx 1 speaker is 8 ohm (could have those wrong way around), it will be marked on the existing speaker.

 

Edit: search this forum, I've also posted a few other threads about similar audio problems.

Edited by GadgetUK

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...