Jump to content
delvis

Adding HD9800 for Low and Medium Res with LCD Monitor

Recommended Posts

I had read several other postings on a few Atari ST sites and saw several ways to use a non-Atari brand Multisync monitor. I bought the "Best Electronics" VGA cable but with my Viewsonic I only get the High res monochrome to display. Following the road many others have taken I went for a scan doubler.

 

I chose the HD9800 ver 5 which seems to be a newer version of the GBS8200 or GBS8220 that others have documented. I did this and it worked for me on my Mega 4 ST.

 

Not using the VGA cable I bought from Best, I built a test cable with a 13 pin to the HD9800 board connector. After playing with the 9 and 12 pin connectors and getting rolling screen I took the 9 wire and connected to the 2 Pin and it worked correctly.

 

Atari signal wire color HD9800 /GBS-8200 V5.0 board
13 pin DIN P11 connector
6 ------green video---green wire------------"G"

7 ------red video-----red wire--------------"R"
2 ------CSync --------grey wire-------------"S"
10 ------blue video----blue wire-------------"B"
12 ------VSync---------yellow wire-----------"VS"
13 ------Ground--------black wire------------"GND"

This is it and it works perfect. (Except for the normal complaints of shadowing, ect.)

 

Settings on HD9800 at default, using RGBS at 1024 x 768 in the Menu. I tried this without hooking the yellow wire up and had distortion along the bottom of the screen. Hooking up the yellow and it went away. Tried going to different resolution in the HD9800 menu and it started have static along bottom of screen.

So basically this did not require adding anything else. Built cable and wired directly to HD9800 connector.

 

I will use the BEST VGA cable for my High res Monochrome.

post-36234-0-30730700-1381722725_thumb.jpg

post-36234-0-81437100-1381722726_thumb.jpg

post-36234-0-39841200-1381722728_thumb.jpg

post-36234-0-36356900-1381722729_thumb.jpg

Share this post


Link to post
Share on other sites

I am sure that if I tweak the menu settings on the HD9800 I can make the desktop larger ect. I was just glad that for $23 USD and free shipping I was able to get this device. Did also spend about $17 USD building the connecting cable. The bigger bucks was buying the special cable from Best. If I get a different monitor I might be able to use that cable for all three modes and not need this scan doubler.

Share this post


Link to post
Share on other sites

I am sure that if I tweak the menu settings on the HD9800 I can make the desktop larger ect. I was just glad that for $23 USD and free shipping I was able to get this device. Did also spend about $17 USD building the connecting cable. The bigger bucks was buying the special cable from Best. If I get a different monitor I might be able to use that cable for all three modes and not need this scan doubler.

 

Have you tried using the Best cable to the HD9800?? In theory, with the scan doubler on, you should get the low and mid color resolutions, and if the doubler has a bypass setting, the ST should sense the high res signal. There should be no reason that you can't get all three with the one cable. Again, this is in theory.

Share this post


Link to post
Share on other sites

I did try it originally with the best VGA cable. Had great Low res picture but it kept rolling and the Hi Res froze. If I use the cable separate without the HD9800 I only get Hi res, and the color says out of range for this LCD that I have. (Viewsonic)

 

These photos with the best cable only on my other monitor. (HP)

post-36234-0-34963100-1381792480_thumb.jpg

post-36234-0-85852100-1381792481_thumb.jpg

post-36234-0-61551100-1381792483_thumb.jpg

Edited by delvis

Share this post


Link to post
Share on other sites

I did try it originally with the best VGA cable. Had great Low res picture but it kept rolling and the Hi Res froze. If I use the cable separate without the HD9800 I only get Hi res, and the color says out of range for this LCD that I have. (Viewsonic)

 

These photos with the best cable only on my other monitor. (HP)

 

Are you selecting the hi res setting on the ST without changing anything on the doubler?? The HD9800 should have a bypass mode so that it is just passing the signal through without modification. That is probably what you would need to use when switching to hi res so it's not trying to modify the signal. Then take it out of bypass mode when you want to switch back to low/med. Also, remember there is a switch on the Best cable that needs to be changed to use it for color or hi res, not that you didn't remember but just covering all bases.

Share this post


Link to post
Share on other sites

So with your test cable you were able to see all three modes through the scan doubler? I am hoping to do the same thing soon!, I have the GBS8200. I want to use a monitor switch or two, switch between my 8bit vbxe through scan doubler, ste through scan doubler and my regular pc. One monitor for three systems will save a lot of desk space.

 

 

Thanks.

Robert

Share this post


Link to post
Share on other sites

Guitarman - The Best cable did provide a picture in both Hi res and low res using the switch on the cable. At one point I took my multi meter and did a pin out of the Best cable in each mode after changing the selector.

 

I did not see anything to bypass the scan doubler when using the hi res with it. But to be clear when trying to use the "Best Elec" cable and the scan doubler the picture rolled and the sync was off.

 

Using my homemade test cable I only had Low or Medium res. By not hooking up pins 12 and 9 together for the Vert and Horz sync I did not have to deal with that issue. (Other forums tons of stuff on that) Instead I hooked up pin 2 and it synced without building other circuit boards and adding resistors to help the sync.

 

I do not get Hi res with this test cable but it works for color. So using the Best cable direct from the ST to LCD I will get the Hi res.

Share this post


Link to post
Share on other sites

Tonight added a 3.5mm audio jack to the Mega ST case so I can hear the sounds and music along with my color LCD.

 

Tested it with the Intro to Starfleet I.

 

post-36234-0-66192000-1381898182_thumb.jpg

post-36234-0-28268300-1381898184_thumb.jpg

post-36234-0-52316700-1381898185_thumb.jpg

post-36234-0-97450100-1381898186_thumb.jpg

post-36234-0-33180600-1381898188_thumb.jpg

Share this post


Link to post
Share on other sites

It looks like in the menu, there is an option to select auto scan for the input. have you tried that. You would have to select it after changing to HiRes and the screen is rolling. It may sense the input signal and set it properly.

Share this post


Link to post
Share on other sites

Thanks, no I tried that too. If I really want to use the Best cable as it is designed I need to get a Multisync monitor that it can work properly with. At one point I was considering making an small connector adapter between the cable and the HD9800 to try and fix the roll. I don't get any signal off the 2 pin. My other choice would be do all the resitors and 74xx chip layout. Use the 9 pin and 12 pin and combine the signal, ect.

 

For now I am happy using the homemade cable through the HD9800 for color and the Best cable direct for mono.

Share this post


Link to post
Share on other sites

Great, I tried the Best cable and HD9800 on two monitors and TV with same results of the rolling screen in color, and frozen screen in High res.

 

Both devices seem to work fine as designed just not together.

Share this post


Link to post
Share on other sites

hmm would be great to have all modes on this board got myself a 8220 overhere will test with that.. this is cool... I did buy it for ega > vga with my Atari ABC but that was no success.. maybe it can be of use for the ST

Share this post


Link to post
Share on other sites

I did buy it for ega > vga with my Atari ABC but that was no success.. maybe it can be of use for the ST

 

The ABC PC....still looking for one of those!!! Just about the only thing NOT in my sig. LOL

Share this post


Link to post
Share on other sites

 

The ABC PC....still looking for one of those!!! Just about the only thing NOT in my sig. LOL

 

Do you own an Atari ATW800 aswell ?

Share this post


Link to post
Share on other sites

 

Do you own an Atari ATW800 aswell ?

 

No, don't have one of those either!!! Wouldn't mind finding 1 ea of the PCx, ABC and Transputer line. Wow!! Total thread derail!! Sorry....

Share this post


Link to post
Share on other sites

Just for grins I tried the "Best Elec" cable again with the HD9800 and got the same results I did before. Using the home built cable it is working fine so far. Have tested it on a handful of programs and it works great.

 

I have a version of Battlezone I tried it on last night and the intro screen looks fine but when the game comes on the screen goes to a static look. Might be the version of the game I have. Will continue to montior stuff like this.

Share this post


Link to post
Share on other sites

Wondering if anyone else has updates on using this setup? Can't believe had good it works. I would like to get a better LCD monitor since the one I am using is old and cheap.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...