Jump to content
Sign in to follow this  
Phaedrus32

Troubleshooting the 2600

Recommended Posts

Hey everyone,

 

I picked up a 2600 and I can't get any games to display on the screen. I can see the power is working because it is "trying" to put something up, but nothing recognizable. I've tried 8 different games and they all have a similar result: Thick vertical bars. Seems like different games put up different color bars... not sure that is a clue or not. No sound come through the TV.

 

Where do I start? I really want to make this thing work. Surprisingly, it looks like it is fantastic condition cosmetically.

 

I took the board out and checked the RF cable. It does not appear to be kinked/cut. There are no obvious "burned" parts.

 

One last tip. It didn't come with a tv/game switch, so I got one of those F connectors to coax that I'm using.

 

My appologies if there is already a place on this forum for this type of thing.

 

Any help/leads you could give would be very appreciated.

 

Thanks!

 

Phaedrus32

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...