Jump to content
Tupin

Bally Astrocade problems

Recommended Posts

I recently just got an Astrocade, hooked it up, and all that shows up is a black screen. Sometimes there's lines, but it doesn't start up right. I know these things are finicky, where should I start?

Share this post


Link to post
Share on other sites

Close your eyes and wish REAL hard for someone to make a new drop-in board for the Astrocade. I know that's what I'm hoping for. :lolblue:

 

Seriously though, I'm in the same boat. I wound up taking mine apart and I see that some of the traces are actually separating from the motherboard (they kind of look melted). Hope you can get yours working!

 

-Rob

  • Like 2

Share this post


Link to post
Share on other sites

I'm pretty sure your Custom Data IC has overheated and gone bad. Pretty common. Not much you can do unless you have another unit to borrow parts from. My blog (link below) has an article on Astrocades that includes a link to the Service Manual.

Share this post


Link to post
Share on other sites

there are 30 chips in the unit. Beleive it or not, the custom data chip is more robust than most people think. What color is the label on the bottom? only the earliest of Ballys had the custom data chip problem.

Share this post


Link to post
Share on other sites

If you know anyone that has a working unit, there are some things you can do easily to check to see what may not be wrong. You can swap out the prwer supply, the RF cable, the modulator ( tse rectangular metal box that has the rf cord attached to it), the t 40 pin custom chips. swap the out one at a time, putting yopur into the good unit. If the unit works after replaceing all of these components, and you switch is good. everything else in the unit acn be repaced by parts that are still pretty redilly available.

 

Share this post


Link to post
Share on other sites

Alright well, I really don't have the option to switch things out. I already had to replace the RF cable because the end got cut off, so that was one of the first steps of repair.

Share this post


Link to post
Share on other sites

Do you think most of the Astrocade problems are perhaps with the power adapter? A bad power adapter can kill any system. Maybe the voltage and/or current is too "hot" on the typical power supply for the Astrocade. Maybe something with a slightly lower voltage would work better? Just a thought... :idea:

Share this post


Link to post
Share on other sites

The Bally got a rather impressive PSU and one hell of a weird way of getting it working. Maaaybe, I say maybe that some units have it badly tuned. The early models have the transformer rated at 11.5V and 7.5V, and later have just a 12V.

If you look at blueprints, you'll see that the internal PSU part is feed with two AC lines from the transformer, and they use a "bi phase" model to get a second voltage of 11.5V/ 2 =8V(approx) Which is terribly odd. And that's why the transformer mention having 11.5V on the black-red and yellow-white lines, and 7.5V on the red-yellow lines. Yeah. Caused me a headache trying to understand how they were doing that at first.

And I still wonder why doing such a goddamit complex thing when at the end you get a rather regular arcade power output.

 

http://ballyalley.com/documentation/misc_hardware_docs/Bally/full_size/Bally%20Schematic%20%28Ken%20Lill%29%28August%2024,%202011%29.pdf

 

It would be wise to check on the power output at the end, indeed, to ensure that you have the needed +15, +10 and -5 V and VCC is probably 0V

 

Maybe, like on the Colecovision, checking the power switch? Might be good to know it it works well?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...