Jump to content
RevEng

7800basic beta, the release thread

Recommended Posts

Thanks. Yeah, you understood correctly. Probably then the better solution in my case then would be to use sprites for the limited amount of text I would need instead of doing a split mode screen. It's good to know that the reason I couldn't figure it out was because it's not possible, though. 🙂

  • Like 1

Share this post


Link to post
Share on other sites

@mksmith found a long-standing Mac OS bug in 7800basic, during his testing for ADS, so I figured I'd put out a quick bug-fix release. I try not to let bugs sit around too long, though this one is a bit obscure, so I'm not sure if anybody else would have hit it anytime soon. (triggered by a very long-named 8.8 variable being used to index an array, on Mac OS)

 

7800basic v0.12 is available at the github release page.

 

Whats new, compared to v0.11:

  • Fixed a bug where overly long-named array indexes would cause Mac OS not to compile.
  • There's now a forced abort of the compile process when you overrun a bank or dmahole.

There were no functionality or syntax changes in this release. (no manual update required, RT)

  • Like 3

Share this post


Link to post
Share on other sites

Looks like @darryl1970 found a compile-stopping bug regarding pokey sfx. If your game uses pokey, you may wish to hold off on updating, until I get another release out to fix it.

  • Like 1

Share this post


Link to post
Share on other sites

I have another question. If I have tallsprite on, and I'm trying to do a plotsprite on an image taller than the zoneheight, then what is the frame parameter supposed to do? Instead of going to the next file, it seems to zoneheight pixels down the image to find the next frame. Is this the intended behavior? Should I break up my image into zoneheight chunks if I want to use multiple frames instead?

Share this post


Link to post
Share on other sites
16 minutes ago, Karl G said:

I have another question. If I have tallsprite on, and I'm trying to do a plotsprite on an image taller than the zoneheight, then what is the frame parameter supposed to do? Instead of going to the next file, it seems to zoneheight pixels down the image to find the next frame. Is this the intended behavior? Should I break up my image into zoneheight chunks if I want to use multiple frames instead?

It's expected behavior, and admittedly a minor quirk. If you change your frame index to a multiple of the sprite height in zones, you can use animation frames with tall sprites.

  • Thanks 1

Share this post


Link to post
Share on other sites

Or you can use the plotsprite tallheight parameter, which apparently I've forgotten about *and* forgotten to document.

 

See mksmith's example for details.

 

I'll update the plotsprite documentation now.

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
13 hours ago, RevEng said:

Looks like @darryl1970 found a compile-stopping bug regarding pokey sfx. If your game uses pokey, you may wish to hold off on updating, until I get another release out to fix it.

The latest release of 7800basic at the github release page addresses the pokey compile issue, and adds "dynamic memory" for 7800basic functions. Basically that means you get extra stack space, if you don't use every single 7800basic feature.

 

I did update the plotsprite manual entry, as previously mentioned.

  • Like 3

Share this post


Link to post
Share on other sites

I have a couple of questions about plotvalue - what determines the width of the digits it is expecting in the digit graphics? Does it use characters under the hood, and it's based on the character width of the graphics mode? I'm using 160A with doublewide on, and plotvalue seems to be expecting 8 pixel-width digits. Is there any way to use 4-pixel wide digits instead? For now I'm just plotting the numbers as sprites one at a time, which works.

Share this post


Link to post
Share on other sites

plotvalue does indeed just use plotchars under the hood. It basically just sets up a character string of your digits into a private character buffer of it's own, and then jumps to plotchars.

 

Mixing single-wide and double-wide character objects is possible on the 7800, so this limitation is on me. I didn't want to overly complicate the code, and the object plotting code tends to be the most expansive already. Carry on with the sprites, and I'll have a look with a fresh eye this weekend, to see if there's anything clever to be done.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Hi @RevEng

 

Not sure if this is 7800basic or Atari Dev Studio related.

 

My ADS auto updated this morning and now it seems I can't compile any code. I get the following error :

 

image.thumb.png.36fc9cb54b3c8fc961fa906a5372d9be.png

 

I cross posted here for @mksmith .

 

 

Any suggestions on how to resolve it would be appreciated :)

 

 

 

 

Share this post


Link to post
Share on other sites

My first guess is that your antivirus software has quarantined it. Check with the software and see if there's anything in it's vault that can be restored and white-listed.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Grrr! Thanks Mike. I just had to fight with damn virus software for like an hour.


Appreciate the quick answer !

 

Virus software - this stuff is really dodgy, I quarantined it.

Me, Nope, restore and don't quarantine.

VS - OMG, i found this file (same as last time) it's dodgy, quarantine that bad boy!

Me, Really, just stop, I restored it and added to the white list.

VS... I found this..

ME, NO ffs.

VS.😷

 

 

  • Haha 1

Share this post


Link to post
Share on other sites

You're welcome. Glad to get you back on track.

 

This is an AV industry issue that free software writers have become acutely attuned to. The AV vendors would rather software developers invest time in white-listing each release of our apps with each vendor individually, rather than invest time and money in writing software that can actually discern the difference between a virus and hello-world. The former is free for them, and the latter would actually decrease the number of times they claim to have saved people from malware.

 

You feel saved, right? :D

 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

AV Software on a jury: I know of a killer that wore a baseball cap. He is wearing a baseball cap, too, so he must be a killer!

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
On 9/4/2020 at 5:46 PM, RevEng said:

plotvalue does indeed just use plotchars under the hood. It basically just sets up a character string of your digits into a private character buffer of it's own, and then jumps to plotchars.

 

Mixing single-wide and double-wide character objects is possible on the 7800, so this limitation is on me. I didn't want to overly complicate the code, and the object plotting code tends to be the most expansive already. Carry on with the sprites, and I'll have a look with a fresh eye this weekend, to see if there's anything clever to be done.

 

Is it time to update the online version of the guide yet or are you still working on it?

Share this post


Link to post
Share on other sites

I took a look, and it's not an easy change to do without bloating the code significantly. For now, 7800basic coders using doublewide will get doublewide everywhere.

 

This is how "how doublewide" is already documented, so no changes needed at this time.

  • Like 2

Share this post


Link to post
Share on other sites

I might add a note if those files aren't found to check your virus setup 👍

  • Like 3

Share this post


Link to post
Share on other sites

As of yesterday, I am unable to export an png files, using the sprite editor.

 

I downloaded the dev kit onto my Surfacebook yesterday, so I could tweak some stuff on a road trip. I couldn't get any exports to save. I kept getting this error:

image.thumb.png.6693a5726b97d5a99c97391450a91962.png

 

I tried opening VSC in admin mode. I suspected it was a fluke of the Surfacebook, and I gave up.

 

I made the changes this morning, on the PC I have been using the entire time. I get the same error. I cannot export any graphics from the Dev Studio's built-in sprite editor.

 

I tried reverting to the last version of Dev Studio, in case there was an issue with the upgrade. It didn't fix the issue.

 

It doesn't matter if it's a new file name, existing overwrite (which I get a prompt for), or where I save it on the PC.

 

I do not know what to do, but this affected a new install, as well as my existing.

 

Any suggestions are appreciated.

 

--Darryl

image.png

Share this post


Link to post
Share on other sites
2 minutes ago, Muddyfunster said:

I was just about to post the exact same thing :)

 

 

I don't feel as lost now. I just tried to build after upgrading, and I have an issue. I do not see an evidence of my antivirus causing issues. In fact, I ignored the Dev Studio install folder. I am going to double-check anyway.

Share this post


Link to post
Share on other sites

When I press F5, I see the "Activating Extension" message, and it spins. There isn't any output in the window though...

 

I only run Windows Security (formerly Defender) and Malwarebytes. Neither have detected anything. I have VS Extensions on the ignore list for Defender.

 

image.thumb.png.9b9f80207f41823357b78dbab769f883.png

Share this post


Link to post
Share on other sites
1 minute ago, darryl1970 said:

I thought this was the ADS forum? Is there another forum I should be watching or posting to? I am new to this group.

Easy mistake to make :)

 

7800Basic is developed by @RevEng (this thread)

 

ADS is developed by @mksmith and works with 7800Basic and Batari Basic (2600)(the thread I linked above)

 

The two go hand in hand but are actually separate. 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...