Jump to content
Root_Of_All_Beer

ALTIRRA 2.40 input frustration (photo heavy)

Recommended Posts

Hello, for the life of me, I just can't figure this out. I've tried everything except screw up my computer just to make things happen. Pictures enclosed below 1-9, please can someone give us all a better step-by-step procedure on what to do? I'm trying to play games off of just my standard USB keyboard instead of joystick (just like M.A.M.E. and all the other emulators I've been running since 1999):

 

 

post-38771-0-72089900-1395713927_thumb.jpg

post-38771-0-60553200-1395713943_thumb.jpg

post-38771-0-58588700-1395713952_thumb.jpg

post-38771-0-08433100-1395713963_thumb.jpg

post-38771-0-44274300-1395713985_thumb.jpg

post-38771-0-65947400-1395713996_thumb.jpg

post-38771-0-23900600-1395714009_thumb.jpg

post-38771-0-65367100-1395714019_thumb.jpg

post-38771-0-04494500-1395714028_thumb.jpg

Share this post


Link to post
Share on other sites

Well, it'd help if you explained in more detail what you were trying to do.

 

If all you needed was keyboard control of the emulated joystick, then just selecting the default Input > Port 1 > Arrow Keys -> Joystick setting would have done the trick. Since your screenshots show the fire button bound to Enter instead of Ctrl, I assume that's what you were trying to change. You were on the right track with editing the input map, but you didn't need to edit the map entries manually -- you can just hit Rebind and then you can just type the key you want bound to each input going down the list. After you're done, the modified input map will show up on the Input > Port X menus, so you don't have to go back into the dialog to select them.

Share this post


Link to post
Share on other sites

You're probably right about everything you're telling me, but I'm just not getting it to do anything right. Here, I'll explain with images:

 

3rd image on this reply (titled "ALTIRRA 8") I selected as you told me in that order, as seen with proof. I do not recall making my "CTRL" in place of my "ENTER" button, but oh well.... Either way, neither of them can even start any game.

 

2nd image on this reply (titled "ALTIRRA 9") the arrow keys don't function at all, they cannot select any of those settings on that game pictured ("Crypts Of Plumbous").

 

1st image from this reply (titled "ALTIRRA 10") it seems that the "S" button starts the game ("Pharaoh's Curse") as well as "Crypts Of Plumbous" but not other games (list is too long). But as seen on that game's title screen "press trigger to start the game" ....but in the actual game while playing it, it doesn't let me shoot/fire/whatever whenever I press the "S" button nor any key. Sure the arrow keys seem to work nicely but that's all!

 

I've pressed practically every key on the entire keyboard, and nothing does the Atari 800 XL's standard buttons:

"RESET"

"OPTION"

"SELECT"
"START"

"HELP"

 

(well I can do "reset" from the top tabs of the emulator itself)

post-38771-0-11489600-1395729580_thumb.jpg

post-38771-0-98420800-1395729596_thumb.jpg

post-38771-0-41761900-1395730269_thumb.jpg

Edited by Root_Of_All_Beer

Share this post


Link to post
Share on other sites

First, you've got the input maps messed up, because you've got clones of the original arrow keys -> joystick map active. Go into Input > Input Maps again and click Reset to clear everything out, and then reselect the Arrow Keys -> Joystick (port 1) mode. Arrow keys + Left Ctrl are now your joystick.

 

Next, the keys you are looking for are F2 = start, F3 = select, F4 = option, F5 = warm reset, Shift+F5 = cold reset, and F6 = help. This is documented in the help file in more detail under How to use > Keyboard Layout. If you have an F-Lock key on your keyboard, make sure the F-Lock light is on or else these keys will not work. If you have gone into Input > Keyboard and checked Enable Function Keys, go back in there an uncheck it.

 

Crypts of Plumbous doesn't use arrow keys or the joystick for that menu. It says Select to change the difficulty, and so you would use the F3 key for that.

Share this post


Link to post
Share on other sites

Hey I appreciate everything so far.  It makes sense.  But I can't get F2 to start the game "Pitfall 2" as tests.  It's late here tonight, I'm gonna re-check everything in the morning before work.  I did reset the defaults and a bunch of other things just not, not sure why it's not working. 
 
I don't see an F-lock w/light, but I can get the F1 to fast-forward the intros or loading sequences.  F5 etc, seems like it's doing what you said.  But the rest.......... MAN this is painfully frustrating. 

post-38771-0-23037700-1395735812_thumb.jpg

Edited by Root_Of_All_Beer

Share this post


Link to post
Share on other sites

Next, the keys you are looking for are F2 = start, F3 = select, F4 = option, F5 = warm reset, Shift+F5 = cold reset, and F6 = help. This is documented in the help file in more detail under How to use > Keyboard Layout. If you have an F-Lock key on your keyboard, make sure the F-Lock light is on or else these keys will not work. If you have gone into Input > Keyboard and checked Enable Function Keys, go back in there an uncheck it.

 

Crypts of Plumbous doesn't use arrow keys or the joystick for that menu. It says Select to change the difficulty, and so you would use the F3 key for that.

I'm not lying when I say this..... and I swear I even toggled for "full screen" mode just to make sure the obvious isn't that the emulator + game itself wasn't highlighted w/mouse etc or not...... Here goes:

 

"Crypts Of Plumbous"

F1 = speeds up the simulated loading process on most games, excluding this game, which goes straight to the game mode beginning/intro screen.

 

F2 = nothing

 

F3 = nothing

 

F4 = nothing

 

F5 = RESET

 

F6 = nothing

 

F7 = nothing

 

F8 = TOGGLES BETWEEN "Altirra 2.40 [running]" / "Altirra 2.40 [stopped"

 

F9 = PAUSE

 

F10 = HIGHLIGHTS or SENDS CURSOR/MOUSE TO TABS

 

F11 = nothing

 

F12 = nothing

 

And all of my computer keyboards do not have a "FUNCTION LOCK" light on it at all.

All I have is the standard:

"NUM LOCK"

"CAPS LOCK"

"SCROLL LOCK"

 

Please do instruct me further. Is this some personalized setting within the computer itself? Do I need to go inside the control panel of this entire computer and/or any computer to enable any particular switches/toggles just to get ALTIRRA to function properly?

 

So in "Pharaoh's Curse" I had to set the "fire" button-1 to have "autofire" with "speed of 2" just to get it even work at all, otherwise it wont shoot anything at all. FINALLY!!!! At least I'm getting somewhere and nobody told me how to figure THAT out!!!!!!

post-38771-0-18205500-1395762814_thumb.jpg

Share this post


Link to post
Share on other sites

I just went to KeyboardTester.com and tested my keyboard, everything works! So why isn't Altirra? I swear, "CAVERNS OF MARS" wont start unless I press "S" and if I wanted to pause the game "H" ....Then for "ARCHON II" I need to press the "SPACEBAR" just to get past the title screen, making me think I had finally started the game, but without the options, I can't truly start that game.

 

Why can't Altirra keep a strict reliable integrity universal for all games? Why not just redo Altirra and model it after M.A.M.E. or FCE-Ultra or anything else? I'm not trying to insult the designer(s) but this is so frustrating, it's no wonder that computer classic games are the most overlooked, soon to be totally forgotten, and wiped off existence as all that new trendy contemporary mess takes over like usual.......

post-38771-0-78044100-1395768197_thumb.jpg

Share this post


Link to post
Share on other sites

Recently I let the emulator run without any ROM/ATR/image/cart/cassette/game (whatever you need to call them) at all, and let it do the standard RAM/ROM checks just like the real computer, then the audio, then.........

 

....the KEYBOARD!!!!!

 

Now I don't remember on my actual Atari 800XL having randomized keys just suddenly beep like they're being pressed. This might explain what's going on with the bugs, but hey..... am I typing THIS VERY SENTENCE with excessive extra letters beyond my control? Certainly not! So it's obviously the emulator. (photo enclosed)

 

And mind you all, I still have plenty of unanswered questions posted here today that still baffle me.

post-38771-0-08013500-1395781515_thumb.jpg

Share this post


Link to post
Share on other sites

Actually, it does do that on a real 800XL, when the keyboard test is run through the All Tests option:

 

Why Atari made it simulate random keys in that mode is anyone's guess, but it's supposed to happen.

 

Could you try enabling BASIC under System > Firmware and just boot into the BASIC interpreter to see if you can type normally on the emulated keyboard? You should get to a blue screen with a READY prompt. I've never seen or heard of keys acting bonkers in this way in the emulator, I'm afraid.

  • Like 1

Share this post


Link to post
Share on other sites

Actually, it does do that on a real 800XL, when the keyboard test is run through the All Tests option:

http://www.youtube.com/

watch?v=Laz3AY63jkg

 

Why Atari made it simulate random keys in that mode is anyone's guess, but it's supposed to happen.

 

Could you try enabling BASIC under System > Firmware and just boot into the BASIC interpreter to see if you can type normally on the emulated keyboard? You should get to a blue screen with a READY prompt. I've never seen or heard of keys acting bonkers in this way in the emulator, I'm afraid.

WOW!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

GOOD NEWS!!!!!!!!!!!!

 

GOOD NEWS!!!!!!!!!!!!

 

GOOD NEWS!!!!!!!!!!!!

 

GOOD NEWS!!!!!!!!!!!!

 

GOOD NEWS!!!!!!!!!!!!

 

(not "BOOT ERROR"!)

 

 

............Hours ago, I didn't get a chance to reply here, but I believe I got it working. And no...... I had to figure this one out for myself, not that everyone else here wasn't helpful, but there are critical steps never mentioned and NOT OBVIOUS! I will post again later, with screen shots and FINALLY: STEP-BY-STEP methods on how to get the KEYBOARD to actually work with Altirra and do what it's supposed to do. I even added SCAN LINES!!! hahahahaahahahahahahahah (an obvious option).

  • Like 1

Share this post


Link to post
Share on other sites

 

12 hours ago, Samuel Pedigo said:

while we're on the subject, how do i toggle between uppercase and lowercase in Altirra?

What version of Altirra, and which machine system are you using.  The firmware might make a difference as well.

The shift and caps lock buttons work as expected for me, using Altirra 3,1 and XL system.  When using the 800 system, caps lock doesn't work as expected, it switches to lowercase but thereafter I hold shift for capitals.

Share this post


Link to post
Share on other sites
7 hours ago, mr_me said:

 

What version of Altirra, and which machine system are you using.  The firmware might make a difference as well.

The shift and caps lock buttons work as expected for me, using Altirra 3,1 and XL system.  When using the 800 system, caps lock doesn't work as expected, it switches to lowercase but thereafter I hold shift for capitals.

3.20 64 bit 400/800 range for now, then XL later. 

Share this post


Link to post
Share on other sites
10 hours ago, mr_me said:

What version of Altirra, and which machine system are you using.  The firmware might make a difference as well.

I'm pretty sure it does.

 

10 hours ago, mr_me said:

The shift and caps lock buttons work as expected for me, using Altirra 3,1 and XL system.  When using the 800 system, caps lock doesn't work as expected, it switches to lowercase but thereafter I hold shift for capitals.

Use SHIFT and CAPSLOCK together to switch to uppercase again.

  • Thanks 1

Share this post


Link to post
Share on other sites
16 hours ago, Samuel Pedigo said:

3.20 64 bit 400/800 range for now, then XL later. 

I tested the 800 emulator in v3.2, I also tested both altirra and atari firmwares and basic.  They all behave the same as v3.1, caps lock switches to lowercase and, like Keatah says, shift-capslock switches to upper case.

Edited by mr_me

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...