Jump to content
NIAD

ADAMem DOS and ADAMem SDL v1.81

Recommended Posts

Here are the latest versions of ADAMem DOS and ADAMem SDL that were provided to me by Doug Slopsema. I have only tested out the DOS version by overwriting the old ADAMem DOS files that were provided with the Virtual ADAM v1.03 Frontend by Steve Pitman. The DOS version works beautifully with the CF Card backup image files (either the 60Mb Single or 100Mb Dual) that I have posted in the IDE CF Card thread.

 

Here are some additional instructions for ADAMem DOS v1.81 that Doug provided as well:

 

Here are a couple of updated ADAMEM compilations. Key change is the ability to work with both IDE master and IDE slave images.

 

The MSDOS version can be used within Virtual ADAM v1.03 by replacing the adamem.exe in the adamem folder under the installation location.

 

Hard drive images should be named hd_ide1.img and hd_ide2.img and be placed in the same folder. Use the included EXP.rom in the same folder for auto-booting to the hard drive (once again, please in the adamem folder).

 

The WIN32 version is an SDL version as before that runs natively on Windows. Same filename requirements as MSDOS version.

 

Feel free to post these on AtariAge and let me know if you run into any issues with them.

 

Doug Slopsema

 

Additional updates/notes are provided with the SDL version.

 

 

ADAMEM_MSDOS_v1.81.zip

ADAMEM_WIN32_v1.81.zip

Share this post


Link to post
Share on other sites

Something to be aware of when using this new ADAMem DOS v1.81 with IDE Hard Drive/CF Flash image files through Virtual ADAM v1.03...

 

- To use only the CF Card image file(s) with the EXP.ROM (Slot #2 boot rom image file), load Virtual ADAM and then press the BOOT button WITHOUT mounting any Disk or Data Pack image files. If you mount a Disk or Data Pack image file first, that program will be loaded instead of the EXP.ROM file due to the boot hierarchy of the ADAM Computer and you will not have access to the CF Card image file(s). Also, due to a conflict between Virtual ADAM and DOSbox, you can not use ADAMem's built-in configuration option (CONTROL+F9) for mounting Disk and DDP image files.

 

- If you want to use Disk and DDP image files alongside the CF Card image files, you will need to boot the Hard Drive system with the boot disk image that I just made and have attached below. So load Virtual ADAM as you normally do, mount the Hard Disk System v5.0 disk image in Floppy Drive #1, mount any other Disk or DDP images that you want in the other drives and then press the BOOT button. The driver will be loaded from disk, switch to the files on the CF Card image file and then you can proceed from there to work with the other Disk or DDP image file(s) that have been mounted.

 

If you use ADAMem DOS without Virtual ADAM, you can ignore all this seeing as you can mount Disk and DDP image files at will with the (CONTROL+F9) configuration option when the emulator is running.

 

 

Hard Disk System v5.0 (2014) (AJM - RJD Software).zip

Share this post


Link to post
Share on other sites

This could have been fixed in Virtual ADAM, but at the time I don't think Steve was aware that you could change the default keys in DOSbox. As it is, CONTROL+F9 exits out of DOSbox which of course kills ADAMem and Virtual ADAM. I experimented around and changed the "exit" keystroke in DOSbox when running Virtual ADAM so you could bring up the configuration option in ADAMem, but then I discovered whatever disk or ddp image you are running is actually renamed to something that is hardwired into the Virtual ADAM program (can't remember the exact name now). So even if you enter a new disk or ddp name, it still runs the original program that you started with and not the one you are trying to change to.

 

Also, due to a conflict between Virtual ADAM and DOSbox, you can not use ADAMem's built-in configuration option (CONTROL+F9) for mounting Disk and DDP image files.


 

 

Share this post


Link to post
Share on other sites

but then I discovered whatever disk or ddp image you are running is actually renamed to something that is hardwired into the Virtual ADAM program (can't remember the exact name now).

I think this "hardwired" filename is either LDRIVE1.DSK or LDRIVE1.DDP... depending on what media type/drive you are using in Virtual ADAM/ADAMem.

Share this post


Link to post
Share on other sites

 

Very nice, NIAD!

Is it possible to upload a working Hard drive image as example?

 

I have uploaded my 60Mb Single and 100Mb Dual CF Card (HDD) Image files to MediaFire and the links are provided in the IDE CF Card thread here in this forum.

 

 

Is the Dragon's Lair disk image working?

It works on ADAMem SDL v1.80

Yes, it is working and my very large software collection of ADAM DDP and Disk Images is stored on MediaFire as well and linked in the IDE CF Card thread as well as available on Joe B.'s ADAM website that is linked in the SIG of my posts.

 

ED: I tracked the thread down for ya. Make sure to use the links provided in Post #166....

 

http://atariage.com/forums/topic/202664-new-idecompact-flash-interface-for-adam/page-7

Edited by NIAD

Share this post


Link to post
Share on other sites

Thanks for the link, NIAD. : )

ADAMem SDL v1.81

 

Dragon's Lair.dsk

 

It seems I have to remove the "hd_ide1.img" file from the root folder otherwise the game freeze on the second screen.

 

clc76evl.png

 

Command line:

adamem.exe -diska "c:\Emulator\ColecoVision\Software\Adam\Floppy_Disk\Games\Dragon's Lair.dsk"

 

or

adamem.exe -diskb "c:\Emulator\ColecoVision\Software\Adam\Floppy_Disk\Games\Dragon's Lair.dsk"

 

Edited by AnnaWu

Share this post


Link to post
Share on other sites

Odd that Dragon's Lair would freeze at the title sceen since Disk Drive #1 and #2 are ahead of anything else in the ADAM's boot hierarchy so having a HDD image file in the directory should not matter. Maybe just a bug that needs to be ironed out.

Share this post


Link to post
Share on other sites

Command Line:

adamem.exe -diska "c:\Emulator\ColecoVision\Software\Adam\Floppy_Disk\Games\Dragon's Lair.dsk"

 

or

adamem.exe -diskb "c:\Emulator\ColecoVision\Software\Adam\Floppy_Disk\Games\Dragon's Lair.dsk"

 

Doug S. just contacted me about this issue and it's a simple work around...

 

This is actually a bug in the exp.rom (i.e. boot rom for hd), not the hard drive emulation code in Adamem v1.81. If the poster puts –exprom exp1.rom (which would be invalid) on his command line for that particular game boot it will work fine.

Share this post


Link to post
Share on other sites

Any source available perchance?

The source is around. If it isn't readily available, I'll post a copy next week some time.

Share this post


Link to post
Share on other sites

Doug S. just contacted me about this issue and it's a simple work around...

 

This is actually a bug in the exp.rom (i.e. boot rom for hd), not the hard drive emulation code in Adamem v1.81. If the poster puts –exprom exp1.rom (which would be invalid) on his command line for that particular game boot it will work fine.

 

Thanks a lot for the temporary and simple work around, NIAD/Doug S. : )

Edited by AnnaWu

Share this post


Link to post
Share on other sites

Does AdamEm support a second joystick?

 

If you have a second joystick working, would you please provide some insight into how to get it recognized? My first joystick is working perfectly. I updated the source code to map the keys to joystick buttons.

Share this post


Link to post
Share on other sites

To use a second joystick, I just run AdvMess. AdamEm provides a better video though on the Raspberry PI.

 

JamesD, what are you referencing to "Not Responding"?

Share this post


Link to post
Share on other sites

To use a second joystick, I just run AdvMess. AdamEm provides a better video though on the Raspberry PI.

 

JamesD, what are you referencing to "Not Responding"?

SDL version locks up after a while just sitting there.

Share this post


Link to post
Share on other sites

SDL version locks up after a while just sitting there.

 

Yeah, that's a bug in the SDL driver for the routine that handles the video refresh (if memory serves). I attempted a quick fix on it a while back and it didn't work, and I've been busy with other stuff so I've kind of stalled on any work with the emulator. Maybe I'll fire it up tonight and see if I can figure it out.

Share this post


Link to post
Share on other sites

Is 1.81 still the current build? Also, I could never find the OSX SDL version for 1.81.

 

Thanks!

 

I never made one... I should have a build of 1.9 available soon with some new features/fixes.

  • Like 2

Share this post


Link to post
Share on other sites

 

I never made one... I should have a build of 1.9 available soon with some new features/fixes.

 

is there a chance you would redefie the HOME key/function when in ADAM mode? The read me states:

 

Keypad 5 - HOME

 

I can not get this to work. I tried hitting 5 on the joystick and on the keypad (numbers section) on the keyboard.

 

Maybe you could make F9=HOME?

 

Looking forward to the update. Thanks!

Share this post


Link to post
Share on other sites

I've been running Virtual Adam 1.03 but when I try to load any cartridge ROMs all I get is the "TURN GAME OFF" notice after boot. What do I do next? Do I need to relocate the BIOS ROM?

 

~Ben

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...