Jump to content
Sign in to follow this  

Composite video mod problem

Recommended Posts

So I finally got around to installing the composite video mod from Vintage Gaming and More. When I first hooked it back up, it worked fine, but, after putting the top back on, it didn't even power up.

After inspection, the black ground input wire had come loose from the board. The trace had de-laminated from the board and broken loose, so I resolldered the black wire to another place nearby on the same trace.

Now it works against, but I've got no sound.


Any suggestions?

Share this post

Link to post
Share on other sites

Drilling a hole in the metal box (as others have done), and routing the yellow wire thru that, is the solution. My yellow wire was grounding where it was sandwiched between the circuit board and the inside of that metal box.

  • Like 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...