Jump to content

Starting with programming.

Recommended Posts

So, I recently made a port of a PC game I made for the Atari. I have more games I would like to port but the Atari isn't good enough.

Does anyone know where I can download some stuff and some tutorials?


Share this post

Link to post
Share on other sites

newcoleco's devkit has lots of samples and some good documentation in C:




Look at Software->Programming Tools. It uses the good work from PKK on SDCC, but with Daniel's libraries and stuff that is based on the original C library by Marcel de Kogel, as updated and changed by Daniel.


Or I have a little about making a SuperGAME in assembly at:




Although much of what I do would work fine for ColecoVision programming using the OS7 BIOS functions.

Share this post

Link to post
Share on other sites

Since this thread is about getting started with programming, I might as well ask my stupid questions here...


I went to Sebastian Mihai's website to get the Coleco C dev kit and put it in C:\z80 as instructed. I saw that he included his Mowleco game, so I duplicated the directory and renamed it "learning," with the intent of fiddling around with it until I get an idea of how stuff works.


I run CCI3.exe and "learning" shows up as expected. I click "Compile All" then "Link" then "Run." The emulator pops up, though I have to select the result.ROM file by hand (mildly annoying). It works... but it doesn't actually reflect any changes I made to mowleco.c. Likewise when I try make.bat from the "learning" directory and press Default (as instructed) then Compile, Link, and Run. At least CCI2 will open the game in the compiler when I press Run, but, again, the game doesn't reflect any changes I make to the .c file.


What am I doing wrong?

Share this post

Link to post
Share on other sites

Are you sure you saved the C file after your changes and before compiling.

Yeah, but I think I was doing something else wrong.


I just went back to things again. This time, I tried something different:


1. I deleted all files from the project directory except for mowleco.c, tiles.c, and the run.bat and make.bat files

2. I switched to view files by Date Modified, so I can see the most recent files as they're created at the top.


After that, I tried CCI3 first:


1. I opened CCI3

2. The "learning" folder was selected by default, so I clicked mowleco.c and then Compile:

Files created: mowleco.sym, mowleco.rel, mowleco.lst, mowleco.asm

3. I then chose tiles.c and hit Compile again:

Files created: tiles.sym: tiles.rel, tiles.lst, tiles.asm

4. Next, I clicked Link:

Files created: result.rom, crtcv.noi, crtcv.noi, crtcv.map, crtcv.lk, crtcv.ihk

5. Finally, I clicked Run. However, since that doesn't automatically open the ROM (for some reason), I had to navigate to it and select it.

6. This time, I saw a change, which is great!


That worked! Maybe I hadn't clicked on each of the files (mowleco.c and tiles.c) and compiled both before linking.


Alternately, after deleting all but the bat and c files, I tried CCI2 through make.bat:


1. I opened make.bat, which opens CCI2

2. I clicked "Default" as advised, which selects crtcv.rel, cvlib.lib, and getput.lib

3. Next, I clicked Compile All:

Files created: mowleco.rel, c.bat, and tiles.rel

4. Then, I clicked Link:

Files created: result.rom, l.bat, crtcv.noi, crtcv.map, certcv.lk

5. Finally, I clicked Run (which works) and saw the expected change. Woo!


So maybe I was just doing something stupid and not realizing it.


Is there any reason to use CCI3 over CCI2? Why do such a different set of files get created? Why does the Run option in CCI3 not work correctly?

Edited by Cybearg

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...