Jump to content
slx

10502PC and Mac?

Recommended Posts

Is there any software that allows the 10502PC (in my case a combination SIO2PC/10502PC from Atari8Warez) to be used on a Mac, i.e. giving the Mac direct access to the 1050 drive?

 

The documentation seems to mention ProSystem only but AFAIK that's Windows software.

 

Thanks!

 

Share this post


Link to post
Share on other sites

I don't think so but what exactly are you trying to achieve?

 

To write ATR's from my Mac to disk with my Happy 1050, my usual method is to stick an SIO2PC at the end of the SIO chain.

 

Use SIO2OSX/Aspeqt/SIOServer to act as drive 2. Leave emulated D1: turned off because this is our real floppy drive.

 

Fire up Happy Sector copier booting from 1050. Set D2: as source and D1: as destination. Other sector copiers work but this one is my preference because I can hand type the start and end sectors for weird ATR images. And I have a Happy Drive. I have had good luck with other software too.

 

You could go the other way around with this too, just stick a blank image in emulated D2:, format it and use it as destination to copy a real floppy to ATR.

 

I have had no problem mixing emulated and real devices in chain as long as I pay attention to the drive ID.

Edited by kogden
  • Like 1

Share this post


Link to post
Share on other sites

I don't think so but what exactly are you trying to achieve?

 

To write ATR's from my Mac to disk with my Happy 1050, my usual method is to stick an SIO2PC at the end of the SIO chain.

 

What I'm trying to achieve is to archive a couple dozen old discs to .ATRs. I am aware of the setup you posted but would have preferred not to have to set up an 8-bit-System next to my Mac to do this. I hoped to be able to hook up the disc drive only to the Mac and use a Mac based software to read the files and copy them to .ATRs. If the 10502PC functionality does not work with Mac software I'll rather use a SIO2SD with "pre-made" .ATRs, leave my Atari where it is and just carry the SD card to the Mac :grin:

Share this post


Link to post
Share on other sites

First let me say that I'm not an Apple guy at all. But, having said that, have you considered using Parallels to run Windows XP or 2000 on the mac and then using ProSystem? I don't know if it will work because of timing issues, but if you have nothing else running, it may work.

 

Just an idea....

Share this post


Link to post
Share on other sites

What I'm trying to achieve is to archive a couple dozen old discs to .ATRs. I am aware of the setup you posted but would have preferred not to have to set up an 8-bit-System next to my Mac to do this. I hoped to be able to hook up the disc drive only to the Mac and use a Mac based software to read the files and copy them to .ATRs.

 

APE ProSystem will run inside a virtual Win7 installation running inside VirtualBox. That's what I did when I imaged about 100 floppy disk sides into .ATR files a couple months back.

Share this post


Link to post
Share on other sites

Thanks. Any experience with Wine which would be a bit more lightweight than VirtualBox?

Share this post


Link to post
Share on other sites

Thanks. Any experience with Wine which would be a bit more lightweight than VirtualBox?

 

I just checked - it also runs under CrossOver, so it should work fine with WINE.

post-30400-0-48142500-1411946383_thumb.png

Share this post


Link to post
Share on other sites

Yeah, unfortunately, nothing to run the 1050 straight from OSX that I know of. In my current setup, I have my 130XE next to my Hackintosh which makes it fairly convenient. With my setup, I just wish the "shared folder" features of Aspeqt were a little less limited. I seem to have issues with big files and/or SDX a lot.

 

Being able to copy ATR images to an SDFS partition on my IDE+ without having to jump through hoops would be cool.

Share this post


Link to post
Share on other sites

I will add the 10502PC functionality to AspeQt hopefully before the end of 2014. I know it is quite inconvenient to depend on a proprietary software that only runs in Windows but that's the way it is for the time being.

  • Like 1

Share this post


Link to post
Share on other sites

I will add the 10502PC functionality to AspeQt hopefully before the end of 2014. I know it is quite inconvenient to depend on a proprietary software that only runs in Windows but that's the way it is for the time being.

 

What a great news.

Can't wait.. :thumbsup:

Share this post


Link to post
Share on other sites

I just wish the "shared folder" features of Aspeqt were a little less limited. I seem to have issues with big files and/or SDX a lot.

 

Can you be a little more specific, i recently fixed an issue with folder images where copying a large file was entering an endless loop. Is there any other issues that need attention?

Share this post


Link to post
Share on other sites

I don't think so but what exactly are you trying to achieve?

 

To write ATR's from my Mac to disk with my Happy 1050, my usual method is to stick an SIO2PC at the end of the SIO chain.

 

Use SIO2OSX/Aspeqt/SIOServer to act as drive 2. Leave emulated D1: turned off because this is our real floppy drive.

I was unable to mix the SIO2PC/10502PC with a real 1050. Forced to unplug the SIO2PC/10502PC from the 1050 in order for the Atari to see the real drive. Yes I had the DIP set right. tried it as D1 and D2 using the opposite in the SIO server (tried with both SIO2OSX and SIOServer). Aspeqt won't complete a boot - Stops at track 37.

 

BTW, is there any way to get the emulator to boot from the real 1050?

Share this post


Link to post
Share on other sites

I was unable to mix the SIO2PC/10502PC with a real 1050. Forced to unplug the SIO2PC/10502PC from the 1050 in order for the Atari to see the real drive. Yes I had the DIP set right. tried it as D1 and D2 using the opposite in the SIO server (tried with both SIO2OSX and SIOServer). Aspeqt won't complete a boot - Stops at track 37.

 

BTW, is there any way to get the emulator to boot from the real 1050?

 

Do you happen to be using a 65XE or 130XE? If so, the caps which look a lot like resistors on the SIO connector in the machine may need to be removed. I often had issues with more than an SIO device or 2 in the chain because of this. If your an 400/800 or XL user, this is a non-issue.

 

Basically, make sure your real 1050 is D1:. Make sure Aspeqt has no disks or directories mounted in D1. Every once in a while, I see Aspeqt attempt to respond to requests for D1: even with nothing in there but not every time. Now, I did just check and make sure Aspeqt will work in this config but it did screw up on me once like it did with you. After that it seemed to work ok. It may help to make sure your 1050 is on when you fire up Aspeqt.

 

As for booting the emulator from a 1050, that's probably not happening with Atari800MacX.

 

Aspeqt is very finicky for me even with the latest version.

Edited by kogden

Share this post


Link to post
Share on other sites

For the record, here's my hardware setup....

 

Stock 130XE/modded 576K 800XL

SIO Chain from 1st to last device: Atari XL/XE -> Happy 1050 -> 850 (serial/parallel) -> USB SIO2PC (1-chip FTDI FT232RL)

 

On the Mac side my current config is:

Core2Quad (4x3.0GHz) Hackintosh w/ 4GB RAM and OSX 10.9.4

MacBook Air (dual-core i5) w/ 4GB RAM running OSX 10.9.4

 

With my XE, having more than 1 device in chain often causes problems. I haven't modified it to remove caps yet so I often have to bypass the 1050 or the 850 to keep it working stable with SIO2PC. With the 800XL, I have zero problems.

 

I've also had this working in 10.6.8 before I upgraded my Hackintosh as well. It's worked well for me for years so it most likely boils down to configuration and/or whether you have that ugly cluster of caps in your machine.

Share this post


Link to post
Share on other sites

I had to remove the caps on SIO on my 1200XL for my PoKey FIFO to work at high speed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...