Jump to content
Farb

Atari 8-bit Software Preservation Initiative

Recommended Posts

4 hours ago, luckybuck said:

Just took a look inside the archive and missed:

Hey Roland,

 

The files Timothy are offering are from the latest torrent from a8preservation.com. As you know we make and verify dumps from official sources only. Just to make sure we only offer the software in its original form. Sadly we don't have access (yet!) to the original cartridges and disks of the titles you are stating. As you are already a (respected) member of our little forum, let's continue there to see which files we can use from your sources ;-) 

Edited by Fred_M

Share this post


Link to post
Share on other sites
23 minutes ago, CharlieChaplin said:

Still searching for that converter program (which I once had) that converted Strip Poker pictures into standard 62-sector (Micropainter format) pictures... 😀

If EVER there was a game just screaming for a VBXE conversion, this is it - HAHAHA. 

  • Like 1

Share this post


Link to post
Share on other sites

Noticed the cassette version of Astro Chase was included in the new release. Don't remember seeing that back in the day, so decided to try it...

 

Only way it loads up in Altirra is to use the SIO-Patch.... and when it finishes, there's three lines of text, no graphics, some music and 5 seconds later it crashes the emulator.

 

Tried various OS and NTSC/PAL too.

 

Tried it with SDrive-Max, and when the 1st stage program wants the 2nd stage to load... silence (which is what happens if you turn SIO-Patch off in Altirra).

 

Anyway something doesn't seem right. Maybe I'll dig out my cassette deck and 1010 later and see if a cas2wav conversion works.

Edited by firebottle

Share this post


Link to post
Share on other sites

@Fred: Hi! O.K., let's see:

Atari BASIC Version B: https://atariwiki.org/wiki/Wiki.jsp?page=Atari BASIC#section-Atari+BASIC-CARImages

here the dump was made from orginal ROMs of an early Atari 800XL with BASIC Vers. B

 

OSS BASIC XE - BASIC XE Extension Disk: https://atariwiki.org/wiki/Wiki.jsp?page=Basic XE#section-Basic+XE-ATRImage

I have the original disk, untouched and I am quite sure, Dan has made an ATX of it. Else, next meeting.

 

OSS BASIC XL Toolkit: 2 sides!: https://atariwiki.org/wiki/Wiki.jsp?page=Basic XL#section-Basic+XL-ATRImages

Same as above

 

OSS MAC/65 1.0, 1.02 and so on, further the ATRs: https://atariwiki.org/wiki/Wiki.jsp?page=Mac65#section-Mac65-ROMImages

1.0 dumps were made already and from 3 sources, Steve Carden, Atari Geezer and me a 1.02 dump.

 

3.6 is genuine, but I can't go into detail here. This is the last version of MAC/65

 

EDIT 6502 CAR and ATR : sadly, AtariWiki hasn't got a go from Ken L. from LJK Enterprises, Inc.

I have the original cart and good soul from Texas has made the atr of the disk, which was unprotected.

 

Microsoft BASIC II (1982)(Atari)(US)[cartridge]: here the additional disk is missing

I have the original disk and brought it to a meeting, therefore an atx should be available, too.

 

Missile Command (1981)(Atari)(US)[cartridge].zip: here the version for the XEGS(?) is missing, which supports the trackball

This call goes to the XEGS owners. It is on rom inside the machine.

 

Strip Poker (1983)(Artworx)(US)[disk]: the Data Disks are missing? OMG what a miss... please see the attachment, when > 18 ;-)

The 1st disk dump was made, the additional disks are rarity 0, of course. My versions should just lead to the right ones.

 

Turbo-DOS XL-XE v2.1 (1992)(KE-Soft)(DE)[disk]: Version 2.0 ?

That was after my Atari time, someone else has to take over. But ABBUC has all the rights in it. So, don't worry, just a matter of time. 🙂

 

TURBO-BASIC XL? Genuine type-in from the magazine?

As written in the question already. If the checksums from AMPLE match, then this version is genuine and should be added.

 

Hope, I could help?

 

Always a pleasure with you all.

Share this post


Link to post
Share on other sites

Thanks very much for the new release!

 

I'm wondering why the OS ROM images aren't included anymore. I've been saving my copies of them separately so I don't accidentally lose them when I get the new releases, specifically these files:

 

OS ROM 65XE (1984)(Atari)(US).zip
OS ROM 400-800 NTSC (1979)(Atari)(US).zip
OS ROM 400-800 NTSC (1981)(Atari)(US).zip
OS ROM 400-800 PAL (1979)(Atari)(US).zip
OS ROM 600XL (1983)(Atari)(US).zip
OS ROM 800XE (1985)(Atari)(US).zip
OS ROM 1200XL (1982)(Atari)(US).zip
OS ROM XEGS (1987)(Atari)(US).zip
OS ROM XL-XE (1983)(Atari)(US).zip

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, CharlieChaplin said:

Still searching for that converter program (which I once had) that converted Strip Poker pictures into standard 62-sector (Micropainter format) pictures... 😀

Until you find your converter program, try this for a demo.

I hacked this years ago from my SP disk.

Strip Poker Demo.zip

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the spot check, Roland. Fred_M already gave the reasoning 🙂

 

34 minutes ago, luckybuck said:

Atari BASIC Version B: https://atariwiki.org/wiki/Wiki.jsp?page=Atari BASIC#section-Atari+BASIC-CARImages

here the dump was made from orginal ROMs of an early Atari 800XL with BASIC Vers. B

 

33 minutes ago, dukdukgoos said:

I'm wondering why the OS ROM images aren't included anymore.

We've been focused exclusively on (and overwhelmed by) retail software. ROMs beyond cartridges just seemed out of scope so were removed.

 

33 minutes ago, luckybuck said:

OSS BASIC XE - BASIC XE Extension Disk: https://atariwiki.org/wiki/Wiki.jsp?page=Basic XE#section-Basic+XE-ATRImage

I have the original disk, untouched and I am quite sure, Dan has made an ATX of it. Else, next meeting.

We don't have a flux dump for this one that I could find.

 

33 minutes ago, luckybuck said:

Both sides of this are already in the torrent, no?

 

34 minutes ago, luckybuck said:

Microsoft BASIC II (1982)(Atari)(US)[cartridge]: here the additional disk is missing

I have the original disk and brought it to a meeting, therefore an atx should be available, too.

This is already in the torrent as well, no?

 

36 minutes ago, luckybuck said:

Missile Command (1981)(Atari)(US)[cartridge].zip: here the version for the XEGS(?) is missing, which supports the trackball

This call goes to the XEGS owners. It is on rom inside the machine.

Same comment as OS ROMs.

 

37 minutes ago, luckybuck said:

Strip Poker (1983)(Artworx)(US)[disk]: the Data Disks are missing? OMG what a miss... please see the attachment, when > 18 ;-)

The 1st disk dump was made, the additional disks are rarity 0, of course. My versions should just lead to the right ones.

We haven't come across original disks for any of the data disks yet. Thanks, your ATRs will be helpful for verification once we do!

 

 

  • Like 2

Share this post


Link to post
Share on other sites

Oh, so then OSS BASIC XL & XE disks will be in the next meeting, they were hard to get! Sorry for the trouble, was totally flashed by > 2,500 titles meanwhile... :-))))))))

Share this post


Link to post
Share on other sites

I also noticed that the new Star League Baseball atx, when loaded, doesn't show the game menu in Altirra. The older cas version is the same deal... and even the Atarimania cas version has this problem.

Share this post


Link to post
Share on other sites
15 hours ago, firebottle said:

Noticed the cassette version of Astro Chase was included in the new release. Don't remember seeing that back in the day, so decided to try it...

 

Only way it loads up in Altirra is to use the SIO-Patch.... and when it finishes, there's three lines of text, no graphics, some music and 5 seconds later it crashes the emulator.

 

Tried various OS and NTSC/PAL too.

 

Tried it with SDrive-Max, and when the 1st stage program wants the 2nd stage to load... silence (which is what happens if you turn SIO-Patch off in Altirra).

 

Anyway something doesn't seem right. Maybe I'll dig out my cassette deck and 1010 later and see if a cas2wav conversion works.

I'll have a look and get back to you..

 

ED: Works fine here, as its a NL / EU game I set it to a PAL firmware and OSB and apart from having to press a key to make it continue the lape load after LOADING ASTRO CHASE came up there were zero problems. no need to enable any IO port hacks. Also tried it on XL mode with version 2 firmware and worked fine. I'm using Altirra 3.90 beta 24, as always I implore people to use the latest beta's and not just finals, Avery's updates are always super stable AND he's always adding goodies.

 

There is a rogue version 2 xl rom out there which I've found has some weird effects..

 

 

Edited by Mclaneinc

Share this post


Link to post
Share on other sites
2 hours ago, Mclaneinc said:

I'll have a look and get back to you..

 

ED: Works fine here, as its a NL / EU game I set it to a PAL firmware and OSB and apart from having to press a key to make it continue the lape load after LOADING ASTRO CHASE came up there were zero problems. no need to enable any IO port hacks. Also tried it on XL mode with version 2 firmware and worked fine. I'm using Altirra 3.90 beta 24, as always I implore people to use the latest beta's and not just finals, Avery's updates are always super stable AND he's always adding goodies.

 

There is a rogue version 2 xl rom out there which I've found has some weird effects..

 

 

I'm talking about the "Astro Chase (1982)(First Star Software)(US)[!].cas" file dated 10-26-2019.

 

Not the "Astro Chase (1984)(Aackosoft)(NL).cas" file, dated 7-11-2019. And yes, that version does work for me.

Share this post


Link to post
Share on other sites

Ah, I'll re look then...

 

Ed: apologies re the version tested, no glasses on...

 

Right, fully retested on XL 64K version 2 firmware NTSC, apart from a key pressing when the loading title page comes up it all loaded fine and plays fine..

 

Tried on PAL and it works but you need to make sure you use PAL firmware for OSA or B to match the system or the tape loader fails.

 

26-10-19 tested all fine..No IO changes, all speed ups disabled, see if you have random tape start tick, if not try that although it seems to work without it and just in case disable tape turbo support although I don't think it matters??

 

2nd ed: Sometimes on my system I find stuff does the odd weird thing in Altirra and I then backup the reg settings or ini file and reset the settings and rescan the roms, this FOR ME seems to fix stuff that I have not been able to find a reason for before hand..

 

Again, this is something I do but maybe something to do with realtime virus scanners or other stuff, I have no idea but it does seem to work...

Edited by Mclaneinc

Share this post


Link to post
Share on other sites
4 hours ago, firebottle said:

I also noticed that the new Star League Baseball atx, when loaded, doesn't show the game menu in Altirra.

I guess that you mean the scoreboard shows only the copyright.

This happens if the copy protection fails. The image is OK.

Please verify that you have the "D: patch" disabled.

Share this post


Link to post
Share on other sites
4 hours ago, DjayBee said:

I guess that you mean the scoreboard shows only the copyright.

This happens if the copy protection fails. The image is OK.

Please verify that you have the "D: patch" disabled.

 

6 hours ago, Mclaneinc said:

apart from a key pressing when the loading title page comes up it all loaded fine and plays fine..

 

all speed ups disabled

Thanks for the tips guys...

 

Looks like disabling D and C acceleration (plus hitting a key after 1st stage in AstroChase) worked in both cases.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/27/2020 at 11:25 PM, firebottle said:

Noticed the cassette version of Astro Chase was included in the new release. Don't remember seeing that back in the day, so decided to try it...

 

Only way it loads up in Altirra is to use the SIO-Patch.... and when it finishes, there's three lines of text, no graphics, some music and 5 seconds later it crashes the emulator.

 

Tried various OS and NTSC/PAL too.

 

Tried it with SDrive-Max, and when the 1st stage program wants the 2nd stage to load... silence (which is what happens if you turn SIO-Patch off in Altirra).

I think I had the same problem as you did. Three lines of text, a few seconds of music and it crashes. I had this when I loaded this cas-file in an older version of Altirra (in my case 2.90). When I load it with Altirra 3.10 it runs fine.

 

And when you load it with a later version of Altirra (and without acceleration / or with real HW and the SDrive Max), don't forget to hit a key after the 1st stage is loaded, the seconds stage will load after a key is pressed.

Share this post


Link to post
Share on other sites
1 hour ago, Fred_M said:

I had this when I loaded this cas-file in an older version of Altirra (in my case 2.90). When I load it with Altirra 3.10 it runs fine.

Something interesting I noticed... my favorite old version of Altirra is 2.50... when trying to load the new cas dump of Star League Baseball, no matter what setting I have, it eventually crashes the emulator after about 5 and a half minutes... like having a dreaded error-138 or error-143 in Basic.

 

Loading it in Altirra 3.0 & newer... no problems.

Share this post


Link to post
Share on other sites

Again, keeping the emulator up to date is a must do, the beta's are 99.9999999% fine and always feature loaded, I would say 100% but there's always room for a typo etc..I've never had to regress a beta as far as I can remember, that sort of says just how stable Avery's work is. Plus you just can't help to be amazed at what delights hit us in the beta's, things he's been working on come out of left field and its always a real treat even in my case if its above my pay grade in knowledge.

 

Anyway, to all the people making the preservation movement just how wonderful it is, THANK YOU..Striving to get perfect versions of our beloved old games is such a noble thing for all of us, we really appreciate it and if there's a donation place I'm happy to throw some money there, it won't be much but it might help.

 

Paul.

Edited by Mclaneinc
  • Like 2

Share this post


Link to post
Share on other sites
18 hours ago, firebottle said:

Something interesting I noticed... my favorite old version of Altirra is 2.50... when trying to load the new cas dump of Star League Baseball, no matter what setting I have, it eventually crashes the emulator after about 5 and a half minutes... like having a dreaded error-138 or error-143 in Basic.

I also have some cas-files that work perfectly in the older versions of Altirra (versions starting with 2.) and do not work on the newer version (3 and up).....

Share this post


Link to post
Share on other sites

What??? That may be the solution! 🙂 You see the questionmark in my avatar? I am a greenhorn regarding Windows. Have Altirra with Mac under Wine in 3.0, 3.1 and 3.2, the attached atr doesn't run. 😞

Error 12.jpg

 

It is just about the program A1.BAS on the atr. Shortly after start, i receive ERROR 12. Can you acknowledge this with Altirra 2.5 or even better on real hardware? I am just on an emulator... 🙂

 

Many thanks in advance. 🙂

Noch_mehr_Basic1.atr

Edited by luckybuck

Share this post


Link to post
Share on other sites
2 hours ago, luckybuck said:

It is just about the program A1.BAS on the atr. Shortly after start, i receive ERROR 12.

Just to ask the obvious - did you switch from Altirra BASIC if you are using it to one of the Atari BASICs? Altirra BASIC is a) great and b) faster than Atari BASIC, but isn't 100% compatible in all cases.

Share this post


Link to post
Share on other sites
9 hours ago, luckybuck said:

It is just about the program A1.BAS on the atr. Shortly after start, i receive ERROR 12. Can you acknowledge this with Altirra 2.5 or even better on real hardware? I am just on an emulator...

In Altirra 2.60 and 3.2 (on windows) it does not crash, but it does not do anything either than showing a blue screen with the yellow text "Lektion Eins". I guess this can be a result of the missing an audio track. Like the other Invitation to programming translations I think this one should be run from tape only.

 

My experience with not loading cas-files (and the original wav-files) in older versions of Altirra and the other way around is only with tape files (cas/wav). They all stopped loading without any error message. These titles did not start at all. According to phaeron this has to do with the fact that from Altirra 3 (and higher) he increased the precision of the datastream. As a result small glitches in the audio stream were not picked up in older versions of Altirra (below 3) but are picked up in the newer versions.

 

So I guess (I am not an expert on this) that you should try to get the dumped cassette tape files, not this ATR on which the basic files were csaved.

Share this post


Link to post
Share on other sites

I don't get the error 12 with a1.bas but then again it just stays blue screen as per screen shot....

 

I tried a0.bas and that started to try and load a non existent tape so I have no clue what the software does..

 

The best thing I suggest is to make sure the emulator is set up as close to a real Atari, turn off any boosting stuff in acceleration and fast boot, check your firmware is matching the system ie PAL or NTSC. 

Edited by Mclaneinc

Share this post


Link to post
Share on other sites

Thank you both so much for testing. So, then, there is still hope. 🙂

 

Yes, A0.BAS ist the preloader for the course, followed directly by A1.BAS. My suggestion, we freeze here and I will try to get the code visible like in A0.BAS. In Altirra it is possible to make invisible and protected BASIC code visible and unprotected. 🙂 Then, from the soure code, we should know. 🙂 Thank you so much. 🙂

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...