Jump to content
Vectral_Gamer

Broken Atari-Black Screen

Recommended Posts

That is your problem, that power supply is for the Sears pong console. You need a 2600 power supply. You can order one from Best Electronics or you can get one from RadioShack. I'll put a link below for Best and a post that has the RadioShack parts in it. If you're going to order from Best just send them an email and they will get back to you pretty quickly.

 

Best Electronics: http://www.best-electronics-ca.com/power%20guide.htm

 

RadioShack Power Supply: http://atariage.com/forums/topic/235787-atari-2600-jr-power-adapter/

Share this post


Link to post
Share on other sites

I don't know what to try next. I know it's not the switch box/ rca cable, i tested the chips as best I could, I cleaned it. What does that leave? Soldering and power?

Share this post


Link to post
Share on other sites

I can almost guarantee it's the power supply, take a picture of the underside of the power supply so we know what the specs are on it. Just to rule out that it's not 9v.

Share this post


Link to post
Share on other sites

Well there it is, that's the source of your problem. 5.5vdc and 100ma, that's nowhere near enough to power the 2600. Now you need to order a power supply, I posted above to point you in the right direction. Once you get a new power supply it will solve the problem.

Share this post


Link to post
Share on other sites

also find a pong console & play some Pong :thumbsup:

Pong consoles are really fun too :) and most of the time pretty cheap.

Share this post


Link to post
Share on other sites

I don't know how he could of? Who knows though, it may of worked half way at one point with that power supply.

Share this post


Link to post
Share on other sites

I went to lowes many years ago and got a rca universal for 15 bucks. No longer available. But works great. Its 500mah and came with bunch of adapters different sizes. Not sure where I put them. But the one for the atari still works great. Fits perfectly.

 

This is the one.

 

http://www.lowes.com/pd_326425-63374-AH5WHN_0__?productId=3437998

Edited by 0078265317

Share this post


Link to post
Share on other sites

It worked! I got the new power supply, Hooke it up, and vóila! It's working! Donkey Kong, here I come! Thanks everyone who posted, especially you Gribble

Share this post


Link to post
Share on other sites

It worked! I got the new power supply, Hooke it up, and vóila! It's working! Donkey Kong, here I come! Thanks everyone who posted, especially you Gribble

No problem, I hope you enjoy it. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...