Jump to content
robbo007

Atari 2600 UK version TV connection issues

Recommended Posts

Hi all,

I've just acquired an Atari 2600 UK version and I'm having problems connecting to the TV. Its got the RF cable and not the RCA one. My TV has Satellite IN Coax in and RCA IN ports.

 

What connector do I need?

 

I've tried connecting the the normal antenna connector on my TV but the image is bad and its does not tune in properly.

Share this post


Link to post
Share on other sites

I think you'll either need to mod the console or use a PAL VCR to convert the connection into a composite signal for your TV.

Share this post


Link to post
Share on other sites

Is the UK version not PAL? Why do I have to mod it? My TV has component RCA video and audio inputs. Can't I use them?

 

Thanks,

Rob

Share this post


Link to post
Share on other sites

You should be able to connect through the areal input, that's what I used to do back in the day although how good a signal you will get can depend on the quality & stability of the output from the VCS and your TVs ability to cope with it, unfortunately in my experience older consoles just don't seem to display well on modern TV's, even my Jag and PS2 don't come out well using AV/SCART input.

 

Are you using Auto or manual tune?

In the UK things like games consoles and VCRs were required to output a signal on Ch.37 (I believe somewhere around the 550 - 650MHz frequency) so as not to interfere with other channels. Auto tune may stop at a side band and not the main channel or a few MHz short of the main channel when it receives as suitable signal strength which may be enough for sound and/or video but not of the best quality as it is not tuned exactly (i.e. bad sound and/or video that is snowy or has the wrong colours) so if you have not already done so try either auto tune to get you close then manually adjust from there to get the best quality possible or just manual tune from the start.

Share this post


Link to post
Share on other sites

ok thanks for the help. I'll try this. If this fails and I don't get a good picture is there any other way to get a better picture?

Share this post


Link to post
Share on other sites

I am sure this issues has seen questions like this asked before so try doing a search of the Hardware and 2600 forums to see what (if any) solutions worked.

 

As I recall there is also an AV mod (developed by Curt Vendel/Longhorn Engineering?) although you would have to find reviews from people who have used it to know if it produces better results than RF or just provides an alternative connection method, in any case any other solution is likely to require some soldering.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...