Jump to content

Recommended Posts

Greetings,

 

I downloaded Atari800MacX.

 

I then downloaded the ROMs.

 

I can use BASIC and play some .atr games using keyboard.

 

Bought a retrolink joystick. Having trouble making that work.

Played around with USB Overdrive and Joystick Mapper, but not having much luck.

 

Any advice?

 

Thanks.

Share this post


Link to post
Share on other sites

I have problems getting usb joysticks to work, and with getting emulation to work in general. Haven't tried the retrolink cable. Neither syzygy rev 1 or 2, and controllers plugged into a 2600daptor II would work. What I did is to turn USB Overdrive off by leaving the enabled box empty, unchecked, or unclicked. (I guess that program didn't help) Then, I tested Atari800MacX with the joystick plugged in before opening Atari800MacX, and then again with it plugged in after opening Atari800MacX. I also clicked preferences, Atari tab, and clicked 'use international keyboard translation', which I saw in a forum.



Before, no keyboard or joystick input was having any noticeable effect, except If I plugged in the controller before opening Atari800MacX, the character would make a hard left after pressing start, and no effect if I plugged it in after opening Atari800MacX. The only input I that worked was the mouse, menu, and using the mouse with the function key window. After "turning off" USB overdrive and perhaps because of the keyboard preference change in the emulator, both Syzygy and 2600daptor 2 joysticks worked. However, it works on the second try, at least on this mac. Something about if the joysticks are plugged before or after the emulator is loaded makes a difference. So you plug in the controller, open the emulator, it won't work, and then unplu and replug the controller, you re-open the emulator and it should work. I tried plugging in the joystick after opening the emulator the first time, and that did not work. It was only after leaving the controller plugged in and re-opening Atari800MacX again after that did the controls just suddenly work. Not sure why all this is.




The 2600daptor worked on the first try later, and was stuck on autofire somehow, but the syzygy seemed to work normal. Hope this helps. It sure was frustrating trying to get this to work.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...