Jump to content
nanochess

CoolCV emulator for Mac OS X, Linux, Windows and Raspberry

Recommended Posts

So is this the best CV emulator for windows? Sorry new to CV emu scene and all the phoenix news has me wanting to try some CV games.

 

Does CoolCV have SGM support?

Yes, it supports the SGM.

 

Best emulators are for CV are BlueMsx, CoolCV, Adamem and then MAME/MESS.

  • Like 1

Share this post


Link to post
Share on other sites

Yes, it supports the SGM.

 

Best emulators are for CV are BlueMsx, CoolCV, Adamem and then MAME/MESS.

 

While BlueMSX has great CV emulation it does have some issues and appears to be no longer under development. I don't recall clearly but my recollection is that the SGM was never successfully supported and there were issues when using real CV controllers with rotary movement such as the driving controller, roller controller and the spinner on the super action controllers. Whereas with CoolCV all of these work, more or less out of the box, and so CoolCV is now my go to CV emulator replacing BlueMSX after many years.

  • Like 1

Share this post


Link to post
Share on other sites

I've been proposed to implement F18A support some months ago but I don't had time yet to check it.

 

Just curious if you've had any further thoughts about adding F18A emulation to Cool CV. I'm sure this would be something quite a lot of people would like to have.

  • Like 1

Share this post


Link to post
Share on other sites

Hi, apologies for the late question, I was wondering, do you still need to supply +5v directly to the trackball? TIA. Al

Yes, you need to connect the CV Power Supply to the Roller Controller just the same as you still need 4 C-Batteries to use the Driving Module with that controller interface.

Share this post


Link to post
Share on other sites

Having issues with running COOLCV 6.6 in windows 10 64 bits. It opens in black screen and it is unresponsive. Appears running on 32 bit......Any ideas on how to fix issue? thanks!

Share this post


Link to post
Share on other sites

Having issues with running COOLCV 6.6 in windows 10 64 bits. It opens in black screen and it is unresponsive. Appears running on 32 bit......Any ideas on how to fix issue? thanks!

 

How are you loading it? Are you double clicking on the executable? Running it from a command prompt? What parameters are you using if from a command prompt? Dragging a ROM over to it? Which ROM?

Share this post


Link to post
Share on other sites

Thanks for your response.

 

Yes, I am trying to run directly by double clicking on the exec. I then get a black screen. When I drag and drop any rom, it remains black and becomes unresponsive. The only way to close is to end with task manager. See pictures.

 

I have used COOLCV in the past, but never with Win 10 64.

 

thanks again for your help!

Al

post-44601-0-38385500-1547765318.png

post-44601-0-55037700-1547765325.png

post-44601-0-13068700-1547765334_thumb.png

post-44601-0-74548200-1547765340.png

Share this post


Link to post
Share on other sites
I have used COOLCV in the past, but never with Win 10 64.

 

I just downloaded 6.6 and copied it to a new folder in my Window-64bit system and the game loaded fine. I do have the latest updates applied. I am thinking the issue is not Windows. Could it be an access issue? Maybe it is not creating the config file in the My Documents folder?

 

Would you try right clicking on the executable and select "Run as administrator"?

Share this post


Link to post
Share on other sites

Hi, thanks a lot!

 

I tried "run as admin" and did not work. Also I checked for config. is present in my documents and looks all correct . See attached. I will run win updates an check. Does the computer need to have any other apps/drivers loaded for coolcv to work? I such as JAVa, Flash adobe or any other like. Attached all I see in programs.

 

Stella work perfectly first try. K5200 and retroarch worked fine after I fixed some VCS.dll files and video drivers gl.

 

 

thanks!

Al

post-44601-0-45160400-1547768928.png

post-44601-0-94280000-1547769236_thumb.png

Edited by alortegac

Share this post


Link to post
Share on other sites

I tried "run as admin" and did not work. Also I checked for config. is present in my documents and looks all correct . See attached. I will run win updates an check. Does the computer need to have any other apps/drivers loaded for coolcv to work? I such as JAVa, Flash adobe or any other like. Attached all I see in programs.

 

Stella work perfectly first try. K5200 and retroarch worked fine after I fixed some VCS.dll files and video drivers gl.

 

I did nothing special to my system. CoolCV ran perfectly. Hopefully, Oscar will chime in about the need for supporting programs. I do not think anything extra is needed. Sorry I could not help.

Share this post


Link to post
Share on other sites

 

I did nothing special to my system. CoolCV ran perfectly. Hopefully, Oscar will chime in about the need for supporting programs. I do not think anything extra is needed. Sorry I could not help.

Thank you so much. I have tried almost everything I know...still no luck.

Share this post


Link to post
Share on other sites

I switch to another computer and COOLCV was running correctly standalone. Once I paired with LAUNCHBOX.....run well few times and then I got the black screen of death again..It does not run anymore., even standalone. Crashing every time.

KAT5200 also crashed the same way after running fine few times standalone, I paired it with LAUNCH BOX...it worked few times, then black screen.

 

I reinstalled both emulators from scratched again both still crashing to black screen when starting up....

 

Any ideas? Any experience with COOLCV and LAUNCH BOX.

 

 

thanks!

  • Like 1

Share this post


Link to post
Share on other sites

Running (trying) CoolCV on Mac Mojave 10.14.1 - (OpenEMU does fine on regular Colecovision but wanted the SGM)

Keep getting this:

 

CoolCV cannot be opened because of a problem

 

Check with the developer to make sure CoolCV works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS.

Click Report to see more detailed information and send a report to Apple.

 

Share this post


Link to post
Share on other sites

Running (trying) CoolCV on Mac Mojave 10.14.1 - (OpenEMU does fine on regular Colecovision but wanted the SGM)

Keep getting this:

 

CoolCV cannot be opened because of a problem

 

Check with the developer to make sure CoolCV works with this version of macOS. You may need to reinstall the application. Be sure to install any available updates for the application and macOS.

 

Click Report to see more detailed information and send a report to Apple.

I'm running on 10.14.1 with no issues. Which games have you tried?

Share this post


Link to post
Share on other sites

Tried The Dukes of Hazzard game & Buck Rogers by dragging onto the icon & then setting it up to open with the CoolCV app via "get info".

Neither worked.

 

I did get the dialogue box.

Exactly how did you get yours running & what version did you use?

Edited by knievel1
  • Like 1

Share this post


Link to post
Share on other sites

Tried The Dukes of Hazzard game & Buck Rogers by dragging onto the icon & then setting it up to open with the CoolCV app via "get info".

Neither worked.

 

I did get the dialogue box.

Exactly how did you get yours running & what version did you use?

I just dragged to my CoolCV icon. I just tried your other method of changing the associated program to CoolCV and it also worked. You've re-installed the emulator as well?

 

I'm using version 0.6.3

 

Oh and a possibly silly question but you do have the coleco bios on your system correct?

Share this post


Link to post
Share on other sites

I just dragged to my CoolCV icon. I just tried your other method of changing the associated program to CoolCV and it also worked. You've re-installed the emulator as well?

 

I'm using version 0.6.3

 

Oh and a possibly silly question but you do have the coleco bios on your system correct?

The BIOS is included with CoolCV. Probably it's missing installing libSDL.

Share this post


Link to post
Share on other sites

The BIOS is included with CoolCV. Probably it's missing installing libSDL.

Is the BIOS also included on the raspberry pi version?

Share this post


Link to post
Share on other sites

Is the BIOS also included on the raspberry pi version?

 

Yes, it's integrated in the emulator. Couldn't find an easy and portable way to get the current directory of executable.

  • Like 1

Share this post


Link to post
Share on other sites

 

Yes, it's integrated in the emulator. Couldn't find an easy and portable way to get the current directory of executable.

God bless you for that :)

Share this post


Link to post
Share on other sites

Thanks for your response.

 

Yes, I am trying to run directly by double clicking on the exec. I then get a black screen. When I drag and drop any rom, it remains black and becomes unresponsive. The only way to close is to end with task manager. See pictures.

 

I have used COOLCV in the past, but never with Win 10 64.

 

thanks again for your help!

Al

Could you please tell me about this problem? Everything works perfectly except COOLCV. I cannot find a confi file to check on how is loading or a debugger? Does it conflict with LAUNCHBOX? Any suggestions will be appreciated./ Al

Share this post


Link to post
Share on other sites

I get only here and then it crashes and becomes unresponsive....but I could see it is there somewhere but screen is all black. Any ideas? thanks!

post-44601-0-25674300-1548284314.png

Edited by alortegac

Share this post


Link to post
Share on other sites

I get only here and then it crashes and becomes unresponsive....but I could see it is there somewhere but screen is all black. Any ideas? thanks!

 

Sorry! I don't know what happens. I don't know Launchbox nor I've tested it.

 

If CoolCV already worked in your setup, and doesn't work after installing LaunchBox, and also makes another emulator to fail, then it's pretty probable LaunchBox messed up your display settings.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...