Jump to content
kevtris

FPGA Based Videogame System

Interest in an FPGA Videogame System  

667 members have voted

  1. 1. I would pay....

  2. 2. I Would Like Support for...

  3. 3. Games Should Run From...

    • SD Card / USB Memory Sticks
    • Original Cartridges
    • Hopes and Dreams
  4. 4. The Video Inteface Should be...



Recommended Posts

I am not great at this stuff, but would love to get ahold of all the hacks and such in the SmokeMonster 7.0.7 pack.

But I have tried many different searches, and downloads after creating accounts various places and keep getting errors when I try to load them from Megasync etc.

If anyone could be so kind as to PM me a good location for this set, I would be GREATLY obliged, thanks in advance!

 

 

pm sent

  • Like 1

Share this post


Link to post
Share on other sites

They should be able to get much darker at 720p. Try dropping the height to 719 and then adjust the scanline intensity and they will go much darker. That suggests to me that they are broken even at 720p and this seems to be the case for both normal and hybrid scanlines.

 

I just tried this myself and got some interesting results. It seems that the scanlines closer to the center of the screen are much more defined in 720p when you move the height to 719. They actually look pretty awesome, like the scanlines on my BVM. But when you get further to the edge of the screen they're less defined. This is the case for normal and hybrid. Looking at a 240p test grid for instance, when height is set to 720, you see no scanlines in the white using hybrid scanlines. You switch to 719 and at the highest intensity, even the white has very defined BVM like scanlines. Odd....

Edited by jamon1567

Share this post


Link to post
Share on other sites

 

 

I did try out the "Altered Beast Arcade Voice+Alternate Style (Hack) Linkuei v1, Pyron v2” and it worked fine both via the Mega SG Jailbreak, as well as on the Everdrive X7.

 

Maybe it's a bad copy onto your SD card or something. What might be helpful is in the Smokemonster Packs there are multiple copies of that rom (in mine I count 13 duplicate copies :lol: ). Maybe try out one of the other locations? Also you didn't mention if you tried it out via the jailbreak.. maybe try that as well?

 

attachicon.gifimage1.jpg

Doesn’t work on my MED X5 or JB MSg. I’ve got a feeling it has something to do with the filename (length and special characters) but I’m not at home and can’t verify right now.

Share this post


Link to post
Share on other sites

 

 

I did try out the "Altered Beast Arcade Voice+Alternate Style (Hack) Linkuei v1, Pyron v2" and it worked fine both via the Mega SG Jailbreak, as well as on the Everdrive X7.

 

Maybe it's a bad copy onto your SD card or something. What might be helpful is in the Smokemonster Packs there are multiple copies of that rom (in mine I count 13 duplicate copies :lol: ). Maybe try out one of the other locations? Also you didn't mention if you tried it out via the jailbreak.. maybe try that as well?

 

attachicon.gifimage1.jpg

 

I did try it out on the Mega SG jailbreak. I have tried many of those in both the Mega Everdrive and the Mega SG and all I get is a blue screen on all of them. How does this even happen?

Share this post


Link to post
Share on other sites

Doesn’t work on my MED X5 or JB MSg. I’ve got a feeling it has something to do with the filename (length and special characters) but I’m not at home and can’t verify right now.

 

I just changed the file name so it was shorter and didn't have any special characters and still on the X7 and the Mega SG jailbreak I get the blue screen. The same rom with the name not changed works perfect on the Genesis core on the MiSTer.

Edited by killersquirel

Share this post


Link to post
Share on other sites

Quick question to all. Has anybody had issue, or know how to overcome controller port #2 not recognising a x6 button controller.

 

Just tried playing Street Fighter 2 (Super), on cartridge and no matter which controller is plugged in, port #2 only recognises x3 buttons, not all x6.

 

I performed the controller test in the Mega SG menu and same there, the port only recognises buttons ABC. Again I've switched controllers to check for defects, port #1 will recognise all x6 buttons on both controls.

 

Am I missing something, or do I have a duff port?

Share this post


Link to post
Share on other sites

Quick question to all. Has anybody had issue, or know how to overcome controller port #2 not recognising a x6 button controller.

 

Just tried playing Street Fighter 2 (Super), on cartridge and no matter which controller is plugged in, port #2 only recognises x3 buttons, not all x6.

 

I performed the controller test in the Mega SG menu and same there, the port only recognises buttons ABC. Again I've switched controllers to check for defects, port #1 will recognise all x6 buttons on both controls.

 

Am I missing something, or do I have a duff port?

For now you have to turn on passthrough mode to get 6 buttons to work for controller 2. There will be a fix possibly next firmware update.

Edited by SegaSnatcher
  • Like 2

Share this post


Link to post
Share on other sites

 

I did try it out on the Mega SG jailbreak. I have tried many of those in both the Mega Everdrive and the Mega SG and all I get is a blue screen on all of them. How does this even happen?

 

This happens on roms packs all the time. Having a corrupt file is commonplace in the retro scene I've had my share of bad files.

Share this post


Link to post
Share on other sites

For now you have to turn on passthrough mode to get 6 buttons to work for controller 2. There will be a fix possibly next firmware update.

Excellent, worked a treat, two happy children hitting he'll our of each other in Street Fighter now. Was getting worried about some sort of fault for a minute.

  • Like 1

Share this post


Link to post
Share on other sites

I haven't had any problems with the sound so far on the current firmware besides Greatest Heavyweights on the Genesis.

 

There's an instrument on the Title theme that feels nonexistent compared to what it would sound like on a real Genesis. You can hear it a little bit if you play around with the audio settings, but it's just not like it is on the real thing. Excited for the audio revamp in the next firmware because I think this will be fixed.

Share this post


Link to post
Share on other sites

How do you get Colecovision SGM games to work on Mega Sg jailbreak?

 

edit: Select Cores, Colecovision, press Start button, Core Options, click Use SGM.

Share this post


Link to post
Share on other sites

I haven't had any problems with the sound so far on the current firmware besides Greatest Heavyweights on the Genesis.

 

There's an instrument on the Title theme that feels nonexistent compared to what it would sound like on a real Genesis. You can hear it a little bit if you play around with the audio settings, but it's just not like it is on the real thing. Excited for the audio revamp in the next firmware because I think this will be fixed.

Who said anything about an audio revamp in the next firmware?

Share this post


Link to post
Share on other sites

 

I did try it out on the Mega SG jailbreak. I have tried many of those in both the Mega Everdrive and the Mega SG and all I get is a blue screen on all of them. How does this even happen?

 

I dunno man. Here's what I played. Maybe try it out and see if any difference.

Altered Beast Arcade Voice+Alternate Style (Hack) Linkuei v1, Pyron v2.bin

  • Like 1

Share this post


Link to post
Share on other sites

Who said anything about an audio revamp in the next firmware?

I might have mistook the information regarding this current firmware having a overhaul. Not really sure. I thought some place or somebody said something about it and maybe I mistook it for this current firmware. Sorry.

 

The game I mentioned was the only one I saw as a problem though of it not sounding like it does originally.

Share this post


Link to post
Share on other sites

 

On the subject of scanlines, i've noticed that in 720p mode at 3x screen height, using the normal non-hybrid scanlines the line darkness/intensity will reach its maximum somewhere on the depth slider between 60-80 and anything more than that doesn't seem to affect them at all.

 

It's only when you go in to the Width & Height settings and change the height to anything less than 720 that the scanlines will darken beyond this at higher depth settings, although by changing the height to a non-integer scale this obviously starts to mess up the scanline spacing a bit.

Does this on the Super Nt too. Looks like they both share the same simulated scanlines and it’s broken on both.

Share this post


Link to post
Share on other sites

I might have mistook the information regarding this current firmware having a overhaul. Not really sure. I thought some place or somebody said something about it and maybe I mistook it for this current firmware. Sorry.

 

The game I mentioned was the only one I saw as a problem though of it not sounding like it does originally.

 

There were definitely some audio fixes in 4.3, but I haven't heard of any additional audio fixes that are coming soon:

https://support.analogue.co/hc/en-us/articles/360024836892-Mega-Sg-Firmware-Update-v4-3

Share this post


Link to post
Share on other sites

Yeah, and it’s not like some of their suggestions weren’t wrong from the start... like telling people to just leave Cartridge/CD Audio on when they aren’t even connected to a Sega CD or playing special carts. That’s what caused the audio noise they complained about earlier in the video.

 

I mean... DUH. If they had even asked themselves “why is this optional?” and got an answer then they would have known better. Instead, they just complained that it defaulted to Off “for some reason” and theorized that it might be fixed in an update. Clearly, their knee-jerk assumption that it should be On no matter what was never even questioned and they didn’t notice the connection between their complaint and their advice.

 

Can’t edit their video, indeed.

 

I enjoyed their review and thought it was the best of the first wave but the hubris is pretty strong here. The idea that there is any one particular Genesis with perfect audio for all games continues to express that.

 

 

 

I agree with your conclusion. I enjoyed Joe's video, but some of his comments this past week bug me. when they "finally understand" the Genesis audio hardware, for example. I'm all for calling out a company when they don't get it right, but this is hyperbolic at best and outright harmful and intentionally divisive at worst.

 

Joe got it for free (which he said in the video, so I'm not making it up) and made a video that's received nearly 100k views. In the conclusion of his video he said "hell yeah it's worth it" if you just want to plug in and play your carts with no lag, and "this is the best fake Genesis there is". Not sure what his beef is a week later just because the firmware has improved.

  • Like 1

Share this post


Link to post
Share on other sites

PSA: if you're following some video online on how to set up the audio on your Mega Sg, it's time to stop. According to GameSack, the latest firmware changed how all the settings work, so nobody's suggestions are going to work like they did on the release-day firmware. https://twitter.com/GameSack/status/1114390465665568769

 

 

Ya know... it never crossed my mind to try and tweak the sound settings. I know they're there, but I just left them at default and started playing. I guess I figured the designers know way more about how it "should" be set than I ever will, so default was the way to go. If I stop being lazy and decide to figure it out, is there a nice handy guide for what tweaks what floating around somewhere? Or is that a "read the friggin' manual" kind of thing?

Edited by malrak

Share this post


Link to post
Share on other sites

SMS FM sound for Shinobi is not quite right with JB software.

 

Playing Colecovision games with rapid fire Genesis controller is awesome.

  • Like 1

Share this post


Link to post
Share on other sites

 

Ya know... it never crossed my mind to try and tweak the sound settings. I know they're there, but I just left them at default and started playing. I guess I figured the designers know way more about how it "should" be set than I ever will, so default was the way to go. If I stop being lazy and decide to figure it out, is there a nice handy guide for what tweaks what floating around somewhere? Or is that a "read the friggin' manual" kind of thing?

Im experimenting and have settings I like well enough. But FirebrandX has promised hed do a video that will go into depth once the firmware settles down. Im interested in that but what I have is ok for now.

 

Im using a low pass filter at around 3.8kHz with a rolloff of 20. The ladder effect is at 4. PSG channels at 30 and YM channels at 100. I think for the most part it sounds close to my model 1, but not exact.

Share this post


Link to post
Share on other sites

Oh for sure, that was kinda my point. You would think PAL exclusives would be best at 50hz but without knowing what the developers actually intended or what dev kits they used it is hard to really know for sure.

MM games are too fast at 60hz IMO though.

At least the MSG gets rid of the aspect ratio issues, although again who is to say PAL region developers didnt intend their games to be played in a letterbox format?

IIRC, most games run at about 17% slower on the PAL 50Hz video standard. Just watch a playthrough of Sonic on a PAL Mega Drive and it will look like it's running in a slow motion mode, complete with slow music too.

 

There were some games which took this slowdown into consideration and adjusted the original game for PAL 50Hz, so that it would match the speed of the NTSC counterpart. Codemasters did this with Micro Machines, so if you play the PAL-optimized version on an NTSC system then it's going to be 17% faster than it should run.

 

There may be more to it than this. I'm just going off of memory here from when I used to download MD roms from a German BBS in the early 90's.

Share this post


Link to post
Share on other sites

This dummy might need a little assistance with the JB Firmware. My memory is deteriorating pretty badly, but I muddle through with enough prods. Anyways, I managed to drop the JB FW onto the card, booted up the SG and after a couple of tries, it reflashed - then I checked the revision number and noted the extra cores options. So far, so good. Deleted the firmware from the card, then, I unzipped the structure folder into the root, reading MSG File System in the outer folder, the SD Card, then within that the BIOS and individual system folders. Is this correct or do they need to be organized differently? Then I copied the BIOS files I had in my NT Mini BIOS folder over to the BIOS folder on the SG. I have a feeling this might be a bit off. Do the B's need a specific naming scheme, different from that, are they out of date? I also plopped a few random game roms I had into the individual folders. Booted up again, selected a core, selected a game and - plop, just little white squares.

 

Had little trouble with the Mini, but that was a couple years back...probably need my head reflashed or a refresher.

Share this post


Link to post
Share on other sites

This is what the directory structure on the root of your SD card should look like :

 

\BIOS

\COLECO

\FONT

\GENESIS

\GG

\PATTERN

\SAVES

\SMS

 

The file name of the BIOS does not need to be anything special, unlike the Nt Mini. Just select your BIOS, ensure the checkbox is enabled, then load a game on the SD card.

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...