Jump to content
Sign in to follow this  
wayne253

TurboDuo dead :( :( needing a repair

Recommended Posts

So I dug out my TurboDuo yesterday and hooked it up to my old CRT TV in hopes to play Bonk and my new acquisition of Bloody Wolf; turned the power on.....nothing, checked the power supply and made sure it was in the wall....nothing. Even took the HuCard out and tried to power on the system, hit start, and see if the busy light was lit (thinking it may be an AV connection issue)....nothing.

 

So looks like I need my Duo repaired; whether it be the fuse, or the internal voltage regulators crapped out and need replaced. Could use a hand here on where I can send off my system. Better yet is there anyone near the Pacific Northwest area that have the know-how to get my Duo back up and running?

 

Any help/advice would be awesome. Thanks :)

Share this post


Link to post
Share on other sites

Have you checked the power supply first? as in, have you tried to use it on say, a Megadrive I or a NES or SNES to see if those systems power on?

If they do, then we removed that part and can go on the system itself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...