Jump to content
Sign in to follow this  
MaximRecoil

The picture jumps in Asteroids

Recommended Posts

The whole picture shifts slightly (maybe 1/16") up and down every few seconds in Asteroids. That isn't normal is it? It doesn't do it in the Stella emulator. I tried my Asteroids cartridge in a few different Atari 2600s (heavy sixer, light sixer, and a 4-switch woodgrain), as well as in my Atari 7800, and it does the same thing in all of them. None of my other cartridges do this.

Edited by MaximRecoil

Share this post


Link to post
Share on other sites

I just tried Asteroids on two different CRT TVs and the picture was perfectly stable on both of them. So apparently, my main TV (also a CRT) doesn't like Asteroids, which is bizarre, given that I don't have any issues on that TV with any other cartridge for Atari or any other game for any other console I own.

 

I wonder if there are any non-standard coding tricks used in Asteroids. Doesn't the Atari 2600 rely on the game code to generate an NTSC-compatible video signal? If so, it would be possible for some 2600 games to be more NTSC compatible than others.

Share this post


Link to post
Share on other sites

Possible bit-rot of the ROM, while rare it does happen. I think I've encountered it twice out of 500 or so cartridges.

 

Easy fix - Space Rocks :D

 

Hmm, the video's missing from the store front for some reason. Probably happened when the Box and Box-less versions were combined into one entry.

Share this post


Link to post
Share on other sites

Possible bit-rot of the ROM, while rare it does happen. I think I've encountered it twice out of 500 or so cartridges.

 

Easy fix - Space Rocks :D

 

Hmm, the video's missing from the store front for some reason. Probably happened when the Box and Box-less versions were combined into one entry.

 

You posted at about the same time that I made my second post, so you didn't see it. In any event, it isn't the cartridge, it's my TV.

 

I'm aware of Space Rocks, and it would be a nice game to have, but I'm also nostalgic about the original Asteroids cartridge. It was 1 of the 5 games I bought the same day I bought my first Atari when I was 10 years old in 1985.

Edited by MaximRecoil

Share this post


Link to post
Share on other sites

I wonder if there are any non-standard coding tricks used in Asteroids. Doesn't the Atari 2600 rely on the game code to generate an NTSC-compatible video signal? If so, it would be possible for some 2600 games to be more NTSC compatible than others.

 

It's possible, Warlords generated the sync signal incorrectly and confused the XRGB-mini when used with that new RGB mod. I fixed that ROM, it's available in my blog.

 

I took a quick look at Asteroids and it's doing the same thing, setting VSYNC before WSYNC instead of after:

post-3056-0-09917500-1444746025_thumb.png

 

Do you have a Harmony cartridge? If not, I highly recommend getting one.

Share this post


Link to post
Share on other sites

 

It's possible, Warlords generated the sync signal incorrectly and confused the XRGB-mini when used with that new RGB mod. I fixed that ROM, it's available in my blog.

 

I took a quick look at Asteroids and it's doing the same thing, setting VSYNC before WSYNC instead of after:

attachicon.gifScreen Shot 2015-10-13 at 9.19.16 AM.png

 

Do you have a Harmony cartridge? If not, I highly recommend getting one.

 

Thanks for looking into that.

 

No, I don't have a Harmony cartridge. And that sucks about Warlords; I just bought that game (it hasn't arrived yet), and it will probably do the same thing on my main TV that Asteroids is doing. I wish Atari 2600 cartridges could be opened up without ruining the label; then I could possibly have a new, fixed ROM burned for games like this. I suppose a Harmony cartridge would make more sense, but I like dedicated cartridges and their labels, that simply boot to the game you want to play immediately.

 

Would it be hard to fix the Asteroids ROM? I'd like to have a fixed version in case I get a Harmony cartridge.

Edited by MaximRecoil

Share this post


Link to post
Share on other sites

 

No, I don't have a Harmony cartridge. And that sucks about Warlords; I just bought that game (it hasn't arrived yet), and it will probably do the same thing on my main TV that Asteroids is doing. I wish Atari 2600 cartridges could be opened up without ruining the label; then I could possibly have a new, fixed ROM burned for games like this. I suppose a Harmony cartridge would make more sense, but I like dedicated cartridges and their labels, that simply boot to the game you want to play immediately.

 

Would it be hard to fix the Asteroids ROM? I'd like to have a fixed version in case I get a Harmony cartridge.

 

If it does check out Medieval Mayhem, my take on Warlords. Hmm, that video's missing too...

Share this post


Link to post
Share on other sites

I've noticed that progressive scan CRT televisions don't do too great with some of my games. Check to see if you have the Red, Blue and Green component connections for more modern systems on your TV. I have two sets that have this and neither does well with my Atari games. My HD's do fine, as do my non-component TV's.

Share this post


Link to post
Share on other sites

I've noticed that progressive scan CRT televisions don't do too great with some of my games. Check to see if you have the Red, Blue and Green component connections for more modern systems on your TV. I have two sets that have this and neither does well with my Atari games. My HD's do fine, as do my non-component TV's.

 

My TV has component (YPbPr) inputs, but it isn't capable of progressive scan (at least not of the ~480p variety, which is ~31 kHz). It handles progressive scan of the ~240p variety just fine (~15 kHz), as do nearly all CRT TVs ever made. Most, if not all, consoles prior to the Sega Dreamcast output a ~240p signal, which is why you can see "scanlines" on them. The Dreamcast defaulted to 480i, which is also ~15 kHz.

 

In any event, I bought this TV new 10 years ago, and I've connected practically every major console made between the Atari 2600 and the PS2 to it, and I've never had an issue with any game before. Granted, I haven't played a lot of different Atari 2600 games on it; I usually stick with a handful of favorites when I'm in the mood to play Atari.

Share this post


Link to post
Share on other sites

And that sucks about Warlords; I just bought that game (it hasn't arrived yet), and it will probably do the same thing on my main TV that Asteroids is doing.

 

Warlords came in the mail today, and its picture is perfectly stable on my main TV, so I don't know what's going on with Asteroids. Weren't there two versions of Asteroids, one with the "©1981, Atari Inc." splash screen and one without? Mine has the splash screen. I wonder if the version without the splash screen would be any different. Oddly enough, the picture is perfectly stable on that splash screen; it doesn't start jumping until it goes into "attract mode", and continues to jump when you are playing the game.

Share this post


Link to post
Share on other sites

 

Warlords came in the mail today, and its picture is perfectly stable on my main TV, so I don't know what's going on with Asteroids.

Darrell has already told the problem. Asteroids is not syncing to the TV correctly. This a real easy fix. There is a LDX #$FF instruction that can be changed to TSX, and then the VSYNC routine from Macro.h can be used. The values for TIM64T also have to be updated, but that's about it.

 

 

I don't have time to fix it right now, so maybe someone else will. You would also need a Harmony cart.

Share this post


Link to post
Share on other sites

Darrell has already told the problem. Asteroids is not syncing to the TV correctly.

 

Yes, and he said Warlords has the same problem, yet Warlords is perfectly stable on the same TV, so that changes things. And this doesn't look like any sync issue I've ever seen; the picture isn't rolling; it is shifting ever so slightly (about 1/16") up and then immediately back down, and it repeats that every couple/few seconds. Also, why is the splash screen perfectly stable? Here's a video:

 

Edited by MaximRecoil

Share this post


Link to post
Share on other sites

Yes, and he said Warlords has the same problem

It does have the same problem, VSYNC is hit before WSYNC instead of after.

 

When VSYNC is hit after WSYNC it ends up being triggered at cycle 3 (can also consider it as cycle 79 as a scanline takes 76 cycles).

 

For Asteroids it's being triggered at cycle 22.

 

For Warlords it's triggered at 62.

 

Also, why is the splash screen perfectly stable?

The splash screen in Asteroids is hitting it at cycle 55. Once the splash screen goes away it hits it at 22. For your TV hitting it between 55 and 79 is probably OK, while 22 is not.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...