Jump to content
SainT

Upcoming Jaguar Game Drive Cartridge

Recommended Posts

2 minutes ago, UHATEIT said:

Yeah formatted all of them to FAT32. Even took out a fresh 32GB that was brand new from the store and tried it, didn't work, then formatted it to FAT32 and still didn't work. Tried exFAT and didn't work either. 

Sounds like something is up, but it is probably going to take SainT to look into it (or an exchange from where you bought it) if it is indeed the SD card slot. I was thinking maybe a card that wasn't beveled could have crushed some pins, but even cheap rip-off SD cards I've seen have been beveled, its mostly SD card extenders where you run into that, but it is possible.
I'm just using a SanDisk (I forget, I think it is 64 or 128GB), formatted to FAT32. I used SD Formatter as well. I always use SanDisk and SD Formatter for my carts, unless they support exFAT (I forget if this does), or if they come with an SD card, I assume it is compatible and use it. Sandisk are the only ones I've found to never give me a problem on any, and I have like 3 dozen flash carts for things now.

Share this post


Link to post
Share on other sites

Another option is MiniAide Fat32 Formatter if you have windows or a windows virtual machine.  That is what I use to format cards and it works good.  The home version is free to use.

Share this post


Link to post
Share on other sites

I'm thinking it has to be a problem with the cart vs the cards. I also downloaded that SD formatter tool and did the same format and confirmed FAT32 and still comes back as Memory Card Unreadable. all of the cards show up on two separate laptops completely full with ROMs and properly formatted to FAT32 but the cart always says they're unreadable even though it says I have the most updated firmware

Edited by UHATEIT

Share this post


Link to post
Share on other sites

If SainT or Albert happens to see the issues I'm having above, is there any way for me to completely wipe the GD Cart of what is installed on it and then reinstall the latest firmware and see if that is the solution? This one was shipped this week and has Firmware V1.09 per the B option when pressed so it has the most updated stuff on it. But I never got any sort of update or ASIC thing or anything the first time I put it in (like in the Setup Guide video showing scrolling updates), only to "Insert Memory Card" and all cards say "Memory Card Unreadable"

 

Also with regards to SD cards, I have tried 3 Brands (Samsung, SanDisc, and Micro Center) and 3 sizes (16GB, 32GB, and 64GB) and all of them are formatted to FAT32 and all work on 2 laptops I own showing over 200 rom and mrq files but the GD just wont read any of them.

 

This is my cart info incase any of this matters for a possible new firmware link:

 

QR code#: 8CZ5GCMBAVVQH2

Serial#: W7F3J5P05Y5FB456759W1CYZVJ

Edited by UHATEIT
added info

Share this post


Link to post
Share on other sites

My GameDrive arrived today, worked just fine (sorry to hear someone else having an issue) I fired up Native, which to my understanding was a demo for something that would go on to become Sturmwind on Dreamcast, so as a big Dreamcast fan that was a treat to play. Atari Karts was fun too, though a little tricky to get the handling down. But great looking and running game.

Thanks Saint and Al 🥳

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, UHATEIT said:

If SainT or Albert happens to see the issues I'm having above, is there any way for me to completely wipe the GD Cart of what is installed on it and then reinstall the latest firmware and see if that is the solution? This one was shipped this week and has Firmware V1.09 per the B option when pressed so it has the most updated stuff on it. But I never got any sort of update or ASIC thing or anything the first time I put it in (like in the Setup Guide video showing scrolling updates), only to "Insert Memory Card" and all cards say "Memory Card Unreadable"

 

Also with regards to SD cards, I have tried 3 Brands (Samsung, SanDisc, and Micro Center) and 3 sizes (16GB, 32GB, and 64GB) and all of them are formatted to FAT32 and all work on 2 laptops I own showing over 200 rom and mrq files but the GD just wont read any of them.

 

This is my cart info incase any of this matters for a possible new firmware link:

 

QR code#: 8CZ5GCMBAVVQH2

Serial#: W7F3J5P05Y5FB456759W1CYZVJ

Odd, that means the format is not recognised. It needs FAT32. Are you formatting on a PC or MAC?

Share this post


Link to post
Share on other sites

Mine arrived a few hours ago. Can’t test it yet but excited to have this nonetheless!

61FAA4D9-4DB6-4B9B-9B05-11609FE1F958.jpeg

  • Like 3

Share this post


Link to post
Share on other sites
3 hours ago, SainT said:

Odd, that means the format is not recognised. It needs FAT32. Are you formatting on a PC or MAC?

It's being formatted on a PC. When the formatting is done it pops up showing FAT32. I even tried a brand new fresh never used 32gb I bought at the store 2 days ago that should already be FAT32 and it wouldn't work either. Then tried formatting it anyways and still didn't work. 

 

Share this post


Link to post
Share on other sites
2 minutes ago, UHATEIT said:

It's being formatted on a PC. When the formatting is done it pops up showing FAT32. I even tried a brand new fresh never used 32gb I bought at the store 2 days ago that should already be FAT32 and it wouldn't work either. Then tried formatting it anyways and still didn't work. 

 

(Not sponsered)

I had issues with various devices that claimed to be FAT32 compatible but wouldn't read a FAT32 formatted SD card. A format using AOMEI Partition Assistant made everything solved the problem in every case. Just something I discovered personally, YMMV :) 

Share this post


Link to post
Share on other sites
5 minutes ago, UHATEIT said:

It's being formatted on a PC. When the formatting is done it pops up showing FAT32. I even tried a brand new fresh never used 32gb I bought at the store 2 days ago that should already be FAT32 and it wouldn't work either. Then tried formatting it anyways and still didn't work. 

 

Very odd -- I know some have reported issues with Mac formatted memory cards, but I've never had an issue when formatted as FAT32 on PC. A new 32GB card should be FAT32 afaik, and should definitely work.

 

Sounds like there may be an issue with the cart at this point! Frustrating as they are all tested before leaving me, but things do occasionally get damaged in transit.

Share this post


Link to post
Share on other sites

Let me give my 2cents on this because I had similar problems with the NeoSD Loader and some everdrives.

 

For some odd reason some SD cards when formated with fat32format or some other software have an empty partition space or some odd partiton in the very beggining of it.

Get some software like Partition Wizard and move that small space to the end of the card.

  • Like 1

Share this post


Link to post
Share on other sites

 

 
For those with micro sd's problems ..... I think it is because of the type of partition. Try change it to MBR.
Edited by juanluma01

Share this post


Link to post
Share on other sites
Just now, juanluma01 said:

 

 
For those who do not work with the micro sd card ..... I think it may be because it have to be in MBR format.

 

I suspect this kind of thing is an issue for some, yes.

 

I need to take a look at how FatFS deals with trying to locate the main FAT partition and see if I can just ignore any non-FAT partitions before any FAT ones.

 

However a brand new card *should* be ok.... but I guess you never know. You can use partition manager in windows to check this kind of thing -- type "Create and format hard disk partitions" into the start bar.

 

If a memory card has been formatted weirdly I'll use that to delete all partitions and create a single partition and format.

 

Share this post


Link to post
Share on other sites

I'll try again when I get home soon. But I blew like 3 hours last night constantly reformatting all 7 cards with 2 different programs on my laptop, redrafting over 200 files to the cards and all immediately say memory card unreadable the instant it's pushed in. It's recognizing a card is inserted because it changes from "insert memory card". 

 

Since this came with V1.09 on it is there a way for me to erase the format on the cart itself and then download the latest update and format the cart brand new again? 

 

Definitely sucks to be the only one with this issue out of the 100 or so that were sent out this week. I have seenany arrive and posted but I seem to be the only one having this issue. Especially when I tried a completely brand new untouched SD I bought on Tuesday and got the same result. 

 

I have another laptop I can try formatting them on as well and see if it's the formatting program itself. I also have 3 other Atari Jaguars if I need to try another console. 

Share this post


Link to post
Share on other sites
1 hour ago, SainT said:

Very odd -- I know some have reported issues with Mac formatted memory cards, but I've never had an issue when formatted as FAT32 on PC. A new 32GB card should be FAT32 afaik, and should definitely work.

 

Sounds like there may be an issue with the cart at this point! Frustrating as they are all tested before leaving me, but things do occasionally get damaged in transit.

This one came from Atari Age versus the UK unless you test them before they are sent to Atari Age. But I ordered it with the cardboard box and it was super well packaged and arrived flawlessly tho. 

Share this post


Link to post
Share on other sites
3 minutes ago, UHATEIT said:

I'll try again when I get home soon. But I blew like 3 hours last night constantly reformatting all 7 cards with 2 different programs on my laptop, redrafting over 200 files to the cards and all immediately say memory card unreadable the instant it's pushed in. It's recognizing a card is inserted because it changes from "insert memory card". 

 

Since this came with V1.09 on it is there a way for me to erase the format on the cart itself and then download the latest update and format the cart brand new again? 

 

Definitely sucks to be the only one with this issue out of the 100 or so that were sent out this week. I have seenany arrive and posted but I seem to be the only one having this issue. Especially when I tried a completely brand new untouched SD I bought on Tuesday and got the same result. 

 

I have another laptop I can try formatting them on as well and see if it's the formatting program itself. I also have 3 other Atari Jaguars if I need to try another console. 

 

You dont need to copy anything onto the memory card to see if it works, in fact its probably helpful not to in terms of ruling things out.

 

If the cart cannot read the memory card you can't do anything to erase or re-install firmware as it's all done via the memory card.

 

Also definitely worth trying another machine, just in case. And if you can try another Jag, it's worth a go -- it shouldn't be related, but anything is a worth a try.

 

There are not as many JagGD's out there as there are my other carts, so I'm less familiar with the issues you may get than with those. It's a learning experience for me as much as everyone else when things don't work as expected! Sometimes issues are down to the (nearly) 30 year old hardware, other times they are actually issues with the cart.

 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, UHATEIT said:

This one came from Atari Age versus the UK unless you test them before they are sent to Atari Age. But I ordered it with the cardboard box and it was super well packaged and arrived flawlessly tho. 

Yes, everything is tested before it goes out to retailers. It doesn't matter where they're bought from, they all go through the exact same QC process here. :)

Share this post


Link to post
Share on other sites
28 minutes ago, UHATEIT said:

I'll try again when I get home soon. But I blew like 3 hours last night constantly reformatting all 7 cards with 2 different programs on my laptop, redrafting over 200 files to the cards and all immediately say memory card unreadable the instant it's pushed in. It's recognizing a card is inserted because it changes from "insert memory card". 

 

Since this came with V1.09 on it is there a way for me to erase the format on the cart itself and then download the latest update and format the cart brand new again? 

 

Definitely sucks to be the only one with this issue out of the 100 or so that were sent out this week. I have seenany arrive and posted but I seem to be the only one having this issue. Especially when I tried a completely brand new untouched SD I bought on Tuesday and got the same result. 

 

I have another laptop I can try formatting them on as well and see if it's the formatting program itself. I also have 3 other Atari Jaguars if I need to try another console. 

 

You can also try the MiniAide Fat32 Formatter program I mentioned.  It also very clearly shows if there are "ghost" or empty partitions on the card and they can be removed.

Share this post


Link to post
Share on other sites
33 minutes ago, UHATEIT said:

I'll try again when I get home soon. But I blew like 3 hours last night constantly reformatting all 7 cards with 2 different programs on my laptop, redrafting over 200 files to the cards and all immediately say memory card unreadable the instant it's pushed in. It's recognizing a card is inserted because it changes from "insert memory card". 

 

Mac Disk Utility these days can kinda be hit or miss.  :P    I don't know what they're doing.

 

Anyway, just some quick things I've done.

 

1) Use an older version of disk utility, like back in the OS 10.7 days if you have an older Mac around.

2) Trying formatting the SD card in an Android phone that has an Micro SD slot.   

 

Either of those could help you get a good Fat32 card for use in this.

 

For me I just try not to format flash media to Mac format if I can help it.

Share this post


Link to post
Share on other sites
1 hour ago, UHATEIT said:

This one came from Atari Age versus the UK unless you test them before they are sent to Atari Age. But I ordered it with the cardboard box and it was super well packaged and arrived flawlessly tho. 

I would be glad to exchange the cartridge for another, certainly sounds like there's an issue with it.  I'll send you a PM.

 

 ..Al

Share this post


Link to post
Share on other sites
3 hours ago, SainT said:

Yes, everything is tested before it goes out to retailers. It doesn't matter where they're bought from, they all go through the exact same QC process here. :)

if you are able to SainT can you tell based on looking at these pics I took if there is something showing wrong with these cards or the format? Albert responded and mentioned I could send it back, I'd just hate to have to ship it and wait for a new one if I can figure this out but this would be my last ditch attempt at it. I took pics showing what the formatting shows when it is done (with 1 of the programs) and then another showing when I click the card that it is in the drive it also shows Fat32. Am I missing something or does this look correct? also no light ever comes on for the card if there is supposed to be a light on it when it's reading the card.

 694071764_163232795_456379482148006_259152999384099895_n(1).thumb.jpg.1c8398e5a8c2b852515f202e653fae3c.jpg59758391_162987259_457891831933307_7043188421238149464_n(1).thumb.jpg.9c87d653b7d56149680089b0a890d0ab.jpg1587590035_164668145_270715767984661_1560500842400919778_n(1).thumb.jpg.dda10b8e75df4af0c95debaa8b9ce38c.jpg1336310696_163642244_488481202172984_5518558005734405148_n(1).thumb.jpg.b7cb6f7759d82129f2a9ab70079a2032.jpg

163062267_2910420465844119_3547750833536437989_n.jpg

Edited by UHATEIT

Share this post


Link to post
Share on other sites

From everything I've seen, it really should be working.

 

It certainly worked when leaving me, but as I say, things can get damaged in the post. :(

 

I'd say give a replacement a go given you've tried many different cards and many different formatting attempts.

  • Like 2

Share this post


Link to post
Share on other sites

Have you checked in disk management to see if there are any blank/empty partitions? Unlikely if you have tried so many cards but worth a look.  Anything caught in the SD slot?

Share this post


Link to post
Share on other sites
51 minutes ago, str0m said:

Have you checked in disk management to see if there are any blank/empty partitions? Unlikely if you have tried so many cards but worth a look.  Anything caught in the SD slot?

I actually downloaded one of the programs someone posted called MiniAide fat 32 Formatter and still got the same issue, I hit the erase partition options, tried formatting multiple cards, and still nothing. The slot seems to be fine too. When I push the SD card in its almost instant to tell me "Memory card Unreadable" and when I push it back out it goes back to "Insert Memory card" so it seems to know there IS a card in there almost instantly, just not reading anything on it. This is the kind of luck I have, I swear I've had so much bad luck in the retro game world these last few years!

1 hour ago, SainT said:

From everything I've seen, it really should be working.

 

It certainly worked when leaving me, but as I say, things can get damaged in the post. :(

 

I'd say give a replacement a go given you've tried many different cards and many different formatting attempts.

Thanks for taking a look at my pics man. I swear I've tried everything, just wanted to avoid having to ship, wait for them to get it and then wait for a new one. I thought perhaps if you saw the screen shots you could see an issue. Both show FAT32 in the pics. The only thing I can see it something called "Volume" not sure what that is but have tried 3 formatting programs on 2 different computers and it's all the same 

Share this post


Link to post
Share on other sites

So looks like Dragonbox got the shipment. Exciting, ordered and waiting...now somewhat more impatiently than before. :-D What a journey. Thanks SainT, this is going to be cool.

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...