Jump to content
nshollingsworth

Is it possible to fix a cartridge?

Recommended Posts

Hello everyone, When I first picked up my 800 (not xl), I bought a BASIC cartridge. I doesn't work. When I boot from it, the screen goes blank except for a few lines. When I push system reset the screen gets rid of the lines and shows the ready prompt. But I can only type in one line. When I push return to type in another, the screen goes blank and displays the lines (if I push reset it displays ready). Can anyone help me? Is there a way to fix the cartridge?

This is what I was typing in:

10 PRINT CR$(125)

20 FOR D=1 TO 10000: NEXT D

30 FOR L=1 TO 100

40 FOR P=253 TO 1 STEP -1

50 SOUND 0,P,10,15

60 SOUND 1,P=1,10,15

70 SOUND 2,P=2,10,15

80 SOUND 3,P+3,10,15

90 NEXT P

100 NEXT L

*end of program*

Thanks,

nate

Share this post


Link to post
Share on other sites

Have you tried cleaning the cart? I have a Centipede cart for the Atari 8-bit that refused to work for a long time, even with basic cleaning. I then decided to dismantle the whole cart, ran an alcohol-covered Q-tip across all the pins, let it dry, and then used a pencil eraser on the pins. Needless to say, the cart hasn't given me a single problem since.

Share this post


Link to post
Share on other sites

Well, the first step is to clean the cartridge connector and the 800's connector. If that doesn't work, take the cart apart and reseat and clean the chips inside. They should be socketed.

 

If that fails. Try another cartridge of the same title. If that still fails. Try the cart in another computer. STILL failing? Then you start reseating the chips in the computer, checking power supplies and other connectors and slots and things. Roughly in that order more or less.

Share this post


Link to post
Share on other sites

Hello everyone, When I first picked up my 800 (not xl), I bought a BASIC cartridge. I doesn't work. When I boot from it, the screen goes blank except for a few lines. When I push system reset the screen gets rid of the lines and shows the ready prompt. But I can only type in one line. When I push return to type in another, the screen goes blank and displays the lines (if I push reset it displays ready). Can anyone help me? Is there a way to fix the cartridge?

This is what I was typing in:

10 PRINT CR$(125)

20 FOR D=1 TO 10000: NEXT D

30 FOR L=1 TO 100

40 FOR P=253 TO 1 STEP -1

50 SOUND 0,P,10,15

60 SOUND 1,P=1,10,15

70 SOUND 2,P=2,10,15

80 SOUND 3,P+3,10,15

90 NEXT P

100 NEXT L

*end of program*

Thanks,

nate

 

I think I may have already done this. Here's an .ATR with binary load Atari BASIC A,B,C. It should work on your 800.

Of course 'BASICON.OBJ" and BASICOFF.OBJ' won't work on an 800/400.

BASICS.zip

Edited by russg

Share this post


Link to post
Share on other sites

The advice about cleaning the cart contact fingers (with an eraser) and the cartridge slot is good advice as is reseating the ROM in the cart. However, instead of alcohol, which always has some concentration of water in it, use something like this. I can vouch for the effective and safe use on lots of electronics, including modern computer motherboards etc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...