Jump to content
-^CrossBow^-

AtariVox+ Few oddities

Recommended Posts

Ok, thanks for the report. Any chance you could test with the 2600 playback utility? With the utility you press the joystick in various directions or press fire, to trigger phrases.

 

Your symptoms - immediate failure on pitch change between phonemes - seems to vary in character from Crossbow's testing, which makes me think we may be looking at 2+ issues. (one electrical fixed by pic removal, one speakjet firmware)

 

Comparing your results with the 2600 utility to Crossbow's results may be instructive. (apples to apples)

Share this post


Link to post
Share on other sites

Ok, thanks for the report. Any chance you could test with the 2600 playback utility? With the utility you press the joystick in various directions or press fire, to trigger phrases.

 

Your symptoms - immediate failure on pitch change between phonemes - seems to vary in character from Crossbow's testing, which makes me think we may be looking at 2+ issues. (one electrical fixed by pic removal, one speakjet firmware)

 

 

Sure... I can test it out this evening.

 

I had tried the utilty in the zip file that plays different sounds with joystick and fire (I must say the Twiki sound is dead on!) I didn't test it out that much, but it seemed okay. I will try out the one linked here tonight and let you know how it goes.

 

BTW, no problems with the different pitch changes on "Man Goes Down"... that appears to play and voice flawlessly.

Share this post


Link to post
Share on other sites

BTW, no problems with the different pitch changes on "Man Goes Down"... that appears to play and voice flawlessly.

Yeah, don't know what to tell you there. The pitch change is simple and documented - just send 2 bytes. Not sure why it would cause an issue with pitch changes in Spell and Speak, on some units.

 

Everything, including Spell and Speak questions, works on mine.

Share this post


Link to post
Share on other sites

Some interesting results... and something I didn't try before. After Spell & Speak... instead of rebooting the AtariVox, I just restarted the ROM instead (remember using Stella here)... and everything worked perfectly again (until I used another "?"). I tried this several times and never once rebooted the avox... so it appears to be temporary until you restart the ROM.

 

As far as the playback utility... I moved it quickly to different positions, hit the fire button quickly, and interrupted phrases, but could not get it to mess up. It did not queue all my movement but just the last phrase I stopped on. I imagine that is working the way you intended. If there is anything else you wanted tested here, let me know.

 

Lastly, I did go back to Spell & Speak again and it responded as stated above. All this without rebooting the avox.

 

When I had the PIC chip, it definitely stayed messed up until I rebooted avox... I know that for sure.

 

What are you using for your testing with Spell & Speak... the original avox or the plus version?

Edited by MissCommand

Share this post


Link to post
Share on other sites

Yeah, those are interesting results. Crossbow was able to reproduce the problem with the same utility, so either your PICectomy fix has helped there, or it's an entirely different problem on his end.

 

I tested the question code extensively when developing S&S, but I'd like to retest when I get a chance. Right now my Harmony is packed up and I've been pulling long shifts at work, so it will have to wait until the weekend.

 

I'm using an AtariVox+.

Share this post


Link to post
Share on other sites

Yes I was also using an AVox+ on an actual 7800 though not through emulation. Again I could get the Avox+ to eventually screw up and reboot itself or go glitchy and stay silent with both a 7800 and 2600 through the test program. But it took A LOT more work to get it to hose up on the 2600 than the 7800 which would do it within a few phrases.

Share this post


Link to post
Share on other sites

Yes I was also using an AVox+ on an actual 7800 though not through emulation. Again I could get the Avox+ to eventually screw up and reboot itself or go glitchy and stay silent with both a 7800 and 2600 through the test program. But it took A LOT more work to get it to hose up on the 2600 than the 7800 which would do it within a few phrases.

 

Yes... when I had the PIC chip and it hit, it was glitchy for my remaining time running the ROM (sounded like R2D2 :grin:), and then if I did not reboot avox and restarted the ROM, it was silent from there on out.

Edited by MissCommand

Share this post


Link to post
Share on other sites
On 1/31/2019 at 10:27 PM, RevEng said:

Yeah, the emulation may also be a factor... so not really apples to apples. :|

Was it ever determined if the Spell & Speak AtariVox pitch change problem was just a problem that happens in emulation? Has anyone else had the same problems as MissCommand?

Share this post


Link to post
Share on other sites

I haven't had my Harmony functional for a while, so I haven't been able to try and recreate the issue.

 

There were testers other than myself when I developed Spell&Speak, and nobody reported this problem. I can't say if it's emulation or what at this point.

Share this post


Link to post
Share on other sites

So..this morning I finally decided to remove the PIC off my Avox+. I don't have a hot air station...(yet), so I clipped the pins in the middle with my flush side cutters. But to do that, I had to remove the sockets for the speakjet and IC2 to the left and right of the PIC to have room to get in there. Got it off and put the speakject and IC2 back in place.

 

And it works 100% without issues so far! At least on Wizard of Wor which, to me was the most important game to have it working on!

 

That PIC is the issue bar none here and even at this years PRGE, all the speech enabled games were using standard AVox units and not the + variant. So... if I really feel I need Vectrex speech ability again, I will simply purchase a second AVox+ unit when they are available again and have it be dedicated for the Vectrex only. 

 

@Albert - how would I go about getting a replacement label that just has the AVox branding on it? Otherwise I might just take a sharpie to my current label to remove the '+' and Vectrex Enhanced underneath it.

 

 

  • Like 5

Share this post


Link to post
Share on other sites
19 hours ago, -^CrossBow^- said:

 

And it works 100% without issues so far! At least on Wizard of Wor which, to me was the most important game to have it working on!

That PIC is the issue bar none here

 

 

  Yep, glad to hear someone else having the same results! Since I removed the PIC several months ago, not a single issue with WOW (or Man Goes Down), which is two I really wanted it to work with.

 

  And now I hear they are working on a new GORF (I think it is Champ Games)... really excited about the speech possibilities with that!😀

  • Like 3

Share this post


Link to post
Share on other sites
On 11/3/2019 at 7:59 AM, MissCommand said:

 

  Yep, glad to hear someone else having the same results! Since I removed the PIC several months ago, not a single issue with WOW (or Man Goes Down), which is two I really wanted it to work with.

We are currently testing a new board design by Richard H. and so far there are no issues!  I'm pretty sure Al is planning on having new AtariVox's in the store sometime soon with this fix.

On 11/3/2019 at 7:59 AM, MissCommand said:

 

  And now I hear they are working on a new GORF (I think it is Champ Games)... really excited about the speech possibilities with that!😀

That is correct!  @Nathan Strum has done most of the graphics and I'm finally getting around to working on the game.  The title screen and Astro Battles screen is looking good so far.  We do plan on adding all the phrases (or most of them depending on space) with AtariVox support too! :D 

 

  • Like 2

Share this post


Link to post
Share on other sites

That would be great if no issues with the new board. I stopped using Vox on my 7800 due to the resets.  Although not every game had a problem. 

Share this post


Link to post
Share on other sites

I'm glad that something of a fix has been found and seemingly confirmed. One thing I am concerned about, although it's sort of already happened, is the schism between vox and vox+ owners. Are we going to have a situation where a game is just not playable with the vox+ unless they make this modification?

 

Knowing that I will never own a Vectrex I'd be happy to risk breaking my current AtariVox cutting pins. I don't actually own any vox compatible games yet because I got it for development and even that is problematic with these issues as I have to keep restarting the vox if I happen to stumble across a combination of sounds / commands / timings / whatever that it doesn't like.

Of the pins on the PIC (shame it's the only chip soldered down) which would need cutting if not all of them if I were to go ahead with this? Of course I'd take full responsibility for my actions in following any advice from this forum regardless of the outcome.

 

 

Share this post


Link to post
Share on other sites
29 minutes ago, SmittyB said:

Of the pins on the PIC (shame it's the only chip soldered down) which would need cutting if not all of them if I were to go ahead with this? Of course I'd take full responsibility for my actions in following any advice from this forum regardless of the outcome.

Well I at first tried to just lift the Vcc and GND pins off the PIC but that wasn't enough to keep it from happening. Obviously the other pins where causing the issues to still happen. So I just removed the whole chip off the board completely. I then grabbed a sharpie and made dots next to the dips switch selections specific to the AtariVox mode of operation. I had one sticker I placed originally inside the case showing which dip switches did what. But now that I'm using it as an Avox only device, I didn't think that needed. 

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, johnnywc said:

We are currently testing a new board design by Richard H. and so far there are no issues!  I'm pretty sure Al is planning on having new AtariVox's in the store sometime soon with this fix.

Have the Atari 7800 titles, Dungeon Stalker and T:ME Salvo, been a part of the testing?  Both titles utilize the voice features of the Vox quite frequently.  There have been mixed results with some not experiencing issues, but many have problems with the speech working properly.

 

Just to ensure all bases are covered, it may be best to test on several different 7800 consoles.  The CO25233-001 and CO25233-002 motherboards as well as C300633.  If possible, testing at least one console from each of the significant serial lines (I.E. EP, ATXX, A1, A3, X) would be ideal.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

If the reset and speech issues have been worked out on current AVox units, what was the fix?
 

Is there a hack or component swap we can make if we have older units?

Share this post


Link to post
Share on other sites
52 minutes ago, nick3092 said:

I see the AtariVox+ is back in stock now. Have the issues been worked out of it? I thought the plan was not to produce more until they were. 

Yes, we're selling a new revision of the AtariVox+ that doesn't have the reset issues with some games.  It is possible to modify the older units to fix this behavior, and early next year I'll describe how people can send them back to have them repaired. 

 

 ..Al

  • Like 4
  • Thanks 3

Share this post


Link to post
Share on other sites
14 hours ago, Albert said:

Yes, we're selling a new revision of the AtariVox+ that doesn't have the reset issues with some games.  It is possible to modify the older units to fix this behavior, and early next year I'll describe how people can send them back to have them repaired. 

 

 ..Al

Oh well...guess I will need to purchase a second one then since I totally removed the PIC off mine and tossed it... (Kosmic Stardust style)

  • Haha 3

Share this post


Link to post
Share on other sites
18 hours ago, Albert said:

Yes, we're selling a new revision of the AtariVox+ that doesn't have the reset issues with some games.  It is possible to modify the older units to fix this behavior, and early next year I'll describe how people can send them back to have them repaired. 

 

 ..Al

Good news, that bug drives me crazy and I can't truly enjoy the Vox because of it. I'll have to get a new one. 

Share this post


Link to post
Share on other sites

I got a new one and I can report that all is good. I wasn't expecting the startup sound to have changed so I was startled when it played the new sound effect.

 

I've found it is possible to garble its speech by sending new commands while it's still playing but unlike before it actually recovers when it's finished. An example being starting Dungeon Stalker quickly, because I'm in PAL land there's no delay from the BIOS so I can have both sounds try to play at the same time.

 

I'm thinking of testing starting speech data with 255,31 which might work to put it into a known state if something interrupts it.

 

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...