Jump to content

Recommended Posts

Looks great. I´m using it with Wine under Mac OS X and it seems to work fine so far.

But I had to copy the default.fnt to another path, because MadStudio wasn´t looking in it´s own subdirectory for it. Could you change that, or make it possible to set the path manually?

 

The same for "Save" - it fails. But "Save as..." works just fine.

Edited by skr

Share this post


Link to post
Share on other sites

Hi skr,

 

thank you for the notes. Great to see it is working under Mac environment. Strange, default.fnt should be looked under bin directory in Win OS, I will check the code. Can you tell me to which path did you put it? Relative to the program I mean. And sure, I can add manual setting of the path.

 

Ok, Save probably has the same issues, which I will also check.

 

Just post here for anything similar, even for features you would like to see in the program.

 

Greetings

Edited by Gury

Share this post


Link to post
Share on other sites

As I use the German GUI, I have to tell you that "Programme" means "Applications" and "Benutzer" means "Users" (not "user", that´s a different one) (under the hood even German GUI uses english, e.g. when using the Terminal)

 

The path to madstudio:

post-21666-0-28611100-1484773240_thumb.png

 

The path to where I had to put "default.fnt" to make it run without error:

post-21666-0-08856500-1484773242_thumb.png

 

The error message, if "default.fnt" is not located in the folder named above.

post-21666-0-12835600-1484773243_thumb.png

 

"Z:" is the root of Macintosh HD. Under Wine, the "C:"-Drive is, errr, somewhere else.

Edited by skr

Share this post


Link to post
Share on other sites

That's very informative and useful explanation. I will think about the ways to make path reading more flexible, taking into account various OS systems and their behaviours.

 

Another solution would be to include default Atari font in resource file, like in the case of color palette, which is integrated in the system. Final way of doing it would be making it possible to manually select such path, as you proposed.

  • Like 1

Share this post


Link to post
Share on other sites

Another small hint: The folder "/Users/<name>/bin" does not exist by default on OS X systems. It has to be created by the user or other programs.

Edited by skr

Share this post


Link to post
Share on other sites

Ok, here is updated version of Mad Studio executable file, which does not require default Atari character set to exist on any path. It is now part of resource file, which is compiled into main program. Also, you can now load default Atari font from main menu in Character set editor (Edit / Set default Atari character set) in case you loaded any custom character set and you want to get default one back.

 

In this editor, by pressing F1 or Ctrl-I you are presented with edit field with some information about path. So, skr, if you are so kind, please post here what you get on Mac OS under Wine. Thank you!

 

Greetz

  • Like 1

Share this post


Link to post
Share on other sites

Thx, Gury, this works great. But... ;)

 

The Text mode 1,2 editor still asks for the fnt-file to be in /Users/<name>/bin/

 

When trying to open or write a file, I get an access violation. Solution for me was to set read and write rights for everyone (not only the user) to the folder, where madstudio.exe is in. Not sure if this can be solved from your side.

 

Another quite annoying thing: The dialogue-windows open under existing windows and therefore are invisible. And as long as they are open, you can´t move the other windows around. But you can hit space or return to confirm whatever the window is asking for. I know that and push the other windows away from the middle of the screen, but that´s not a good solution.

 

F1 and ctrl-I (or cmd-I) do nothing on my system.

Edited by skr

Share this post


Link to post
Share on other sites

What a mistejka tu mejka. I fixed text mode 1 & 2 issue, thanks for the notice. Please confirm if it works now, just click the same link with the program.

 

Did you press F1 in Character set editor? That's where it should work. About dialogue-windows... Does this issue persist in all such windows? I hope this problem exists only in Wine environment. Anyway, I have to check the reason.

Share this post


Link to post
Share on other sites

Can´t confirm text mode 1,2 without new version.

 

F1 works in Character Set Editor, thx. :)

 

For whatever reason, the dialogue windows are in focus, but behind all other windows. And all windows pop up in the middle of the screen. Could be some priority settings. Would be nice to be able to save the windows positions.

Share this post


Link to post
Share on other sites

New executable is on the same url here.

 

Great, good idea about windows, that is on to-do list for the next version. Now for the Character set editor. By pressing F1 or Ctrl-I you get additional memo edit, where some path information appears. That is what I want to see in Mac OS X under Wine on your system. It would be great if you post that information here, thanks for your time.

Share this post


Link to post
Share on other sites

Nice to hear! The screenshot you posted is exactly what I wanted to see, so I can see more detailed information about path specifics on different platforms.

Share this post


Link to post
Share on other sites

Is the latest version available for WINE?

 

Also, does it handle character set editing for ANTIC mode 4?

 

Thanks

Kevin

Share this post


Link to post
Share on other sites

Hi,

 

currently ANTIC mode 4 is not supported, but will be. Latest version for WINE can be found some posts above, but I will check out for issues about opening dialog boxes, which was detected by skr.

Share this post


Link to post
Share on other sites

Another one:

 

When I try to parse, I get an error (see screenshot). So I´ve downloaded the tbparser and set the path manually. That works, but the path isn´t saved. When I start Mad Studio again, all paths are lost. And I could not make MADS parser work.

 

post-21666-0-86869800-1486203981_thumb.png

Share this post


Link to post
Share on other sites

Hi skr,

 

definitely this bug must be fixed, I will check the possibilities to overcome the problem in WINE. I will look at path data you posted above (post #36) and hopefully find the way to properly manipulate the paths and config files in WINE in Mad Studio.

Share this post


Link to post
Share on other sites

I gave it a try and used a PC with a current version of Windows 10.

The windows behave correctly, but the path issue is the same. And out of the box, it doesn´t parse. Get the well known error here, too.

 

post-21666-0-36228600-1486213669_thumb.jpg

Share this post


Link to post
Share on other sites

Strange, basicParser works for me on Win10 out of the box. But you are right, paths are not saved. Ow, my... My head made me believe I have already done that :)

 

Next versions will fix these problems, thanks also to you.

Share this post


Link to post
Share on other sites

Hi,

 

new version of the program can be downloaded here, which includes Antic mode 4 editor.

 

Some notes!

Currently, character editor is in text mode 0, which will be extended to Antic mode 4 later. Also, to make changes to your drawings while you change some character appearance, just move from character editor and all changes will be seen in the main editor.

 

skr, please test the program on your setup as before, to see if there are any path issues left.

 

post-7301-0-49196600-1486579316_thumb.png

 

Greetings

Edited by Gury
  • Like 3

Share this post


Link to post
Share on other sites

Great Gury, the path issues seem to be solved now, everything is working fine so far.

 

Only problem with wine still is windows priority. When I open any editor, the window will pop up in front of all others. If I choose a window in the background, it will stay in the background. So I have to move it around or close the other window(s).

 

If I open a file dialouge, this will pop up in the middle of the screen behind all other windows. In worst case it is invisible, and you can´t move around the other windows, as long as the dialouge window is open. I hit escape then to close the dialouge, that works, as the focus is correctly on the dialouge window. One would expect the current window to have highest priority and be in the foreground, but this is not the case here.

Share this post


Link to post
Share on other sites

Thank you, 777. I am glad you make use of this program. And of course, it is open for new features and any comments, so I will know for missed bugs and what to include in to-do list.

Share this post


Link to post
Share on other sites

Sourcegenerator to ACTION! not Correkt (Grafik 7, picture01.mic) :

 

------------------------------------------------

PROC MAIN()
BYTE I, ; COUNTER >>>>>>>>>>>>>>>>>>>>>counter muss CARD !!!!!!!!!!!!!!!!!
DATA ; BYTE OF DATA
CARD SCR=88 ; SCREEN DISPLAY
BYTE CH=764 ; KEY SCAN REGISTER
GRAPHICS(7+16)
SCR=PEEKC(88)
CLOSE(1)
OPEN(1,"picture01.mic",4,0)
FOR I=0 TO 3839 DO
DATA=GETD(1)
POKEC(SCR+I,DATA)
OD
CLOSE(1) >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> close(1) not here !!!!!!!!!!!!
DATA=GETD(1) POKE(712,DATA)
DATA=GETD(1) POKE(708,DATA)
DATA=GETD(1) POKE(709,DATA)
DATA=GETD(1) POKE(710,DATA)
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>close(1) muss here !!!!!!!!!!!!!!!!!
CH=255
DO UNTIL CH#255 OD CH=255
RETURN
------------------------------------------------
Edited by funkheld

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...